aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-2.6.31/003-squashfs_add_decompressor_framework.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-2.6.31/003-squashfs_add_decompressor_framework.patch')
-rw-r--r--target/linux/generic/patches-2.6.31/003-squashfs_add_decompressor_framework.patch426
1 files changed, 0 insertions, 426 deletions
diff --git a/target/linux/generic/patches-2.6.31/003-squashfs_add_decompressor_framework.patch b/target/linux/generic/patches-2.6.31/003-squashfs_add_decompressor_framework.patch
deleted file mode 100644
index cbfbf53690..0000000000
--- a/target/linux/generic/patches-2.6.31/003-squashfs_add_decompressor_framework.patch
+++ /dev/null
@@ -1,426 +0,0 @@
-From 327fbf47a419befc6bff74f3ca42d2b6f0841903 Mon Sep 17 00:00:00 2001
-From: Phillip Lougher <phillip@lougher.demon.co.uk>
-Date: Tue, 6 Oct 2009 04:04:15 +0100
-Subject: [PATCH] Squashfs: add a decompressor framework
-
-This adds a decompressor framework which allows multiple compression
-algorithms to be cleanly supported.
-
-Also update zlib wrapper and other code to use the new framework.
-
-Signed-off-by: Phillip Lougher <phillip@lougher.demon.co.uk>
----
- fs/squashfs/Makefile | 2 +-
- fs/squashfs/block.c | 6 ++--
- fs/squashfs/decompressor.c | 58 ++++++++++++++++++++++++++++++++++++++++++
- fs/squashfs/decompressor.h | 55 +++++++++++++++++++++++++++++++++++++++
- fs/squashfs/squashfs.h | 14 +++++-----
- fs/squashfs/squashfs_fs_sb.h | 41 +++++++++++++++--------------
- fs/squashfs/super.c | 45 ++++++++++++++++++-------------
- fs/squashfs/zlib_wrapper.c | 17 ++++++++++--
- 8 files changed, 185 insertions(+), 53 deletions(-)
- create mode 100644 fs/squashfs/decompressor.c
- create mode 100644 fs/squashfs/decompressor.h
-
---- a/fs/squashfs/Makefile
-+++ b/fs/squashfs/Makefile
-@@ -4,4 +4,4 @@
-
- obj-$(CONFIG_SQUASHFS) += squashfs.o
- squashfs-y += block.o cache.o dir.o export.o file.o fragment.o id.o inode.o
--squashfs-y += namei.o super.o symlink.o zlib_wrapper.o
-+squashfs-y += namei.o super.o symlink.o zlib_wrapper.o decompressor.o
---- a/fs/squashfs/block.c
-+++ b/fs/squashfs/block.c
-@@ -36,7 +36,7 @@
- #include "squashfs_fs_sb.h"
- #include "squashfs_fs_i.h"
- #include "squashfs.h"
--
-+#include "decompressor.h"
- /*
- * Read the metadata block length, this is stored in the first two
- * bytes of the metadata block.
-@@ -151,8 +151,8 @@ int squashfs_read_data(struct super_bloc
- }
-
- if (compressed) {
-- length = zlib_uncompress(msblk, buffer, bh, b, offset, length,
-- srclength, pages);
-+ length = squashfs_decompress(msblk, buffer, bh, b, offset,
-+ length, srclength, pages);
- if (length < 0)
- goto read_failure;
- } else {
---- /dev/null
-+++ b/fs/squashfs/decompressor.c
-@@ -0,0 +1,58 @@
-+/*
-+ * Squashfs - a compressed read only filesystem for Linux
-+ *
-+ * Copyright (c) 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009
-+ * Phillip Lougher <phillip@lougher.demon.co.uk>
-+ *
-+ * This program is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU General Public License
-+ * as published by the Free Software Foundation; either version 2,
-+ * or (at your option) any later version.
-+ *
-+ * This program is distributed in the hope that it will be useful,
-+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+ * GNU General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU General Public License
-+ * along with this program; if not, write to the Free Software
-+ * Foundation, 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
-+ *
-+ * decompressor.c
-+ */
-+
-+#include <linux/types.h>
-+#include <linux/mutex.h>
-+#include <linux/buffer_head.h>
-+
-+#include "squashfs_fs.h"
-+#include "squashfs_fs_sb.h"
-+#include "squashfs_fs_i.h"
-+#include "decompressor.h"
-+#include "squashfs.h"
-+
-+/*
-+ * This file (and decompressor.h) implements a decompressor framework for
-+ * Squashfs, allowing multiple decompressors to be easily supported
-+ */
-+
-+static const struct squashfs_decompressor squashfs_unknown_comp_ops = {
-+ NULL, NULL, NULL, 0, "unknown", 0
-+};
-+
-+static const struct squashfs_decompressor *decompressor[] = {
-+ &squashfs_zlib_comp_ops,
-+ &squashfs_unknown_comp_ops
-+};
-+
-+
-+const struct squashfs_decompressor *squashfs_lookup_decompressor(int id)
-+{
-+ int i;
-+
-+ for (i = 0; decompressor[i]->id; i++)
-+ if (id == decompressor[i]->id)
-+ break;
-+
-+ return decompressor[i];
-+}
---- /dev/null
-+++ b/fs/squashfs/decompressor.h
-@@ -0,0 +1,55 @@
-+#ifndef DECOMPRESSOR_H
-+#define DECOMPRESSOR_H
-+/*
-+ * Squashfs - a compressed read only filesystem for Linux
-+ *
-+ * Copyright (c) 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009
-+ * Phillip Lougher <phillip@lougher.demon.co.uk>
-+ *
-+ * This program is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU General Public License
-+ * as published by the Free Software Foundation; either version 2,
-+ * or (at your option) any later version.
-+ *
-+ * This program is distributed in the hope that it will be useful,
-+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-+ * GNU General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU General Public License
-+ * along with this program; if not, write to the Free Software
-+ * Foundation, 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
-+ *
-+ * decompressor.h
-+ */
-+
-+struct squashfs_decompressor {
-+ void *(*init)(void);
-+ void (*free)(void *);
-+ int (*decompress)(struct squashfs_sb_info *, void **,
-+ struct buffer_head **, int, int, int, int, int);
-+ int id;
-+ char *name;
-+ int supported;
-+};
-+
-+static inline void *squashfs_decompressor_init(struct squashfs_sb_info *msblk)
-+{
-+ return msblk->decompressor->init();
-+}
-+
-+static inline void squashfs_decompressor_free(struct squashfs_sb_info *msblk,
-+ void *s)
-+{
-+ if (msblk->decompressor)
-+ msblk->decompressor->free(s);
-+}
-+
-+static inline int squashfs_decompress(struct squashfs_sb_info *msblk,
-+ void **buffer, struct buffer_head **bh, int b, int offset, int length,
-+ int srclength, int pages)
-+{
-+ return msblk->decompressor->decompress(msblk, buffer, bh, b, offset,
-+ length, srclength, pages);
-+}
-+#endif
---- a/fs/squashfs/squashfs.h
-+++ b/fs/squashfs/squashfs.h
-@@ -51,6 +51,9 @@ extern struct squashfs_cache_entry *squa
- u64, int);
- extern int squashfs_read_table(struct super_block *, void *, u64, int);
-
-+/* decompressor.c */
-+extern const struct squashfs_decompressor *squashfs_lookup_decompressor(int);
-+
- /* export.c */
- extern __le64 *squashfs_read_inode_lookup_table(struct super_block *, u64,
- unsigned int);
-@@ -70,14 +73,8 @@ extern struct inode *squashfs_iget(struc
- unsigned int);
- extern int squashfs_read_inode(struct inode *, long long);
-
--/* zlib_wrapper.c */
--extern void *zlib_init(void);
--extern void zlib_free(void *);
--extern int zlib_uncompress(struct squashfs_sb_info *, void **,
-- struct buffer_head **, int, int, int, int, int);
--
- /*
-- * Inodes and files operations
-+ * Inodes, files and decompressor operations
- */
-
- /* dir.c */
-@@ -94,3 +91,6 @@ extern const struct inode_operations squ
-
- /* symlink.c */
- extern const struct address_space_operations squashfs_symlink_aops;
-+
-+/* zlib_wrapper.c */
-+extern const struct squashfs_decompressor squashfs_zlib_comp_ops;
---- a/fs/squashfs/squashfs_fs_sb.h
-+++ b/fs/squashfs/squashfs_fs_sb.h
-@@ -52,25 +52,26 @@ struct squashfs_cache_entry {
- };
-
- struct squashfs_sb_info {
-- int devblksize;
-- int devblksize_log2;
-- struct squashfs_cache *block_cache;
-- struct squashfs_cache *fragment_cache;
-- struct squashfs_cache *read_page;
-- int next_meta_index;
-- __le64 *id_table;
-- __le64 *fragment_index;
-- unsigned int *fragment_index_2;
-- struct mutex read_data_mutex;
-- struct mutex meta_index_mutex;
-- struct meta_index *meta_index;
-- void *stream;
-- __le64 *inode_lookup_table;
-- u64 inode_table;
-- u64 directory_table;
-- unsigned int block_size;
-- unsigned short block_log;
-- long long bytes_used;
-- unsigned int inodes;
-+ const struct squashfs_decompressor *decompressor;
-+ int devblksize;
-+ int devblksize_log2;
-+ struct squashfs_cache *block_cache;
-+ struct squashfs_cache *fragment_cache;
-+ struct squashfs_cache *read_page;
-+ int next_meta_index;
-+ __le64 *id_table;
-+ __le64 *fragment_index;
-+ unsigned int *fragment_index_2;
-+ struct mutex read_data_mutex;
-+ struct mutex meta_index_mutex;
-+ struct meta_index *meta_index;
-+ void *stream;
-+ __le64 *inode_lookup_table;
-+ u64 inode_table;
-+ u64 directory_table;
-+ unsigned int block_size;
-+ unsigned short block_log;
-+ long long bytes_used;
-+ unsigned int inodes;
- };
- #endif
---- a/fs/squashfs/super.c
-+++ b/fs/squashfs/super.c
-@@ -41,27 +41,35 @@
- #include "squashfs_fs_sb.h"
- #include "squashfs_fs_i.h"
- #include "squashfs.h"
-+#include "decompressor.h"
-
- static struct file_system_type squashfs_fs_type;
- static struct super_operations squashfs_super_ops;
-
--static int supported_squashfs_filesystem(short major, short minor, short comp)
-+static const struct squashfs_decompressor *supported_squashfs_filesystem(short
-+ major, short minor, short id)
- {
-+ const struct squashfs_decompressor *decompressor;
-+
- if (major < SQUASHFS_MAJOR) {
- ERROR("Major/Minor mismatch, older Squashfs %d.%d "
- "filesystems are unsupported\n", major, minor);
-- return -EINVAL;
-+ return NULL;
- } else if (major > SQUASHFS_MAJOR || minor > SQUASHFS_MINOR) {
- ERROR("Major/Minor mismatch, trying to mount newer "
- "%d.%d filesystem\n", major, minor);
- ERROR("Please update your kernel\n");
-- return -EINVAL;
-+ return NULL;
- }
-
-- if (comp != ZLIB_COMPRESSION)
-- return -EINVAL;
-+ decompressor = squashfs_lookup_decompressor(id);
-+ if (!decompressor->supported) {
-+ ERROR("Filesystem uses \"%s\" compression. This is not "
-+ "supported\n", decompressor->name);
-+ return NULL;
-+ }
-
-- return 0;
-+ return decompressor;
- }
-
-
-@@ -86,10 +94,6 @@ static int squashfs_fill_super(struct su
- }
- msblk = sb->s_fs_info;
-
-- msblk->stream = zlib_init();
-- if (msblk->stream == NULL)
-- goto failure;
--
- sblk = kzalloc(sizeof(*sblk), GFP_KERNEL);
- if (sblk == NULL) {
- ERROR("Failed to allocate squashfs_super_block\n");
-@@ -116,25 +120,25 @@ static int squashfs_fill_super(struct su
- goto failed_mount;
- }
-
-+ err = -EINVAL;
-+
- /* Check it is a SQUASHFS superblock */
- sb->s_magic = le32_to_cpu(sblk->s_magic);
- if (sb->s_magic != SQUASHFS_MAGIC) {
- if (!silent)
- ERROR("Can't find a SQUASHFS superblock on %s\n",
- bdevname(sb->s_bdev, b));
-- err = -EINVAL;
- goto failed_mount;
- }
-
-- /* Check the MAJOR & MINOR versions and compression type */
-- err = supported_squashfs_filesystem(le16_to_cpu(sblk->s_major),
-+ /* Check the MAJOR & MINOR versions and lookup compression type */
-+ msblk->decompressor = supported_squashfs_filesystem(
-+ le16_to_cpu(sblk->s_major),
- le16_to_cpu(sblk->s_minor),
- le16_to_cpu(sblk->compression));
-- if (err < 0)
-+ if (msblk->decompressor == NULL)
- goto failed_mount;
-
-- err = -EINVAL;
--
- /*
- * Check if there's xattrs in the filesystem. These are not
- * supported in this version, so warn that they will be ignored.
-@@ -201,6 +205,10 @@ static int squashfs_fill_super(struct su
-
- err = -ENOMEM;
-
-+ msblk->stream = squashfs_decompressor_init(msblk);
-+ if (msblk->stream == NULL)
-+ goto failed_mount;
-+
- msblk->block_cache = squashfs_cache_init("metadata",
- SQUASHFS_CACHED_BLKS, SQUASHFS_METADATA_SIZE);
- if (msblk->block_cache == NULL)
-@@ -288,7 +296,7 @@ failed_mount:
- squashfs_cache_delete(msblk->block_cache);
- squashfs_cache_delete(msblk->fragment_cache);
- squashfs_cache_delete(msblk->read_page);
-- zlib_free(msblk->stream);
-+ squashfs_decompressor_free(msblk, msblk->stream);
- kfree(msblk->inode_lookup_table);
- kfree(msblk->fragment_index);
- kfree(msblk->id_table);
-@@ -298,7 +306,6 @@ failed_mount:
- return err;
-
- failure:
-- zlib_free(msblk->stream);
- kfree(sb->s_fs_info);
- sb->s_fs_info = NULL;
- return -ENOMEM;
-@@ -342,7 +349,7 @@ static void squashfs_put_super(struct su
- squashfs_cache_delete(sbi->block_cache);
- squashfs_cache_delete(sbi->fragment_cache);
- squashfs_cache_delete(sbi->read_page);
-- zlib_free(sbi->stream);
-+ squashfs_decompressor_free(sbi, sbi->stream);
- kfree(sbi->id_table);
- kfree(sbi->fragment_index);
- kfree(sbi->meta_index);
---- a/fs/squashfs/zlib_wrapper.c
-+++ b/fs/squashfs/zlib_wrapper.c
-@@ -30,8 +30,9 @@
- #include "squashfs_fs_sb.h"
- #include "squashfs_fs_i.h"
- #include "squashfs.h"
-+#include "decompressor.h"
-
--void *zlib_init()
-+static void *zlib_init(void)
- {
- z_stream *stream = kmalloc(sizeof(z_stream), GFP_KERNEL);
- if (stream == NULL)
-@@ -50,7 +51,7 @@ failed:
- }
-
-
--void zlib_free(void *strm)
-+static void zlib_free(void *strm)
- {
- z_stream *stream = strm;
-
-@@ -60,7 +61,7 @@ void zlib_free(void *strm)
- }
-
-
--int zlib_uncompress(struct squashfs_sb_info *msblk, void **buffer,
-+static int zlib_uncompress(struct squashfs_sb_info *msblk, void **buffer,
- struct buffer_head **bh, int b, int offset, int length, int srclength,
- int pages)
- {
-@@ -137,3 +138,13 @@ release_mutex:
-
- return -EIO;
- }
-+
-+const struct squashfs_decompressor squashfs_zlib_comp_ops = {
-+ .init = zlib_init,
-+ .free = zlib_free,
-+ .decompress = zlib_uncompress,
-+ .id = ZLIB_COMPRESSION,
-+ .name = "zlib",
-+ .supported = 1
-+};
-+