aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/files/arch/mips/ath79
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/files/arch/mips/ath79')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt27
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile2
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-domywifi-dw33d.c187
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-e2100l.c126
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h2
5 files changed, 344 insertions, 0 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 52b9b5527e..2e0145cbb5 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -512,6 +512,22 @@ config ATH79_MACH_DLAN_PRO_1200_AC
select ATH79_DEV_NFC
select ATH79_DEV_USB
+config ATH79_MACH_DOMYWIFI_DW33D
+ bool "DomyWifi DW33D support"
+ select SOC_QCA955X
+ select ATH79_DEV_AP9X_PCI if PCI
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_NFC
+ select ATH79_DEV_WMAC
+ select ATH79_DEV_USB
+ select MTD_NAND
+ select MTD_NAND_ECC
+ select MTD_NAND_AR934X
+ select MTD_NAND_AR934X_HW_ECC
+
config ATH79_MACH_DR344
bool "Wallys DR344 board support"
select SOC_AS934X
@@ -681,6 +697,17 @@ config ATH79_MACH_WRT160NL
select ATH79_DEV_WMAC
select ATH79_NVRAM
+config ATH79_MACH_E2100L
+ bool "Linksys E2100L board support"
+ select SOC_AR913X
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+ select ATH79_NVRAM
+
config ATH79_MACH_WRT400N
bool "Linksys WRT400N board support"
select SOC_AR71XX
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index f8b0b2bb5a..d8f1b32d62 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -79,6 +79,7 @@ obj-$(CONFIG_ATH79_MACH_DIR_615_C1) += mach-dir-615-c1.o
obj-$(CONFIG_ATH79_MACH_DIR_615_I1) += mach-dir-615-i1.o
obj-$(CONFIG_ATH79_MACH_DIR_825_B1) += mach-dir-825-b1.o
obj-$(CONFIG_ATH79_MACH_DIR_825_C1) += mach-dir-825-c1.o
+obj-$(CONFIG_ATH79_MACH_DOMYWIFI_DW33D) += mach-domywifi-dw33d.o
obj-$(CONFIG_ATH79_MACH_DR344) += mach-dr344.o
obj-$(CONFIG_ATH79_MACH_DRAGINO2) += mach-dragino2.o
obj-$(CONFIG_ATH79_MACH_ESR900) += mach-esr900.o
@@ -194,6 +195,7 @@ obj-$(CONFIG_ATH79_MACH_WPJ344) += mach-wpj344.o
obj-$(CONFIG_ATH79_MACH_WPJ531) += mach-wpj531.o
obj-$(CONFIG_ATH79_MACH_WPJ558) += mach-wpj558.o
obj-$(CONFIG_ATH79_MACH_WRT160NL) += mach-wrt160nl.o
+obj-$(CONFIG_ATH79_MACH_E2100L) += mach-e2100l.o
obj-$(CONFIG_ATH79_MACH_WRT400N) += mach-wrt400n.o
obj-$(CONFIG_ATH79_MACH_WRTNODE2Q) += mach-wrtnode2q.o
obj-$(CONFIG_ATH79_MACH_WZR_HP_G300NH) += mach-wzr-hp-g300nh.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-domywifi-dw33d.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-domywifi-dw33d.c
new file mode 100644
index 0000000000..52d9da4792
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-domywifi-dw33d.c
@@ -0,0 +1,187 @@
+/*
+ * DomyWifi DW33D support
+ *
+ * Copyright (c) 2012 Qualcomm Atheros
+ * Copyright (c) 2012-2013 Gabor Juhos <juhosg@openwrt.org>
+ *
+ * Permission to use, copy, modify, and/or distribute this software for any
+ * purpose with or without fee is hereby granted, provided that the above
+ * copyright notice and this permission notice appear in all copies.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ *
+ */
+
+#include <linux/platform_device.h>
+#include <linux/ar8216_platform.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/nand.h>
+#include <linux/platform/ar934x_nfc.h>
+
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "pci.h"
+#include "dev-ap9x-pci.h"
+#include "dev-gpio-buttons.h"
+#include "dev-eth.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-nfc.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define DW33D_GPIO_LED_MMC 4
+#define DW33D_GPIO_LED_WLAN_2G 13
+#define DW33D_GPIO_LED_STATUS 14
+#define DW33D_GPIO_LED_USB 15
+#define DW33D_GPIO_LED_INTERNET 22
+
+#define DW33D_GPIO_BTN_RESET 17
+
+#define DW33D_KEYS_POLL_INTERVAL 20 /* msecs */
+#define DW33D_KEYS_DEBOUNCE_INTERVAL (3 * DW33D_KEYS_POLL_INTERVAL)
+
+#define DW33D_MAC0_OFFSET 0
+#define DW33D_MAC1_OFFSET 6
+#define DW33D_WMAC_OFFSET 12
+#define DW33D_WMAC_CALDATA_OFFSET 0x1000
+#define DW33D_PCIE_CALDATA_OFFSET 0x5000
+
+static struct gpio_led dw33d_leds_gpio[] __initdata = {
+ {
+ .name = "dw33d:blue:status",
+ .gpio = DW33D_GPIO_LED_STATUS,
+ .active_low = 1,
+ },
+ {
+ .name = "dw33d:blue:mmc",
+ .gpio = DW33D_GPIO_LED_MMC,
+ .active_low = 1,
+ },
+ {
+ .name = "dw33d:blue:usb",
+ .gpio = DW33D_GPIO_LED_USB,
+ .active_low = 1,
+ },
+ {
+ .name = "dw33d:blue:wlan-2g",
+ .gpio = DW33D_GPIO_LED_WLAN_2G,
+ .active_low = 1,
+ },
+ {
+ .name = "dw33d:blue:internet",
+ .gpio = DW33D_GPIO_LED_INTERNET,
+ .active_low = 1,
+ }
+};
+
+static struct gpio_keys_button dw33d_gpio_keys[] __initdata = {
+ {
+ .desc = "Reset button",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = DW33D_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = DW33D_GPIO_BTN_RESET,
+ .active_low = 1,
+ }
+};
+
+/* GMAC6 of the QCA8337 switch is connected to the QCA9558 SoC via SGMII */
+static struct ar8327_pad_cfg dw33d_qca8337_pad6_cfg = {
+ .mode = AR8327_PAD_MAC_SGMII,
+ .sgmii_delay_en = true,
+};
+
+/* GMAC0 of the QCA8337 switch is connected to the QCA9558 SoC via RGMII */
+static struct ar8327_pad_cfg dw33d_qca8337_pad0_cfg = {
+ .mode = AR8327_PAD_MAC_RGMII,
+ .txclk_delay_en = true,
+ .rxclk_delay_en = true,
+ .txclk_delay_sel = AR8327_CLK_DELAY_SEL1,
+ .rxclk_delay_sel = AR8327_CLK_DELAY_SEL2,
+};
+
+static struct ar8327_platform_data dw33d_qca8337_data = {
+ .pad0_cfg = &dw33d_qca8337_pad0_cfg,
+ .pad6_cfg = &dw33d_qca8337_pad6_cfg,
+ .port0_cfg = {
+ .force_link = 1,
+ .speed = AR8327_PORT_SPEED_1000,
+ .duplex = 1,
+ .txpause = 1,
+ .rxpause = 1,
+ },
+ .port6_cfg = {
+ .force_link = 1,
+ .speed = AR8327_PORT_SPEED_1000,
+ .duplex = 1,
+ .txpause = 1,
+ .rxpause = 1,
+ },
+};
+
+static struct mdio_board_info dw33d_mdio0_info[] = {
+ {
+ .bus_id = "ag71xx-mdio.0",
+ .phy_addr = 0,
+ .platform_data = &dw33d_qca8337_data,
+ },
+};
+
+static void __init dw33d_setup(void)
+{
+ u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
+
+ ath79_register_m25p80(NULL);
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(dw33d_leds_gpio),
+ dw33d_leds_gpio);
+ ath79_register_gpio_keys_polled(-1, DW33D_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(dw33d_gpio_keys),
+ dw33d_gpio_keys);
+
+ ath79_register_usb();
+ ath79_nfc_set_ecc_mode(AR934X_NFC_ECC_HW);
+ ath79_register_nfc();
+ ath79_register_pci();
+
+ ath79_register_wmac(art + DW33D_WMAC_CALDATA_OFFSET, art + DW33D_WMAC_OFFSET);
+
+ ath79_setup_qca955x_eth_cfg(QCA955X_ETH_CFG_RGMII_EN);
+
+ ath79_register_mdio(0, 0x0);
+
+ ath79_init_mac(ath79_eth0_data.mac_addr, art + DW33D_MAC0_OFFSET, 0);
+ ath79_init_mac(ath79_eth1_data.mac_addr, art + DW33D_MAC1_OFFSET, 0);
+
+ mdiobus_register_board_info(dw33d_mdio0_info,
+ ARRAY_SIZE(dw33d_mdio0_info));
+
+ /* GMAC0 is connected to the RMGII interface */
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+ ath79_eth0_data.phy_mask = BIT(0);
+ ath79_eth0_data.mii_bus_dev = &ath79_mdio0_device.dev;
+ ath79_eth0_pll_data.pll_1000 = 0x56000000;
+
+ ath79_register_eth(0);
+
+ /* GMAC1 is connected tot eh SGMII interface */
+ ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_SGMII;
+ ath79_eth1_data.speed = SPEED_1000;
+ ath79_eth1_data.duplex = DUPLEX_FULL;
+ ath79_eth1_pll_data.pll_1000 = 0x03000101;
+
+ ath79_register_eth(1);
+}
+
+MIPS_MACHINE(ATH79_MACH_DOMYWIFI_DW33D, "DW33D",
+ "DomyWifi DW33D",
+ dw33d_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-e2100l.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-e2100l.c
new file mode 100644
index 0000000000..c09083460e
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-e2100l.c
@@ -0,0 +1,126 @@
+/*
+ * Linksys E2100L board support
+ *
+ * Copyright (C) 2009-2012 Gabor Juhos <juhosg@openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <asm/mach-ath79/ath79.h>
+
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "nvram.h"
+#include "machtypes.h"
+
+#define E2100L_GPIO_LED_POWER 14
+#define E2100L_GPIO_LED_WPS_AMBER 9
+#define E2100L_GPIO_LED_WPS_BLUE 8
+#define E2100L_GPIO_LED_WLAN 6
+
+#define E2100L_GPIO_BTN_WPS 7
+#define E2100L_GPIO_BTN_RESET 21
+
+#define E2100L_KEYS_POLL_INTERVAL 20 /* msecs */
+#define E2100L_KEYS_DEBOUNCE_INTERVAL (3 * E2100L_KEYS_POLL_INTERVAL)
+
+#define E2100L_NVRAM_ADDR 0x1f7e0000
+#define E2100L_NVRAM_SIZE 0x10000
+
+static const char *e2100l_part_probes[] = {
+ "cybertan",
+ NULL,
+};
+
+static struct flash_platform_data e2100l_flash_data = {
+ .part_probes = e2100l_part_probes,
+};
+
+static struct gpio_led e2100l_leds_gpio[] __initdata = {
+ {
+ .name = "e2100l:blue:power",
+ .gpio = E2100L_GPIO_LED_POWER,
+ .active_low = 1,
+ .default_trigger = "default-on",
+ }, {
+ .name = "e2100l:amber:wps",
+ .gpio = E2100L_GPIO_LED_WPS_AMBER,
+ .active_low = 1,
+ }, {
+ .name = "e2100l:blue:wps",
+ .gpio = E2100L_GPIO_LED_WPS_BLUE,
+ .active_low = 1,
+ }, {
+ .name = "e2100l:blue:wlan",
+ .gpio = E2100L_GPIO_LED_WLAN,
+ .active_low = 1,
+ }
+};
+
+static struct gpio_keys_button e2100l_gpio_keys[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = E2100L_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = E2100L_GPIO_BTN_RESET,
+ .active_low = 1,
+ }, {
+ .desc = "wps",
+ .type = EV_KEY,
+ .code = KEY_WPS_BUTTON,
+ .debounce_interval = E2100L_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = E2100L_GPIO_BTN_WPS,
+ .active_low = 1,
+ }
+};
+
+static void __init e2100l_setup(void)
+{
+ const char *nvram = (char *) KSEG1ADDR(E2100L_NVRAM_ADDR);
+ u8 *eeprom = (u8 *) KSEG1ADDR(0x1fff1000);
+ u8 mac[6];
+
+ if (ath79_nvram_parse_mac_addr(nvram, E2100L_NVRAM_SIZE,
+ "lan_hwaddr=", mac) == 0) {
+ ath79_init_mac(ath79_eth0_data.mac_addr, mac, 0);
+ ath79_init_mac(ath79_eth1_data.mac_addr, mac, 1);
+ }
+
+ ath79_register_mdio(0, 0x0);
+
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RMII;
+ ath79_eth0_data.phy_mask = 0x01;
+
+ ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_RMII;
+ ath79_eth1_data.phy_mask = 0x10;
+
+ ath79_register_eth(0);
+ ath79_register_eth(1);
+
+ ath79_register_m25p80(&e2100l_flash_data);
+
+ ath79_register_usb();
+
+ if (ath79_nvram_parse_mac_addr(nvram, E2100L_NVRAM_SIZE,
+ "wl0_hwaddr=", mac) == 0)
+ ath79_register_wmac(eeprom, mac);
+ else
+ ath79_register_wmac(eeprom, NULL);
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(e2100l_leds_gpio),
+ e2100l_leds_gpio);
+
+ ath79_register_gpio_keys_polled(-1, E2100L_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(e2100l_gpio_keys),
+ e2100l_gpio_keys);
+}
+
+MIPS_MACHINE(ATH79_MACH_E2100L, "E2100L", "Linksys E2100L",
+ e2100l_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index f40b4a43b5..2a6c61513f 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -71,6 +71,7 @@ enum ath79_mach_type {
ATH79_MACH_DLAN_HOTSPOT, /* devolo dLAN Hotspot */
ATH79_MACH_DLAN_PRO_500_WP, /* devolo dLAN pro 500 Wireless+ */
ATH79_MACH_DLAN_PRO_1200_AC, /* devolo dLAN pro 1200+ WiFi ac*/
+ ATH79_MACH_DOMYWIFI_DW33D, /* DomyWifi DW33D */
ATH79_MACH_DR344, /* Wallys DR344 */
ATH79_MACH_DRAGINO2, /* Dragino Version 2 */
ATH79_MACH_ESR900, /* EnGenius ESR900 */
@@ -255,6 +256,7 @@ enum ath79_mach_type {
ATH79_MACH_WPJ531, /* Compex WPJ531 */
ATH79_MACH_WPJ558, /* Compex WPJ558 */
ATH79_MACH_WRT160NL, /* Linksys WRT160NL */
+ ATH79_MACH_E2100L, /* Linksys E2100L */
ATH79_MACH_WRT400N, /* Linksys WRT400N */
ATH79_MACH_WRTNODE2Q, /* WRTnode2Q */
ATH79_MACH_WZR_HP_AG300H, /* Buffalo WZR-HP-AG300H */