aboutsummaryrefslogtreecommitdiffstats
path: root/package/rrdtool1
diff options
context:
space:
mode:
Diffstat (limited to 'package/rrdtool1')
-rw-r--r--package/rrdtool1/Config.in75
-rw-r--r--package/rrdtool1/Makefile105
-rw-r--r--package/rrdtool1/ipkg/librrd1.control18
-rw-r--r--package/rrdtool1/ipkg/rrdcgi1.control19
-rw-r--r--package/rrdtool1/ipkg/rrdtool1.control18
5 files changed, 0 insertions, 235 deletions
diff --git a/package/rrdtool1/Config.in b/package/rrdtool1/Config.in
deleted file mode 100644
index e79df5b4aa..0000000000
--- a/package/rrdtool1/Config.in
+++ /dev/null
@@ -1,75 +0,0 @@
-config BR2_COMPILE_RRDTOOL1
- prompt "rrdtool1.......................... Round Robin Database (RRD) tools (v1.0.x)"
- tristate
- default m if CONFIG_DEVEL
-
-config BR2_PACKAGE_LIBRRD1
- prompt "librrd1......................... Round Robin Database (RRD) management library (v1.0.x)"
- tristate
- default m if CONFIG_DEVEL
- depends BR2_COMPILE_RRDTOOL1
- select BR2_PACKAGE_ZLIB
- help
- RRD is the Acronym for Round Robin Database. RRD is a system to store and
- display time-series data (i.e. network bandwidth, machine-room temperature,
- server load average). It stores the data in a very compact way that will
- not expand over time, and it presents useful graphs by processing the data
- to enforce a certain data density. It can be used either via simple wrapper
- scripts (from shell or Perl) or via frontends that poll network devices and
- put friendly user interface on it.
-
- http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/
-
- This package contains command line tools used to manage RRDs.
-
- This is version 1.0.x with cgilib-0.4, gd1.3 and libpng-1.0.9 linked into
- librrd.so. The library is much smaller compared to the 1.2.x version with
- separate dynamic linked libraries.
-
-config BR2_PACKAGE_RRDCGI1
- prompt "rrdcgi1......................... Round Robin Database (RRD) CGI graphing tool (v1.0.x)"
- tristate
- default m if CONFIG_DEVEL
- depends BR2_COMPILE_RRDTOOL1
- select BR2_PACKAGE_LIBRRD1
- help
- RRD is the Acronym for Round Robin Database. RRD is a system to store and
- display time-series data (i.e. network bandwidth, machine-room temperature,
- server load average). It stores the data in a very compact way that will
- not expand over time, and it presents useful graphs by processing the data
- to enforce a certain data density. It can be used either via simple wrapper
- scripts (from shell or Perl) or via frontends that poll network devices and
- put friendly user interface on it.
-
- http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/
-
- This package contains the rrdcgi tool used to create web pages containing
- RRD graphs based on templates.
-
- This is version 1.0.x with cgilib-0.4, gd1.3 and libpng-1.0.9 linked into
- librrd.so. The library is much smaller compared to the 1.2.x version with
- separate dynamic linked libraries.
-
-config BR2_PACKAGE_RRDTOOL1
- prompt "rrdtool1........................ Round Robin Database (RRD) management tools (v1.0.x)"
- tristate
- default m if CONFIG_DEVEL
- depends BR2_COMPILE_RRDTOOL1
- select BR2_PACKAGE_LIBRRD1
- help
- RRD is the Acronym for Round Robin Database. RRD is a system to store and
- display time-series data (i.e. network bandwidth, machine-room temperature,
- server load average). It stores the data in a very compact way that will
- not expand over time, and it presents useful graphs by processing the data
- to enforce a certain data density. It can be used either via simple wrapper
- scripts (from shell or Perl) or via frontends that poll network devices and
- put friendly user interface on it.
-
- http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/
-
- This package contains command line tools used to manage RRDs.
-
- This is version 1.0.x with cgilib-0.4, gd1.3 and libpng-1.0.9 linked into
- librrd.so. The library is much smaller compared to the 1.2.x version with
- separate dynamic linked libraries.
-
diff --git a/package/rrdtool1/Makefile b/package/rrdtool1/Makefile
deleted file mode 100644
index b0eb9fcc71..0000000000
--- a/package/rrdtool1/Makefile
+++ /dev/null
@@ -1,105 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=rrdtool1
-PKG_VERSION:=1.0.50
-PKG_RELEASE:=1
-PKG_MD5SUM:=c466e2e7df95fa8e318e46437da87686
-
-PKG_SOURCE_URL:=http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/pub/rrdtool-1.0.x
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/rrdtool-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,LIBRRD1,librrd1,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,RRDCGI1,rrdcgi1,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,RRDTOOL1,rrdtool1,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.{status,cache} ; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
- ac_cv_path_PERL=no \
- rd_cv_ieee_works=yes \
- shrext_cmds=".so" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- --enable-shared=yes \
- --enable-static=yes \
- --disable-rpath \
- --with-gnu-ld \
- --enable-local-zlib \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- shrext_cmds=".so" \
- all install
- touch $@
-
-$(IPKG_RRDTOOL1):
- install -d -m0755 $(IDIR_RRDTOOL1)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/rrdtool $(IDIR_RRDTOOL1)/usr/bin/
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/rrdupdate $(IDIR_RRDTOOL1)/usr/bin/
- $(RSTRIP) $(IDIR_RRDTOOL1)
- $(IPKG_BUILD) $(IDIR_RRDTOOL1) $(PACKAGE_DIR)
-
-$(IPKG_RRDCGI1):
- install -d -m0755 $(IDIR_RRDCGI1)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/rrdcgi $(IDIR_RRDCGI1)/usr/bin/
- $(RSTRIP) $(IDIR_RRDCGI1)
- $(IPKG_BUILD) $(IDIR_RRDCGI1) $(PACKAGE_DIR)
-
-$(IPKG_LIBRRD1):
- install -d -m0755 $(IDIR_LIBRRD1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/librrd.so.* $(IDIR_LIBRRD1)/usr/lib/
- $(RSTRIP) $(IDIR_LIBRRD1)
- $(IPKG_BUILD) $(IDIR_LIBRRD1) $(PACKAGE_DIR)
-
-$(STAGING_DIR)/usr/lib/librrd.so: $(PKG_BUILD_DIR)/.built
- mkdir -p $(STAGING_DIR)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/rrd.h $(STAGING_DIR)/usr/include/
- mkdir -p $(STAGING_DIR)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/librrd.a $(STAGING_DIR)/usr/lib/
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/librrd.so* $(STAGING_DIR)/usr/lib/
- touch $@
-
-install-dev: $(STAGING_DIR)/usr/lib/librrd.so
-
-uninstall-dev:
- rm -rf \
- $(STAGING_DIR)/usr/include/rrd.h \
- $(STAGING_DIR)/usr/lib/librrd.a \
- $(STAGING_DIR)/usr/lib/librrd.so* \
-
-compile-targets: install-dev
-clean-targets: uninstall-dev
diff --git a/package/rrdtool1/ipkg/librrd1.control b/package/rrdtool1/ipkg/librrd1.control
deleted file mode 100644
index 1c0494c90a..0000000000
--- a/package/rrdtool1/ipkg/librrd1.control
+++ /dev/null
@@ -1,18 +0,0 @@
-Package: librrd1
-Priority: optional
-Section: libs
-Depends: zlib
-Description: Round Robin Database (RRD) management library.
- RRD is the Acronym for Round Robin Database. RRD is a system to store and
- display time-series data (i.e. network bandwidth, machine-room temperature,
- server load average). It stores the data in a very compact way that will
- not expand over time, and it presents useful graphs by processing the data
- to enforce a certain data density. It can be used either via simple wrapper
- scripts (from shell or Perl) or via frontends that poll network devices and
- put friendly user interface on it.
- .
- This package contains the shared library used to manage RRDs.
- .
- This is version 1.0.x with cgilib-0.4, gd1.3 and libpng-1.0.9 linked into
- librrd.so. The library is much smaller compared to the 1.2.x version with
- separate dynamic linked libraries.
diff --git a/package/rrdtool1/ipkg/rrdcgi1.control b/package/rrdtool1/ipkg/rrdcgi1.control
deleted file mode 100644
index 330f77a3ad..0000000000
--- a/package/rrdtool1/ipkg/rrdcgi1.control
+++ /dev/null
@@ -1,19 +0,0 @@
-Package: rrdcgi1
-Priority: optional
-Section: web
-Depends: librrd1
-Description: Round Robin Database (RRD) CGI graphing tool.
- RRD is the Acronym for Round Robin Database. RRD is a system to store and
- display time-series data (i.e. network bandwidth, machine-room temperature,
- server load average). It stores the data in a very compact way that will
- not expand over time, and it presents useful graphs by processing the data
- to enforce a certain data density. It can be used either via simple wrapper
- scripts (from shell or Perl) or via frontends that poll network devices and
- put friendly user interface on it.
- .
- This package contains the rrdcgi tool used to create web pages containing
- RRD graphs based on templates.
- .
- This is version 1.0.x with cgilib-0.4, gd1.3 and libpng-1.0.9 linked into
- librrd.so. The library is much smaller compared to the 1.2.x version with
- separate dynamic linked libraries.
diff --git a/package/rrdtool1/ipkg/rrdtool1.control b/package/rrdtool1/ipkg/rrdtool1.control
deleted file mode 100644
index 1bf7eaec3f..0000000000
--- a/package/rrdtool1/ipkg/rrdtool1.control
+++ /dev/null
@@ -1,18 +0,0 @@
-Package: rrdtool1
-Priority: optional
-Section: admin
-Depends: librrd1
-Description: Round Robin Database (RRD) management tools.
- RRD is the Acronym for Round Robin Database. RRD is a system to store and
- display time-series data (i.e. network bandwidth, machine-room temperature,
- server load average). It stores the data in a very compact way that will
- not expand over time, and it presents useful graphs by processing the data
- to enforce a certain data density. It can be used either via simple wrapper
- scripts (from shell or Perl) or via frontends that poll network devices and
- put friendly user interface on it.
- .
- This package contains command line tools used to manage RRDs.
- .
- This is version 1.0.x with cgilib-0.4, gd1.3 and libpng-1.0.9 linked into
- librrd.so. The library is much smaller compared to the 1.2.x version with
- separate dynamic linked libraries.