aboutsummaryrefslogtreecommitdiffstats
path: root/package/quagga
diff options
context:
space:
mode:
Diffstat (limited to 'package/quagga')
-rw-r--r--package/quagga/Config.in66
-rw-r--r--package/quagga/Makefile125
-rw-r--r--package/quagga/files/quagga.init333
-rw-r--r--package/quagga/ipkg/quagga-bgpd.control6
-rw-r--r--package/quagga/ipkg/quagga-ospf6d.control6
-rw-r--r--package/quagga/ipkg/quagga-ospfd.control6
-rw-r--r--package/quagga/ipkg/quagga-ripd.control6
-rw-r--r--package/quagga/ipkg/quagga-ripngd.control6
-rw-r--r--package/quagga/ipkg/quagga-vtysh.control6
-rw-r--r--package/quagga/ipkg/quagga.control6
-rw-r--r--package/quagga/ipkg/quagga.postinst48
-rw-r--r--package/quagga/patches/quagga-cross.patch84
-rw-r--r--package/quagga/patches/quagga-readline.patch58
13 files changed, 0 insertions, 756 deletions
diff --git a/package/quagga/Config.in b/package/quagga/Config.in
deleted file mode 100644
index 758faebf34..0000000000
--- a/package/quagga/Config.in
+++ /dev/null
@@ -1,66 +0,0 @@
-menu "quagga............................ The Quagga Software Routing Suite"
-
-config BR2_PACKAGE_QUAGGA
- prompt "quagga............................ The Quagga Software Routing Suite"
- tristate
- default m if CONFIG_DEVEL
- help
- A routing software package that provides TCP/IP based routing services
- with routing protocols support such as RIPv1, RIPv2, RIPng, OSPFv2,
- OSPFv3, BGP-4, and BGP-4+
-
- http://www.quagga.net/
-
-config BR2_PACKAGE_QUAGGA_BGPD
- prompt "quagga-bgpd..................... BGPv4, BGPv4+, BGPv4- routing engine"
- tristate
- default m if CONFIG_DEVEL
- depends BR2_PACKAGE_QUAGGA
- help
- A BGPv4, BGPv4+, BGPv4- routing engine for use with Quagga routing
- software.
-
-config BR2_PACKAGE_QUAGGA_OSPFD
- prompt "quagga-ospfd.................... OSPFv2 routing engine"
- tristate
- default m if CONFIG_DEVEL
- depends BR2_PACKAGE_QUAGGA
- help
- An OSPFv2 (IPv4) routing engine for use with Quagga routing software.
-
-config BR2_PACKAGE_QUAGGA_OSPF6D
- prompt "quagga-ospf6d................... OSPFv3 routing engine"
- tristate
- default m if CONFIG_DEVEL
- depends BR2_PACKAGE_QUAGGA
- help
- An OSPFv3 (IPv6) routing engine for use with Quagga routing software.
-
-config BR2_PACKAGE_QUAGGA_RIPD
- prompt "quagga-ripd..................... RIP routing engine"
- tristate
- default m if CONFIG_DEVEL
- depends BR2_PACKAGE_QUAGGA
- help
- A RIP (IPv4) routing engine for use with Quagga routing software.
-
-config BR2_PACKAGE_QUAGGA_RIPNGD
- prompt "quagga-ripngd................... RIPNG routing engine"
- tristate
- default m if CONFIG_DEVEL
- depends BR2_PACKAGE_QUAGGA
- help
- A RIPNG (IPv6) routing engine for use with Quagga routing software.
-
-config BR2_PACKAGE_QUAGGA_VTYSH
- prompt "quagga-vtysh.................... integrated shell for Quagga routing software"
- tristate
- default m if CONFIG_DEVEL
- depends BR2_PACKAGE_QUAGGA
- select BR2_PACKAGE_LIBREADLINE
- select BR2_PACKAGE_LIBNCURSES
- help
- vtysh lets you interact with all the Quagga routing daemons
- at once in an integrated shell.
-
-endmenu
diff --git a/package/quagga/Makefile b/package/quagga/Makefile
deleted file mode 100644
index 8b85555807..0000000000
--- a/package/quagga/Makefile
+++ /dev/null
@@ -1,125 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=quagga
-PKG_VERSION:=0.98.5
-PKG_RELEASE:=1
-PKG_MD5SUM:=ec09c1ec624aea98e18aa19282666784
-
-PKG_SOURCE_URL:=http://www.quagga.net/download/ \
- http://www.de.quagga.net/download/ \
- http://www.uk.quagga.net/download/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,QUAGGA,quagga,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,QUAGGA_BGPD,quagga-bgpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,QUAGGA_OSPFD,quagga-ospfd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,QUAGGA_OSPF6D,quagga-ospf6d,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,QUAGGA_RIPD,quagga-ripd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,QUAGGA_RIPNGD,quagga-ripngd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,QUAGGA_VTYSH,quagga-vtysh,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured:
- (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
- LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --sbindir=/usr/sbin \
- --libexecdir=/usr/lib \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var/run/quagga \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc/quagga \
- $(DISABLE_NLS) \
- $(DISABLE_LARGEFILE) \
- --enable-shared \
- --disable-static \
- --enable-ipv6 \
- --enable-vtysh \
- --enable-user=quagga \
- --enable-group=quagga \
- --enable-multipath=8 \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR=$(PKG_INSTALL_DIR) \
- all install
- touch $@
-
-$(IPKG_QUAGGA):
- install -d -m0755 $(IDIR_QUAGGA)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libzebra.so.* $(IDIR_QUAGGA)/usr/lib/
- install -d -m0755 $(IDIR_QUAGGA)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/zebra $(IDIR_QUAGGA)/usr/sbin/
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/watchquagga $(IDIR_QUAGGA)/usr/sbin/
- # avoid /etc being set to 0750
- install -d -m0755 $(IDIR_QUAGGA)/etc/quagga/
- chmod 0750 $(IDIR_QUAGGA)/etc/quagga/
- install -d -m0755 $(IDIR_QUAGGA)/etc/init.d/
- install -m0755 ./files/quagga.init $(IDIR_QUAGGA)/etc/init.d/quagga
- ln -sf quagga $(IDIR_QUAGGA)/etc/init.d/S49quagga
- install -d -m0755 $(IDIR_QUAGGA)/var/run/quagga
- $(RSTRIP) $(IDIR_QUAGGA)
- $(IPKG_BUILD) $(IDIR_QUAGGA) $(PACKAGE_DIR)
-
-$(IPKG_QUAGGA_BGPD):
- install -d -m0755 $(IDIR_QUAGGA_BGPD)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/bgpd $(IDIR_QUAGGA_BGPD)/usr/sbin/
- $(RSTRIP) $(IDIR_QUAGGA_BGPD)
- $(IPKG_BUILD) $(IDIR_QUAGGA_BGPD) $(PACKAGE_DIR)
-
-$(IPKG_QUAGGA_OSPFD):
- install -d -m0755 $(IDIR_QUAGGA_OSPFD)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libospf.so.* $(IDIR_QUAGGA_OSPFD)/usr/lib/
- install -d -m0755 $(IDIR_QUAGGA_OSPFD)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/ospfd $(IDIR_QUAGGA_OSPFD)/usr/sbin/
- $(RSTRIP) $(IDIR_QUAGGA_OSPFD)
- $(IPKG_BUILD) $(IDIR_QUAGGA_OSPFD) $(PACKAGE_DIR)
-
-$(IPKG_QUAGGA_OSPF6D):
- install -d -m0755 $(IDIR_QUAGGA_OSPF6D)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/ospf6d $(IDIR_QUAGGA_OSPF6D)/usr/sbin/
- $(RSTRIP) $(IDIR_QUAGGA_OSPF6D)
- $(IPKG_BUILD) $(IDIR_QUAGGA_OSPF6D) $(PACKAGE_DIR)
-
-$(IPKG_QUAGGA_RIPD):
- install -d -m0755 $(IDIR_QUAGGA_RIPD)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/ripd $(IDIR_QUAGGA_RIPD)/usr/sbin/
- $(RSTRIP) $(IDIR_QUAGGA_RIPD)
- $(IPKG_BUILD) $(IDIR_QUAGGA_RIPD) $(PACKAGE_DIR)
-
-$(IPKG_QUAGGA_RIPNGD):
- install -d -m0755 $(IDIR_QUAGGA_RIPNGD)/usr/sbin
- $(CP) $(PKG_INSTALL_DIR)/usr/sbin/ripngd $(IDIR_QUAGGA_RIPNGD)/usr/sbin/
- $(RSTRIP) $(IDIR_QUAGGA_RIPNGD)
- $(IPKG_BUILD) $(IDIR_QUAGGA_RIPNGD) $(PACKAGE_DIR)
-
-$(IPKG_QUAGGA_VTYSH):
- install -d -m0755 $(IDIR_QUAGGA_VTYSH)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/vtysh $(IDIR_QUAGGA_VTYSH)/usr/bin/
- $(RSTRIP) $(IDIR_QUAGGA_VTYSH)
- $(IPKG_BUILD) $(IDIR_QUAGGA_VTYSH) $(PACKAGE_DIR)
diff --git a/package/quagga/files/quagga.init b/package/quagga/files/quagga.init
deleted file mode 100644
index 01f8d7137d..0000000000
--- a/package/quagga/files/quagga.init
+++ /dev/null
@@ -1,333 +0,0 @@
-#!/bin/sh
-#
-# quagga Starts/stops quagga daemons and watchquagga.
-# Create a daemon.conf file to have that routing daemon
-# started/stopped automagically when using this script
-# without any daemon names as args.
-# If watchquagga is available, it will also be
-# started/stopped if the script is called without
-# any daemon names.
-#
-
-ME=$(basename $0)
-
-usage() {
- echo "Usage: ${ME} {start|stop|restart} [daemon ...]"
- exit 2
-}
-
-if [ -z "$1" ]
-then
- usage
-else
- COMMAND=$1
-fi
-shift
-ARG_DAEMONS=$*
-BINDIR=/usr/sbin
-CONFDIR=/etc/quagga
-STATEDIR=/var/run/quagga
-DAEMONS="zebra ripd ripngd ospfd ospf6d bgpd"
-DAEMON_FLAGS=-d
-WATCHQUAGGA_FLAGS="-d -z -T 60 -R"
-WATCHQUAGGA_CMD="$0 watchrestart"
-if [ ${COMMAND} != "watchrestart" ]
-then
- DAEMONS="${DAEMONS} watchquagga"
-fi
-DAEMONS_STARTSEQ=${DAEMONS}
-
-reverse()
-{
- local revlist r
- revlist=
- for r
- do
- revlist="$r $revlist"
- done
- echo $revlist
-}
-
-DAEMONS_STOPSEQ=$(reverse ${DAEMONS_STARTSEQ})
-
-#pidof() {
-# ps ax | awk 'match($5, "(^|/)'"$1"'$") > 0 { printf " %s", $1 }'
-#}
-
-quit() {
- echo "${ME}: $1"
- exit 0
-}
-
-die() {
- echo "${ME}: $1"
- exit 1
-}
-
-is_in() {
- local i
- for i in $2
- do
- [ "$1" = "$i" ] && return 0
- done
- return 1
-}
-
-select_subset() {
- local unknown i j
- unknown=
- RESULT=
- for i in $1
- do
- is_in $i "$2" || unknown="$unknown $i"
- done
- if [ -n "$unknown" ]
- then
- RESULT=$unknown
- return 1
- else
- for j in $2
- do
- is_in $j "$1" && RESULT="$RESULT $j"
- done
- return 0
- fi
-}
-
-# check command
-
-case ${COMMAND}
-in
- start|stop|restart)
- ;;
- watchrestart)
- if [ -n "$ARG_DAEMONS" ]
- then
- echo "${ME}: watchrestart mode is only for use by watchquagga"
- exit 2
- fi
- ;;
- *)
- usage
- ;;
-esac
-
-# select daemons to start
-
-case ${COMMAND}
-in
- start|restart|watchrestart)
- START_DAEMONS=
- for d in ${DAEMONS_STARTSEQ}
- do
- [ -x "${BINDIR}/${d}" -a -f "${CONFDIR}/${d}.conf" ] \
- && START_DAEMONS="${START_DAEMONS}${d} "
- done
- WATCHQUAGGA_DAEMONS=${START_DAEMONS}
- if is_in watchquagga "${DAEMONS_STARTSEQ}"
- then
- START_DAEMONS="${START_DAEMONS} watchquagga"
- fi
- if [ -n "${ARG_DAEMONS}" ]
- then
- if select_subset "${ARG_DAEMONS}" "${DAEMONS}"
- then
- if select_subset "${ARG_DAEMONS}" "${START_DAEMONS}"
- then
- START_DAEMONS=${RESULT}
- else
- die "these daemons are not startable:${RESULT}."
- fi
- else
- die "unknown daemons:${RESULT}; choose from: ${DAEMONS}."
- fi
- fi
- ;;
-esac
-
-# select daemons to stop
-
-case ${COMMAND}
-in
- stop|restart|watchrestart)
- STOP_DAEMONS=${DAEMONS_STOPSEQ}
- if [ -n "${ARG_DAEMONS}" ]
- then
- if select_subset "${ARG_DAEMONS}" "${STOP_DAEMONS}"
- then
- STOP_DAEMONS=${RESULT}
- else
- die "unknown daemons:${RESULT}; choose from: ${DAEMONS}."
- fi
- fi
- stop_daemons=
- for d in ${STOP_DAEMONS}
- do
- pidfile=${STATEDIR}/${d}.pid
- if [ -f "${pidfile}" -o -n "$(pidof ${d})" ]
- then
- stop_daemons="${stop_daemons}${d} "
- elif [ -n "${ARG_DAEMONS}" ]
- then
- echo "${ME}: found no ${d} process running."
- fi
- done
- STOP_DAEMONS=${stop_daemons}
- ;;
-esac
-
-# stop daemons
-
-for d in $STOP_DAEMONS
-do
- echo -n "${ME}: Stopping ${d} ... "
- pidfile=${STATEDIR}/${d}.pid
- if [ -f "${pidfile}" ]
- then
- file_pid=$(cat ${pidfile})
- if [ -z "${file_pid}" ]
- then
- echo -n "no pid file entry found ... "
- fi
- else
- file_pid=
- echo -n "no pid file found ... "
- fi
- proc_pid=$(pidof ${d})
- if [ -z "${proc_pid}" ]
- then
- echo -n "found no ${d} process running ... "
- else
- count=0
- notinpidfile=
- for p in ${proc_pid}
- do
- count=$((${count}+1))
- if kill ${p}
- then
- echo -n "killed ${p} ... "
- else
- echo -n "failed to kill ${p} ... "
- fi
- [ "${p}" = "${file_pid}" ] \
- || notinpidfile="${notinpidfile} ${p}"
- done
- [ ${count} -le 1 ] \
- || echo -n "WARNING: ${count} ${d} processes were found running ... "
- for n in ${notinpidfile}
- do
- echo -n "WARNING: process ${n} was not in pid file ... "
- done
- fi
- count=0
- survivors=$(pidof ${d})
- while [ -n "${survivors}" ]
- do
- sleep 1
- count=$((${count}+1))
- survivors=$(pidof ${d})
- [ -z "${survivors}" -o ${count} -gt 5 ] && break
- for p in ${survivors}
- do
- sleep 1
- echo -n "${p} "
- kill ${p}
- done
- done
- survivors=$(pidof ${d})
- [ -n "${survivors}" ] && \
- if kill -KILL ${survivors}
- then
- echo -n "KILLed ${survivors} ... "
- else
- echo -n "failed to KILL ${survivors} ... "
- fi
- sleep 1
- survivors=$(pidof ${d})
- if [ -z "${survivors}" ]
- then
- echo -n "done."
- if [ -f "${pidfile}" ]
- then
- rm -f ${pidfile} \
- || echo -n " Failed to remove pidfile."
- fi
- else
- echo -n "failed to stop ${survivors} - giving up."
- if [ "${survivors}" != "${file_pid}" ]
- then
- if echo "${survivors}" > ${pidfile}
- then
- chown quagga:quagga ${pidfile}
- echo -n " Wrote ${survivors} to pidfile."
- else
- echo -n " Failed to write ${survivors} to pidfile."
- fi
- fi
- fi
- echo
-done
-
-# start daemons
-
-if [ -n "$START_DAEMONS" ]
-then
- [ -d ${CONFDIR} ] \
- || quit "${ME}: no config directory ${CONFDIR} - exiting."
- chown -R quagga:quagga ${CONFDIR}
- [ -d ${STATEDIR} ] || mkdir -p ${STATEDIR} \
- || die "${ME}: could not create state directory ${STATEDIR} - exiting."
- chown -R quagga:quagga ${STATEDIR}
-
- for d in $START_DAEMONS
- do
- echo -n "${ME}: Starting ${d} ... "
- proc_pid=$(pidof ${d})
- pidfile=${STATEDIR}/${d}.pid
- file_pid=
- if [ -f "${pidfile}" ]
- then
- file_pid=$(cat ${pidfile})
- if [ -n "${file_pid}" ]
- then
- echo -n "found old pid file entry ${file_pid} ... "
- fi
- fi
- if [ -n "${proc_pid}" ]
- then
- echo -n "found ${d} running (${proc_pid}) - skipping ${d}."
- if [ "${proc_pid}" != "${file_pid}" ]
- then
- if echo "${proc_pid}" > ${pidfile}
- then
- chown quagga:quagga ${pidfile}
- echo -n " Wrote ${proc_pid} to pidfile."
- else
- echo -n " Failed to write ${proc_pid} to pidfile."
- fi
- fi
- elif rm -f "${pidfile}"
- then
- if [ "${d}" = "watchquagga" ]
- then
- $("${BINDIR}/${d}" \
- ${WATCHQUAGGA_FLAGS} \
- "${WATCHQUAGGA_CMD}" \
- ${WATCHQUAGGA_DAEMONS})
- status=$?
- else
- $("${BINDIR}/${d}" ${DAEMON_FLAGS})
- status=$?
- fi
- if [ $status -eq 0 ]
- then
- echo -n "done."
- else
- echo -n "failed."
- fi
- else
- echo -n " failed to remove pidfile."
- fi
- echo
- done
-fi
diff --git a/package/quagga/ipkg/quagga-bgpd.control b/package/quagga/ipkg/quagga-bgpd.control
deleted file mode 100644
index d8e9b80b2c..0000000000
--- a/package/quagga/ipkg/quagga-bgpd.control
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: quagga-bgpd
-Priority: optional
-Section: net
-Depends: quagga
-Description: A BGPv4, BGPv4+, BGPv4- routing engine for use with Quagga
- routing software
diff --git a/package/quagga/ipkg/quagga-ospf6d.control b/package/quagga/ipkg/quagga-ospf6d.control
deleted file mode 100644
index 07cf20582b..0000000000
--- a/package/quagga/ipkg/quagga-ospf6d.control
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: quagga-ospf6d
-Priority: optional
-Section: net
-Depends: quagga
-Description: An OSPFv3 routing engine for use with Quagga
- routing software
diff --git a/package/quagga/ipkg/quagga-ospfd.control b/package/quagga/ipkg/quagga-ospfd.control
deleted file mode 100644
index c9fc77ce81..0000000000
--- a/package/quagga/ipkg/quagga-ospfd.control
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: quagga-ospfd
-Priority: optional
-Section: net
-Depends: quagga
-Description: An OSPFv2 routing engine for use with Quagga
- routing software
diff --git a/package/quagga/ipkg/quagga-ripd.control b/package/quagga/ipkg/quagga-ripd.control
deleted file mode 100644
index e7ff899523..0000000000
--- a/package/quagga/ipkg/quagga-ripd.control
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: quagga-ripd
-Priority: optional
-Section: net
-Depends: quagga
-Description: A RIP routing engine for use with Quagga
- routing software
diff --git a/package/quagga/ipkg/quagga-ripngd.control b/package/quagga/ipkg/quagga-ripngd.control
deleted file mode 100644
index f6b2804c24..0000000000
--- a/package/quagga/ipkg/quagga-ripngd.control
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: quagga-ripngd
-Priority: optional
-Section: net
-Depends: quagga
-Description: A RIPNG routing engine for use with Quagga
- routing software
diff --git a/package/quagga/ipkg/quagga-vtysh.control b/package/quagga/ipkg/quagga-vtysh.control
deleted file mode 100644
index b26d11df33..0000000000
--- a/package/quagga/ipkg/quagga-vtysh.control
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: quagga-vtysh
-Priority: optional
-Section: net
-Depends: quagga, libncurses, libreadline
-Description: integrated shell for interacting with Quagga
- routing software
diff --git a/package/quagga/ipkg/quagga.control b/package/quagga/ipkg/quagga.control
deleted file mode 100644
index 303f299e81..0000000000
--- a/package/quagga/ipkg/quagga.control
+++ /dev/null
@@ -1,6 +0,0 @@
-Package: quagga
-Priority: optional
-Section: net
-Description: A routing software package that provides TCP/IP
- based routing services with routing protocols support such
- as RIPv1, RIPv2, RIPng, OSPFv2, OSPFv3, BGP-4, and BGP-4+.
diff --git a/package/quagga/ipkg/quagga.postinst b/package/quagga/ipkg/quagga.postinst
deleted file mode 100644
index 90ffe61e28..0000000000
--- a/package/quagga/ipkg/quagga.postinst
+++ /dev/null
@@ -1,48 +0,0 @@
-#!/bin/sh
-
-name=quagga
-id=51
-dir=/var/run/quagga
-
-# do not change below
-# check if we are on real system
-if [ -z "${IPKG_INSTROOT}" ]; then
- # create copies of passwd and group, if we use squashfs
- rootfs=`mount |awk '/root/ { print $5 }'`
- if [ "$rootfs" = "squashfs" ]; then
- if [ -h /etc/group ]; then
- rm /etc/group
- cp /rom/etc/group /etc/group
- fi
- if [ -h /etc/passwd ]; then
- rm /etc/passwd
- cp /rom/etc/passwd /etc/passwd
- fi
- fi
-fi
-
-echo ""
-if [ -z "$(grep ^\\${name}: ${IPKG_INSTROOT}/etc/group)" ]; then
- echo "adding group $name to /etc/group"
- echo "${name}:x:${id}:" >> ${IPKG_INSTROOT}/etc/group
-fi
-
-if [ -z "$(grep ^\\${name}: ${IPKG_INSTROOT}/etc/passwd)" ]; then
- echo "adding user $name to /etc/passwd"
- echo "${name}:x:${id}:${id}:${name}:/tmp/.${name}:/bin/false" >> ${IPKG_INSTROOT}/etc/passwd
-fi
-
-grep -q '^zebra[[:space:]]*2601/tcp' ${IPKG_INSTROOT}/etc/services 2>/dev/null
-if [ $? -ne 0 ]; then
-echo "zebrasrv 2600/tcp" >>${IPKG_INSTROOT}/etc/services
-echo "zebra 2601/tcp" >>${IPKG_INSTROOT}/etc/services
-echo "ripd 2602/tcp" >>${IPKG_INSTROOT}/etc/services
-echo "ripngd 2603/tcp" >>${IPKG_INSTROOT}/etc/services
-echo "ospfd 2604/tcp" >>${IPKG_INSTROOT}/etc/services
-echo "bgpd 2605/tcp" >>${IPKG_INSTROOT}/etc/services
-echo "ospf6d 2606/tcp" >>${IPKG_INSTROOT}/etc/services
-echo "ospfapi 2607/tcp" >>${IPKG_INSTROOT}/etc/services
-echo "isisd 2608/tcp" >>${IPKG_INSTROOT}/etc/services
-fi
-
-chown -R $name:$name $dir
diff --git a/package/quagga/patches/quagga-cross.patch b/package/quagga/patches/quagga-cross.patch
deleted file mode 100644
index 5b8276bcc1..0000000000
--- a/package/quagga/patches/quagga-cross.patch
+++ /dev/null
@@ -1,84 +0,0 @@
---- quagga-0.98.4/configure.orig Mon Jun 27 19:05:31 2005
-+++ quagga-0.98.4/configure Mon Jul 11 20:32:07 2005
-@@ -12623,69 +12623,6 @@
-
-
-
--echo "$as_me:$LINENO: checking for broken CMSG_FIRSTHDR" >&5
--echo $ECHO_N "checking for broken CMSG_FIRSTHDR... $ECHO_C" >&6
--if test "$cross_compiling" = yes; then
-- echo "$as_me:$LINENO: result: no" >&5
--echo "${ECHO_T}no" >&6
--else
-- cat >conftest.$ac_ext <<_ACEOF
--/* confdefs.h. */
--_ACEOF
--cat confdefs.h >>conftest.$ac_ext
--cat >>conftest.$ac_ext <<_ACEOF
--/* end confdefs.h. */
--
--#ifdef SUNOS_5
--#define _XPG4_2
--#define __EXTENSIONS__
--#endif
--#include <stdlib.h>
--#include <sys/types.h>
--#include <sys/socket.h>
--
--main()
--{
-- struct msghdr msg;
-- char buf[4];
--
-- msg.msg_control = buf;
-- msg.msg_controllen = 0;
--
-- if (CMSG_FIRSTHDR(&msg) != NULL)
-- exit(0);
-- exit (1);
--}
--_ACEOF
--rm -f conftest$ac_exeext
--if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
-- (eval $ac_link) 2>&5
-- ac_status=$?
-- echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
-- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-- (eval $ac_try) 2>&5
-- ac_status=$?
-- echo "$as_me:$LINENO: \$? = $ac_status" >&5
-- (exit $ac_status); }; }; then
-- echo "$as_me:$LINENO: result: yes - using workaround" >&5
--echo "${ECHO_T}yes - using workaround" >&6
--cat >>confdefs.h <<\_ACEOF
--#define HAVE_BROKEN_CMSG_FIRSTHDR
--_ACEOF
--
--else
-- echo "$as_me: program exited with status $ac_status" >&5
--echo "$as_me: failed program was:" >&5
--sed 's/^/| /' conftest.$ac_ext >&5
--
--( exit $ac_status )
--echo "$as_me:$LINENO: result: no" >&5
--echo "${ECHO_T}no" >&6
--fi
--rm -f core *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
--fi
--
- echo "$as_me:$LINENO: checking route read method check" >&5
- echo $ECHO_N "checking route read method check... $ECHO_C" >&6
- if test "${zebra_rtread+set}" = set; then
-@@ -12783,10 +12720,7 @@
- if test "${zebra_ipforward_path+set}" = set; then
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
-- for zebra_ipforward_path in /proc/net/snmp /dev/ip /dev/null;
--do
-- test x`ls $zebra_ipforward_path 2>/dev/null` = x"$zebra_ipforward_path" && break
--done
-+ zebra_ipforward_path="/proc/net/snmp"
- case $zebra_ipforward_path in
- "/proc/net/snmp") IPFORWARD=ipforward_proc.o
- zebra_ipforward_path="proc";;
diff --git a/package/quagga/patches/quagga-readline.patch b/package/quagga/patches/quagga-readline.patch
deleted file mode 100644
index 8e3b805621..0000000000
--- a/package/quagga/patches/quagga-readline.patch
+++ /dev/null
@@ -1,58 +0,0 @@
---- quagga-0.98.4/configure.orig Mon Jun 27 19:05:31 2005
-+++ quagga-0.98.4/configure Thu Jul 28 07:02:12 2005
-@@ -10937,7 +10937,7 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lcurses $LIBS"
-+#LIBS="-lcurses $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
-@@ -11071,7 +11071,8 @@
- #define HAVE_LIBNCURSES 1
- _ACEOF
-
-- LIBS="-lncurses $LIBS"
-+# LIBS="-lncurses $LIBS"
-+CURSES=-lncurses
-
- fi
-
-@@ -11088,7 +11089,7 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lreadline $LIBS"
-+LIBS="-lreadline $CURSES $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
-@@ -11144,7 +11145,8 @@
- #define HAVE_LIBREADLINE 1
- _ACEOF
-
-- LIBS="-lreadline $LIBS"
-+# LIBS="-lreadline $LIBS"
-+CURSES="$CURSES -lreadline"
-
- fi
-
-@@ -11303,7 +11305,7 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lreadline $LIBS"
-+LIBS="-lreadline $CURSES $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
-@@ -11365,7 +11367,7 @@
- #define HAVE_LIBREADLINE 1
- _ACEOF
-
-- LIBS="-lreadline $LIBS"
-+# LIBS="-lreadline $LIBS"
-
- fi
-