aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/other.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index cef14106d4..d680d326d3 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -898,6 +898,7 @@ define KernelPackage/thermal
KCONFIG:= \
CONFIG_THERMAL \
CONFIG_THERMAL_OF=y \
+ CONFIG_CPU_THERMAL=y \
CONFIG_THERMAL_DEFAULT_GOV_STEP_WISE=y \
CONFIG_THERMAL_DEFAULT_GOV_FAIR_SHARE=n \
CONFIG_THERMAL_DEFAULT_GOV_USER_SPACE=n \
@@ -924,7 +925,6 @@ define KernelPackage/thermal-imx
TITLE:=Temperature sensor driver for Freescale i.MX SoCs
DEPENDS:=@TARGET_imx6 +kmod-thermal
KCONFIG:= \
- CONFIG_CPU_THERMAL=y \
CONFIG_IMX_THERMAL
FILES:=$(LINUX_DIR)/drivers/thermal/imx_thermal.ko
AUTOLOAD:=$(call AutoProbe,imx_thermal)