aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk54
1 files changed, 54 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index d680d326d3..9d01e3e0b3 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -890,6 +890,25 @@ endef
$(eval $(call KernelPackage,random-omap))
+
+define KernelPackage/random-tpm
+ TITLE:= TPM hardware random support
+ SUBMENU:=$(OTHER_MENU)
+ KCONFIG:= \
+ CONFIG_HW_RANDOM_TPM=y
+ FILES:= \
+ $(LINUX_DIR)/drivers/char/hw_random/tpm-rng.ko
+ AUTOLOAD:= $(call AutoProbe, tpm-rng)
+ DEPENDS:=+kmod-random-core kmod-tpm
+endef
+
+define KernelPackage/random-tpm/description
+ TPM backed random support.
+endef
+
+$(eval $(call KernelPackage,random-tpm))
+
+
define KernelPackage/thermal
SUBMENU:=$(OTHER_MENU)
TITLE:=Generic Thermal sysfs driver
@@ -1075,3 +1094,38 @@ endef
$(eval $(call KernelPackage,virtio-mmio))
+define KernelPackage/tpm
+ TITLE:= TPM support
+ SUBMENU:=$(OTHER_MENU)
+ KCONFIG:= \
+ CONFIG_TCG_TPM=y
+ FILES:= \
+ $(LINUX_DIR)/drivers/char/tpm/tpm.ko
+ AUTOLOAD:= $(call AutoProbe, tpm)
+endef
+
+define KernelPackage/tpm/description
+ TPM support.
+endef
+
+$(eval $(call KernelPackage,tpm))
+
+
+define KernelPackage/tpm-i2c-infineon
+ TITLE:= TPM 1.2 infineon i2c driver
+ SUBMENU:=$(OTHER_MENU)
+ KCONFIG:= \
+ CONFIG_TCG_TIS_I2C_INFINEON=y
+ FILES:= \
+ $(LINUX_DIR)/drivers/char/tpm/tpm_i2c_infineon.ko
+ AUTOLOAD:= $(call AutoProbe, tpm_i2c_infineon)
+ DEPENDS:=+kmod-tpm kmod-i2c-core
+endef
+
+define KernelPackage/tpm-i2c-infineon/description
+ TPM 1.2 support for infineon i2c devices.
+endef
+
+$(eval $(call KernelPackage,tpm-i2c-infineon))
+
+