aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk15
1 files changed, 4 insertions, 11 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 5d49160959..eec7934f16 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -594,17 +594,10 @@ $(eval $(call KernelPackage,crypto-test))
define KernelPackage/crypto-xts
TITLE:=XTS cipher CryptoAPI module
- DEPENDS:=+kmod-crypto-manager
- KCONFIG:= \
- CONFIG_CRYPTO_GF128MUL \
- CONFIG_CRYPTO_XTS
- FILES:= \
- $(LINUX_DIR)/crypto/xts.ko \
- $(LINUX_DIR)/crypto/gf128mul.ko
- AUTOLOAD:=$(call AutoLoad,09, \
- gf128mul \
- xts \
- )
+ DEPENDS:=+kmod-crypto-gf128 +kmod-crypto-manager
+ KCONFIG:=CONFIG_CRYPTO_XTS
+ FILES:=$(LINUX_DIR)/crypto/xts.ko
+ AUTOLOAD:=$(call AutoLoad,09,xts)
$(call AddDepends/crypto)
endef