aboutsummaryrefslogtreecommitdiffstats
path: root/package/bitchx
diff options
context:
space:
mode:
Diffstat (limited to 'package/bitchx')
-rw-r--r--package/bitchx/Config.in10
-rw-r--r--package/bitchx/Makefile90
-rwxr-xr-xpackage/bitchx/files/S98bitchxrc7
-rw-r--r--package/bitchx/files/bitchxrc2
-rw-r--r--package/bitchx/ipkg/bitchx.control7
-rw-r--r--package/bitchx/patches/BitchX-fix_declarations.patch24
-rw-r--r--package/bitchx/patches/BitchX-tparm.patch10
7 files changed, 0 insertions, 150 deletions
diff --git a/package/bitchx/Config.in b/package/bitchx/Config.in
deleted file mode 100644
index 91b95a93da..0000000000
--- a/package/bitchx/Config.in
+++ /dev/null
@@ -1,10 +0,0 @@
-config BR2_PACKAGE_BITCHX
- prompt "bitchx............................ popular IRC client"
- tristate
- default m if CONFIG_DEVEL
- select BR2_PACKAGE_LIBNCURSES
- help
- A popular IRC client
-
- http://www.bitchx.org/
-
diff --git a/package/bitchx/Makefile b/package/bitchx/Makefile
deleted file mode 100644
index 0bcc26ee6f..0000000000
--- a/package/bitchx/Makefile
+++ /dev/null
@@ -1,90 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=bitchx
-PKG_VERSION:=1.1
-PKG_RELEASE:=1
-PKG_MD5SUM:=611d2dda222f00c10140236f4c331572
-
-PKG_SOURCE_URL:=http://bitchx.org/files/source/
-PKG_SOURCE:=ircii-pana-$(PKG_VERSION)-final.tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/BitchX
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
-include $(TOPDIR)/package/rules.mk
-
-$(eval $(call PKG_template,BITCHX,bitchx,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
- (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
- ./configure \
- --target=$(GNU_HOST_NAME) \
- --host=mipsel-linux-uclibc-gcc \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_LARGEFILE) \
- $(DISABLE_NLS) \
- );
- touch $@
-
-$(PKG_BUILD_DIR)/.built:
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all
- mkdir -p $(PKG_INSTALL_DIR)/tmp
- mkdir -p $(PKG_INSTALL_DIR)/etc/init.d
- mkdir -p $(PKG_INSTALL_DIR)/usr/bin
- mkdir -p $(PKG_INSTALL_DIR)/usr/lib/bx
- mkdir -p $(PKG_INSTALL_DIR)/usr/share/man/man1
- mkdir -p $(PKG_INSTALL_DIR)/usr/lib/bx/translation
- mkdir -p $(PKG_INSTALL_DIR)/usr/lib/bx/plugins
- mkdir -p $(PKG_INSTALL_DIR)/usr/lib/bx/help
- install -c $(PKG_BUILD_DIR)/source/BitchX $(PKG_INSTALL_DIR)/usr/bin/BitchX-1.1-final
- rm -f $(PKG_INSTALL_DIR)/usr/bin/BitchX
- ln -s /usr/bin/BitchX-1.1-final $(PKG_INSTALL_DIR)/usr/bin/BitchX
- install -c $(PKG_BUILD_DIR)/BitchX.help $(PKG_INSTALL_DIR)/usr/lib/bx/BitchX.help
- install -c $(PKG_BUILD_DIR)/BitchX.ircnames $(PKG_INSTALL_DIR)/usr/lib/bx/BitchX.ircnames
- install -c $(PKG_BUILD_DIR)/BitchX.quit $(PKG_INSTALL_DIR)/usr/lib/bx/BitchX.quit
- install -c $(PKG_BUILD_DIR)/BitchX.reasons $(PKG_INSTALL_DIR)/usr/lib/bx/BitchX.kick
- install -c $(PKG_BUILD_DIR)/source/wserv $(PKG_INSTALL_DIR)/usr/lib/bx/wserv
- install -c $(PKG_BUILD_DIR)/source/scr-bx $(PKG_INSTALL_DIR)/usr/bin/scr-bx
- cp -fpR $(PKG_BUILD_DIR)/script $(PKG_INSTALL_DIR)/usr/lib/bx/
- cp -fpR $(PKG_BUILD_DIR)/translation $(PKG_INSTALL_DIR)/usr/lib/bx/
- bzip2 $(PKG_INSTALL_DIR)/usr/lib/bx/translation/*
- cp -f ./files/bitchxrc $(PKG_INSTALL_DIR)/tmp/.bitchxrc
- cp -pf ./files/S98bitchxrc $(PKG_INSTALL_DIR)/etc/init.d/S98bitchxrc
- touch $@
-
-$(IPKG_BITCHX):
- install -d -m0755 $(IDIR_BITCHX)/usr/bin
- cp -fpR $(PKG_INSTALL_DIR)/usr/bin/* $(IDIR_BITCHX)/usr/bin
- install -d -m0755 $(IDIR_BITCHX)/usr/lib
- cp -fpR $(PKG_INSTALL_DIR)/usr/lib/* $(IDIR_BITCHX)/usr/lib
- install -d $(IDIR_BITCHX)/etc/init.d
- cp -fp $(PKG_INSTALL_DIR)/etc/init.d/S98bitchxrc $(IDIR_BITCHX)/etc/init.d
- install -d -m0755 $(IDIR_BITCHX)/tmp
- cp -fp $(PKG_INSTALL_DIR)/tmp/.bitchxrc $(IDIR_BITCHX)/tmp
- $(RSTRIP) $(IDIR_BITCHX)
- $(IPKG_BUILD) $(IDIR_BITCHX) $(PACKAGE_DIR)
diff --git a/package/bitchx/files/S98bitchxrc b/package/bitchx/files/S98bitchxrc
deleted file mode 100755
index 4578696ae2..0000000000
--- a/package/bitchx/files/S98bitchxrc
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-# make /tmp/.bitchxrc as many servers ban root
-if [ ! -e /tmp/.bitchxrc ]
-then
- echo "IRCUSER OpenWrt" >/tmp/.bitchxrc
- echo "IRCNAME OpenWrt User!" >>/tmp/.bitchxrc
-fi
diff --git a/package/bitchx/files/bitchxrc b/package/bitchx/files/bitchxrc
deleted file mode 100644
index 6e2b271eec..0000000000
--- a/package/bitchx/files/bitchxrc
+++ /dev/null
@@ -1,2 +0,0 @@
-IRCUSER OpenWrt
-IRCNAME OpenWrt User!
diff --git a/package/bitchx/ipkg/bitchx.control b/package/bitchx/ipkg/bitchx.control
deleted file mode 100644
index b95b9ad1cd..0000000000
--- a/package/bitchx/ipkg/bitchx.control
+++ /dev/null
@@ -1,7 +0,0 @@
-Package: bitchx
-Priority: optional
-Section: net
-Maintainer: Duncan Lindley <drhl@drhl.org>
-Source: http://www.bitchx.org
-Depends: libncurses
-Description: A popular IRC client
diff --git a/package/bitchx/patches/BitchX-fix_declarations.patch b/package/bitchx/patches/BitchX-fix_declarations.patch
deleted file mode 100644
index b6766da596..0000000000
--- a/package/bitchx/patches/BitchX-fix_declarations.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -urN BitchX/include/ctcp.h BitchX.new/include/ctcp.h
---- BitchX/include/ctcp.h 2003-04-11 03:09:07.000000000 +0200
-+++ BitchX.new/include/ctcp.h 2006-03-29 13:19:21.170693168 +0200
-@@ -56,7 +56,7 @@
- extern CtcpEntryDll *dll_ctcp;
-
-
--extern char *ctcp_type[];
-+//extern char *ctcp_type[]; /* already declared in ctcp.c
- extern int sed;
- extern int in_ctcp_flag;
-
-diff -urN BitchX/include/struct.h BitchX.new/include/struct.h
---- BitchX/include/struct.h 2003-04-11 03:09:07.000000000 +0200
-+++ BitchX.new/include/struct.h 2006-03-29 13:19:26.653859600 +0200
-@@ -1064,7 +1064,7 @@
- int delete;
- } TimerList;
-
--extern TimerList *PendingTimers;
-+//extern TimerList *PendingTimers;
- typedef struct nicktab_stru
- {
- struct nicktab_stru *next;
diff --git a/package/bitchx/patches/BitchX-tparm.patch b/package/bitchx/patches/BitchX-tparm.patch
deleted file mode 100644
index 18bd7bfd0c..0000000000
--- a/package/bitchx/patches/BitchX-tparm.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- BitchX/source/term.c.orig 2006-03-05 15:01:46.000000000 +1000
-+++ BitchX/source/term.c 2006-03-05 15:01:53.000000000 +1000
-@@ -92,7 +92,6 @@
- #endif
-
- extern char *getenv();
--extern char *tparm();
-
- /*
- * The old code assumed termcap. termcap is almost always present, but on