aboutsummaryrefslogtreecommitdiffstats
path: root/package/atftp
diff options
context:
space:
mode:
Diffstat (limited to 'package/atftp')
-rw-r--r--package/atftp/Config.in1
-rw-r--r--package/atftp/Makefile4
-rw-r--r--package/atftp/ipkg/atftp.control1
-rw-r--r--package/atftp/ipkg/atftpd.control1
4 files changed, 2 insertions, 5 deletions
diff --git a/package/atftp/Config.in b/package/atftp/Config.in
index 296faec842..32ab9512a3 100644
--- a/package/atftp/Config.in
+++ b/package/atftp/Config.in
@@ -4,7 +4,6 @@ config BR2_COMPILE_ATFTP
tristate
default n
depends BR2_PACKAGE_ATFTP || BR2_PACKAGE_ATFTPD
- select BR2_PACKAGE_LIBREADLINE
config BR2_PACKAGE_ATFTP
prompt "atftp............................. TFTP client"
diff --git a/package/atftp/Makefile b/package/atftp/Makefile
index a609c53d36..f49aab6701 100644
--- a/package/atftp/Makefile
+++ b/package/atftp/Makefile
@@ -60,12 +60,12 @@ $(PKG_BUILD_DIR)/.built:
$(IPKG_ATFTP):
install -d -m0755 $(IDIR_ATFTP)/usr/bin
- cp -fpR $(PKG_BUILD_DIR)/atftp $(IDIR_ATFTP)/usr/bin
+ $(CP) $(PKG_BUILD_DIR)/atftp $(IDIR_ATFTP)/usr/bin
$(RSTRIP) $(IDIR_ATFTP)
$(IPKG_BUILD) $(IDIR_ATFTP) $(PACKAGE_DIR)
$(IPKG_ATFTPD):
install -d -m0755 $(IDIR_ATFTPD)/usr/sbin
- cp -fpR $(PKG_BUILD_DIR)/atftpd $(IDIR_ATFTPD)/usr/sbin
+ $(CP) $(PKG_BUILD_DIR)/atftpd $(IDIR_ATFTPD)/usr/sbin
$(RSTRIP) $(IDIR_ATFTPD)
$(IPKG_BUILD) $(IDIR_ATFTPD) $(PACKAGE_DIR)
diff --git a/package/atftp/ipkg/atftp.control b/package/atftp/ipkg/atftp.control
index ca4d86a308..d2083fc619 100644
--- a/package/atftp/ipkg/atftp.control
+++ b/package/atftp/ipkg/atftp.control
@@ -2,4 +2,3 @@ Package: atftp
Priority: optional
Section: net
Description: tftp client
-Depends: libreadline
diff --git a/package/atftp/ipkg/atftpd.control b/package/atftp/ipkg/atftpd.control
index acdd2f1ced..efb40299c3 100644
--- a/package/atftp/ipkg/atftpd.control
+++ b/package/atftp/ipkg/atftpd.control
@@ -2,4 +2,3 @@ Package: atftpd
Priority: optional
Section: net
Description: tftp server
-Depends: libreadline