aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Config.in4
-rw-r--r--target/linux/rb532-2.6/image/Makefile2
2 files changed, 3 insertions, 3 deletions
diff --git a/Config.in b/Config.in
index 0b6fa95927..cdc7b6e2dd 100644
--- a/Config.in
+++ b/Config.in
@@ -109,14 +109,14 @@ source "target/linux/*/image/Config.in"
config TARGET_ROOTFS_FSPART
int "Filesystem part size (in MB)"
- depends X86_GRUB_IMAGES || TARGET_ROOTFS_EXT2FS
+ depends X86_GRUB_IMAGES || TARGET_ROOTFS_EXT2FS || LINUX_2_6_RB532
default 16
help
Allows you to change the filesystem partition size
config TARGET_ROOTFS_MAXINODE
int "Maximum number of inodes in filesystem"
- depends X86_GRUB_IMAGES || TARGET_ROOTFS_EXT2FS
+ depends TARGET_ROOTFS_EXT2FS
default 1500
help
Allows you to change the maximum number of inodes in the filesystem
diff --git a/target/linux/rb532-2.6/image/Makefile b/target/linux/rb532-2.6/image/Makefile
index 2ded1c0788..b35b0b1e7b 100644
--- a/target/linux/rb532-2.6/image/Makefile
+++ b/target/linux/rb532-2.6/image/Makefile
@@ -52,7 +52,7 @@ endef
define Image/Build
$(STAGING_DIR)/bin/patch-cmdline $(KDIR)/vmlinux.elf '$(strip $(call Image/cmdline/$(1))) '
- ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin 4 $(KDIR)/vmlinux.elf 16 $(KDIR)/root.$(1)
+ ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin 4 $(KDIR)/vmlinux.elf $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
endef
$(eval $(call BuildImage))