aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/imx6/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/imx6/image/Makefile b/target/linux/imx6/image/Makefile
index 391db78474..3381473c7f 100644
--- a/target/linux/imx6/image/Makefile
+++ b/target/linux/imx6/image/Makefile
@@ -44,9 +44,9 @@ endef
define Image/InstallKernel/Template
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL)$(CONFIG_TARGET_imx6_VENTANA),)
$(INSTALL_DIR) $(TARGET_DIR)/boot
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE)$(CONFIG_TARGET_imx6_VENTANA),)
$(CP) $(BIN_DIR)/$(IMG_PREFIX)-uImage $(TARGET_DIR)/boot/
ln -sf $(IMG_PREFIX)-uImage $(TARGET_DIR)/boot/uImage
endif
@@ -61,7 +61,7 @@ define Image/InstallKernel/Template
endif
endif
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB)$(CONFIG_TARGET_imx6_VENTANA),)
$(INSTALL_DIR) $(TARGET_DIR)/boot
$(foreach dts,$(shell echo $(1)), \
$(CP) $(BIN_DIR)/$(IMG_PREFIX)-$(dts).dtb $(TARGET_DIR)/boot/ ; \