aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--target/linux/ar71xx/generic/profiles/pcs.mk18
-rw-r--r--target/linux/ar71xx/image/Makefile20
2 files changed, 36 insertions, 2 deletions
diff --git a/target/linux/ar71xx/generic/profiles/pcs.mk b/target/linux/ar71xx/generic/profiles/pcs.mk
index 1466e5282a..b4df1a4712 100644
--- a/target/linux/ar71xx/generic/profiles/pcs.mk
+++ b/target/linux/ar71xx/generic/profiles/pcs.mk
@@ -47,3 +47,21 @@ endef
$(eval $(call Profile,CAP324))
+define Profile/CR3000
+ NAME:=PowerCloud CR3000 Cloud Router
+ PACKAGES:=uboot-envtools
+endef
+
+define Profile/CR3000/Description
+ Package set optimized for the PowerCloud Systems CR3000 Cloud Router
+
+ The CR3000 is a device sold by PowerCloud Systems as a hardware
+ option for their Skydog cloud-managed Wifi solution.
+
+ The CR3000 is a 2.4 GHz 802.11n wireless router with 8MB
+ flash and 64MB RAM, four-port fast ethernet switch, and fast
+ ethernet WAN port.
+endef
+
+$(eval $(call Profile,CR3000))
+
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 5783221b1d..af9516eaa7 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -212,7 +212,6 @@ define Device/gl-domino
endef
TARGET_DEVICES += gl-domino
-
define Device/wndr3700
BOARDNAME = WNDR3700
NETGEAR_KERNEL_MAGIC = 0x33373030
@@ -410,6 +409,24 @@ endef
TARGET_DEVICES += cap324-nocloud
+define Device/cr3000
+ BOARDNAME := CR3000
+ DEVICE_PROFILE := CR3000
+ IMAGE_SIZE = 7104k
+ MTDPARTS = spi0.0:256k(u-boot),64k(u-boot-env)ro,7104k(firmware),640k(certs),64k(nvram),64k(art)
+endef
+
+TARGET_DEVICES += cr3000
+
+define Device/cr3000-nocloud
+ BOARDNAME := CR3000
+ DEVICE_PROFILE := CR3000
+ IMAGE_SIZE = 7808k
+ MTDPARTS = spi0.0:256k(u-boot),64k(u-boot-env)ro,7808k(firmware),64k(art)
+endef
+
+TARGET_DEVICES += cr3000-nocloud
+
define Device/antminer-s1
$(Device/tplink-8mlzma)
BOARDNAME := ANTMINER-S1
@@ -1470,7 +1487,6 @@ define Build/Clean
$(LOADER_MAKE) clean
endef
-
alfa_ap96_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,256k(u-boot-env)ro,13312k(rootfs),2048k(kernel),512k(caldata)ro,15360k@0x80000(firmware)
alfa_mtdlayout_8M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,6144k(rootfs),1600k(kernel),64k(nvram),64k(art)ro,7744k@0x50000(firmware)
alfa_mtdlayout_16M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,15936k(firmware),64k(nvram),64k(art)ro