aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/kernel/linux/modules/other.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 9bb9dec2bc..62fdc3cd69 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -820,7 +820,9 @@ define KernelPackage/ptp
SUBMENU:=$(OTHER_MENU)
TITLE:=PTP clock support
DEPENDS:=+kmod-pps
- KCONFIG:=CONFIG_PTP_1588_CLOCK
+ KCONFIG:= \
+ CONFIG_PTP_1588_CLOCK \
+ CONFIG_NET_PTP_CLASSIFY=y
FILES:=$(LINUX_DIR)/drivers/ptp/ptp.ko
AUTOLOAD:=$(call AutoLoad,18,ptp,1)
endef