aboutsummaryrefslogtreecommitdiffstats
path: root/tools/pkg-config/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-10-30 22:31:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-10-30 22:31:29 +0000
commit80fbb87a84a96618bd6da775ce56dc0f169bca5c (patch)
tree9951fd9705f11055909b71b3c29475702a535fe5 /tools/pkg-config/Makefile
parentb9eaa41e7e3bace5a1e3ca24567448e060ce4a4c (diff)
downloadmaster-187ad058-80fbb87a84a96618bd6da775ce56dc0f169bca5c.tar.gz
master-187ad058-80fbb87a84a96618bd6da775ce56dc0f169bca5c.tar.bz2
master-187ad058-80fbb87a84a96618bd6da775ce56dc0f169bca5c.zip
tools/pkg-config: update to 0.29
Release announcement: http://lists.freedesktop.org/archives/pkg-config/2015-September/001019.html Drop patches, as they have been implemented upstream. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi> Signed-off-by: Felix Fietkau <nbd@openwrt.org> [fix OSX compatibility] git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47300 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'tools/pkg-config/Makefile')
-rw-r--r--tools/pkg-config/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/tools/pkg-config/Makefile b/tools/pkg-config/Makefile
index 9a1b3fb986..40e6e083e8 100644
--- a/tools/pkg-config/Makefile
+++ b/tools/pkg-config/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2013 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,11 +7,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=pkg-config
-PKG_VERSION:=0.28
+PKG_VERSION:=0.29
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://pkgconfig.freedesktop.org/releases/
-PKG_MD5SUM:=aa3c86e67551adc3ac865160e34a2a0d
+PKG_MD5SUM:=77f27dce7ef88d0634d0d6f90e03a77f
HOST_BUILD_PARALLEL:=1
@@ -21,6 +21,10 @@ unexport PKG_CONFIG
HOST_CONFIGURE_ARGS += --with-internal-glib
+ifeq ($(HOST_OS),Darwin)
+HOST_LDFLAGS += -framework CoreFoundation -framework Carbon
+endif
+
define Host/Install
$(MAKE) -C $(HOST_BUILD_DIR) install
mv $(STAGING_DIR_HOST)/bin/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config.real