aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-11-23 16:21:50 +0100
committerZoltan HERPAI <wigyori@uid0.hu>2016-11-23 16:21:50 +0100
commit9e2f8fa1e5df297c172ce1472eb076c3c0b27cad (patch)
treed87851afa0c09b71ff6685b56fc49837f6815517
parentce116bc6f997d8d6e6b976cacce5d4c60d705fc6 (diff)
downloadmaster-187ad058-9e2f8fa1e5df297c172ce1472eb076c3c0b27cad.tar.gz
master-187ad058-9e2f8fa1e5df297c172ce1472eb076c3c0b27cad.tar.bz2
master-187ad058-9e2f8fa1e5df297c172ce1472eb076c3c0b27cad.zip
uboot-sunxi: fix default config for OLIMEX A13 SOM (FS#239)
The current uboot default config for the A13 SOM erroneously enables support for the AXP209 power regulator IC which is not present on the board. This superfluous support module sets an incorrect initial clock frequency and confuses the kernel, ultimately leading to a boot failure later on. Properly disable the PMIC support and enable the EHCI support by translating the deprecated SYS_EXTRA_OPTIONS values into proper SUNXI_NO_PMIC and USB_EHCI_HCD symbols respectively. Also rename 002-add-olimex-a13-som.diff to 002-add-olimex-a13-som.patch and refresh the remaining patches of the series while we're at it. Reported-by: Mario Fischer <mario-fischer@web.de> Signed-off-by: Jo-Philipp Wich <jo@mein.io>
-rw-r--r--package/boot/uboot-sunxi/patches/001-use-dtc-in-kernel.patch7
-rw-r--r--package/boot/uboot-sunxi/patches/002-add-olimex-a13-som.diff20
-rw-r--r--package/boot/uboot-sunxi/patches/002-add-olimex-a13-som.patch21
-rw-r--r--package/boot/uboot-sunxi/patches/003-add-theobroma-a31-pangolin.patch37
-rw-r--r--package/boot/uboot-sunxi/patches/010-dt-sync-files-with-kernel.patch8
-rw-r--r--package/boot/uboot-sunxi/patches/011-dt-sync-dts-files-with-kernel.patch16
-rw-r--r--package/boot/uboot-sunxi/patches/012-sun6i-fix-clock_twi_onoff.patch2
-rw-r--r--package/boot/uboot-sunxi/patches/013-enable-realtek-phy.patch4
-rw-r--r--package/boot/uboot-sunxi/patches/014-fix-gmac-init.patch12
-rw-r--r--package/boot/uboot-sunxi/patches/015-fix-2nd-usb-ctrler-on-sun47i.patch8
-rw-r--r--package/boot/uboot-sunxi/patches/016-spl-print-mmc-slot.patch4
-rw-r--r--package/boot/uboot-sunxi/patches/017-usb-add-support-for-usb3-vbus-pin.patch6
-rw-r--r--package/boot/uboot-sunxi/patches/018-usb-specify-vbus-pins-on-orangepis.patch4
-rw-r--r--package/boot/uboot-sunxi/patches/019-sid-add-efuse-support-for-h3-a83t.patch2
-rw-r--r--package/boot/uboot-sunxi/patches/020-boot-display-board-model-on-startup.patch2
-rw-r--r--package/boot/uboot-sunxi/patches/091-sun6i-sync-PLL1-multdiv-with-Boot1.patch7
-rw-r--r--package/boot/uboot-sunxi/patches/093-sun6i-fix-PLL-LDO-voltselect.patch9
-rw-r--r--package/boot/uboot-sunxi/patches/100-sun6i-alternate-on-UART2.patch7
-rw-r--r--package/boot/uboot-sunxi/patches/101-sun6i-support-console-on-UART2.patch9
-rw-r--r--package/boot/uboot-sunxi/patches/102-sunxi-make_CONS_INDEX-configurable.patch7
20 files changed, 58 insertions, 134 deletions
diff --git a/package/boot/uboot-sunxi/patches/001-use-dtc-in-kernel.patch b/package/boot/uboot-sunxi/patches/001-use-dtc-in-kernel.patch
index afcb37c546..6471e78656 100644
--- a/package/boot/uboot-sunxi/patches/001-use-dtc-in-kernel.patch
+++ b/package/boot/uboot-sunxi/patches/001-use-dtc-in-kernel.patch
@@ -1,7 +1,6 @@
-diff -ruN old/Makefile new/Makefile
---- old/Makefile 2015-04-13 16:53:03.000000000 +0200
-+++ new/Makefile 2015-07-31 15:52:08.920097812 +0200
-@@ -346,7 +346,7 @@
+--- a/Makefile
++++ b/Makefile
+@@ -348,7 +348,7 @@ OBJDUMP = $(CROSS_COMPILE)objdump
AWK = awk
PERL = perl
PYTHON = python
diff --git a/package/boot/uboot-sunxi/patches/002-add-olimex-a13-som.diff b/package/boot/uboot-sunxi/patches/002-add-olimex-a13-som.diff
deleted file mode 100644
index a8c5b3d938..0000000000
--- a/package/boot/uboot-sunxi/patches/002-add-olimex-a13-som.diff
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -ruN u-boot-2015.01.old/configs/OLIMEX_A13_SOM_defconfig u-boot-2015.01/configs/OLIMEX_A13_SOM_defconfig
---- u-boot-2015.01.old/configs/OLIMEX_A13_SOM_defconfig 1970-01-01 01:00:00.000000000 +0100
-+++ u-boot-2015.01/configs/OLIMEX_A13_SOM_defconfig 2015-01-18 16:25:11.908986082 +0100
-@@ -0,0 +1,16 @@
-+CONFIG_SPL=y
-+CONFIG_SYS_EXTRA_OPTIONS="CONS_INDEX=2,NO_AXP,USB_EHCI"
-+CONFIG_DEFAULT_DEVICE_TREE="sun5i-a13-olinuxino"
-+CONFIG_ARM=y
-+CONFIG_ARCH_SUNXI=y
-+CONFIG_MACH_SUN5I=y
-+CONFIG_DRAM_CLK=408
-+CONFIG_DRAM_ZQ=123
-+CONFIG_DRAM_EMR1=0
-+# CONFIG_CMD_IMLS is not set
-+# CONFIG_CMD_FLASH is not set
-+# CONFIG_CMD_FPGA is not set
-+CONFIG_DM_SERIAL=y
-+CONFIG_USB=y
-+CONFIG_DM_USB=y
-+CONFIG_SYS_NS16550=y
diff --git a/package/boot/uboot-sunxi/patches/002-add-olimex-a13-som.patch b/package/boot/uboot-sunxi/patches/002-add-olimex-a13-som.patch
new file mode 100644
index 0000000000..f29ad12b75
--- /dev/null
+++ b/package/boot/uboot-sunxi/patches/002-add-olimex-a13-som.patch
@@ -0,0 +1,21 @@
+--- /dev/null
++++ b/configs/OLIMEX_A13_SOM_defconfig
+@@ -0,0 +1,18 @@
++CONFIG_SPL=y
++CONFIG_SYS_EXTRA_OPTIONS="CONS_INDEX=2"
++CONFIG_DEFAULT_DEVICE_TREE="sun5i-a13-olinuxino"
++CONFIG_ARM=y
++CONFIG_ARCH_SUNXI=y
++CONFIG_MACH_SUN5I=y
++CONFIG_DRAM_CLK=408
++CONFIG_DRAM_ZQ=123
++CONFIG_DRAM_EMR1=0
++# CONFIG_CMD_IMLS is not set
++# CONFIG_CMD_FLASH is not set
++# CONFIG_CMD_FPGA is not set
++CONFIG_DM_SERIAL=y
++CONFIG_USB=y
++CONFIG_DM_USB=y
++CONFIG_SYS_NS16550=y
++CONFIG_SUNXI_NO_PMIC=y
++CONFIG_USB_EHCI_HCD=y
diff --git a/package/boot/uboot-sunxi/patches/003-add-theobroma-a31-pangolin.patch b/package/boot/uboot-sunxi/patches/003-add-theobroma-a31-pangolin.patch
index 2bf5778684..e5a66d7ebe 100644
--- a/package/boot/uboot-sunxi/patches/003-add-theobroma-a31-pangolin.patch
+++ b/package/boot/uboot-sunxi/patches/003-add-theobroma-a31-pangolin.patch
@@ -1,7 +1,6 @@
-diff -ruN a/arch/arm/dts/Makefile b/arch/arm/dts/Makefile
---- a/arch/arm/dts/Makefile 2016-01-12 15:06:54.000000000 +0100
-+++ b/arch/arm/dts/Makefile 2016-01-30 15:31:50.000000000 +0100
-@@ -142,6 +142,7 @@
+--- a/arch/arm/dts/Makefile
++++ b/arch/arm/dts/Makefile
+@@ -152,6 +152,7 @@ dtb-$(CONFIG_MACH_SUN6I) += \
sun6i-a31-m9.dtb \
sun6i-a31-mele-a1000g-quad.dtb \
sun6i-a31-mixtile-loftq.dtb \
@@ -9,9 +8,8 @@ diff -ruN a/arch/arm/dts/Makefile b/arch/arm/dts/Makefile
sun6i-a31s-cs908.dtb \
sun6i-a31s-primo81.dtb \
sun6i-a31s-sinovoip-bpi-m2.dtb
-diff -ruN a/arch/arm/dts/sun6i-a31.dtsi b/arch/arm/dts/sun6i-a31.dtsi
---- a/arch/arm/dts/sun6i-a31.dtsi 2016-01-12 15:06:54.000000000 +0100
-+++ b/arch/arm/dts/sun6i-a31.dtsi 2016-01-31 15:06:47.000000000 +0100
+--- a/arch/arm/dts/sun6i-a31.dtsi
++++ b/arch/arm/dts/sun6i-a31.dtsi
@@ -643,6 +643,13 @@
allwinner,pull = <SUN4I_PINCTRL_NO_PULL>;
};
@@ -26,9 +24,8 @@ diff -ruN a/arch/arm/dts/sun6i-a31.dtsi b/arch/arm/dts/sun6i-a31.dtsi
mmc0_pins_a: mmc0@0 {
allwinner,pins = "PF0", "PF1", "PF2",
"PF3", "PF4", "PF5";
-diff -ruN a/arch/arm/dts/sun6i-a31-pangolin.dts b/arch/arm/dts/sun6i-a31-pangolin.dts
---- a/arch/arm/dts/sun6i-a31-pangolin.dts 1970-01-01 01:00:00.000000000 +0100
-+++ b/arch/arm/dts/sun6i-a31-pangolin.dts 2016-02-09 01:21:44.965168099 +0100
+--- /dev/null
++++ b/arch/arm/dts/sun6i-a31-pangolin.dts
@@ -0,0 +1,292 @@
+/*
+ * Copyright 2015, Theobroma Systems Design und Consulting GmbH
@@ -322,9 +319,8 @@ diff -ruN a/arch/arm/dts/sun6i-a31-pangolin.dts b/arch/arm/dts/sun6i-a31-pangoli
+ status = "okay";
+ usb1_vbus-supply = <&reg_usb1_vbus>;
+};
-diff -ruN a/configs/pangolin_defconfig b/configs/pangolin_defconfig
---- a/configs/pangolin_defconfig 1970-01-01 01:00:00.000000000 +0100
-+++ b/configs/pangolin_defconfig 2016-01-30 14:43:59.000000000 +0100
+--- /dev/null
++++ b/configs/pangolin_defconfig
@@ -0,0 +1,36 @@
+CONFIG_SUNXI_PANGOLIN=y
+CONFIG_SPL=y
@@ -362,8 +358,6 @@ diff -ruN a/configs/pangolin_defconfig b/configs/pangolin_defconfig
+CONFIG_DM_SPI=y
+CONFIG_DM_SPI_FLASH=y
+CONFIG_SUNXI_SPI=y
-diff --git a/board/sunxi/Kconfig b/board/sunxi/Kconfig
-index e155c4c..1b147b2 100644
--- a/board/sunxi/Kconfig
+++ b/board/sunxi/Kconfig
@@ -15,7 +15,6 @@ config SUNXI_GEN_SUN6I
@@ -374,9 +368,9 @@ index e155c4c..1b147b2 100644
choice
prompt "Sunxi SoC Variant"
optional
-@@ -80,6 +79,14 @@ config MACH_SUN8I
- bool
- default y if MACH_SUN8I_A23 || MACH_SUN8I_A33
+@@ -533,6 +532,14 @@ config VIDEO_LCD_PANEL_I2C_SCL
+ Set the SCL pin for the LCD i2c interface. This takes a string in the
+ format understood by sunxi_name_to_gpio, e.g. PH1 for pin 1 of port H.
+choice
+ prompt "Sunxi Board Variant"
@@ -387,8 +381,5 @@ index e155c4c..1b147b2 100644
+
+endchoice
- config DRAM_CLK
- int "sunxi dram clock speed"
---
-cgit v0.10.2
-
+ # Note only one of these may be selected at a time! But hidden choices are
+ # not supported by Kconfig
diff --git a/package/boot/uboot-sunxi/patches/010-dt-sync-files-with-kernel.patch b/package/boot/uboot-sunxi/patches/010-dt-sync-files-with-kernel.patch
index 70925683a6..d8fa52c7e5 100644
--- a/package/boot/uboot-sunxi/patches/010-dt-sync-files-with-kernel.patch
+++ b/package/boot/uboot-sunxi/patches/010-dt-sync-files-with-kernel.patch
@@ -18,9 +18,6 @@ Acked-by: Ian Campbell <ijc@hellion.org.uk>
create mode 100644 include/dt-bindings/clock/sun4i-a10-pll2.h
create mode 100644 include/dt-bindings/input/linux-event-codes.h
-diff --git a/include/dt-bindings/clock/sun4i-a10-pll2.h b/include/dt-bindings/clock/sun4i-a10-pll2.h
-new file mode 100644
-index 0000000..071c811
--- /dev/null
+++ b/include/dt-bindings/clock/sun4i-a10-pll2.h
@@ -0,0 +1,53 @@
@@ -77,8 +74,6 @@ index 0000000..071c811
+#define SUN4I_A10_PLL2_8X 3
+
+#endif /* __DT_BINDINGS_CLOCK_SUN4I_A10_PLL2_H_ */
-diff --git a/include/dt-bindings/input/input.h b/include/dt-bindings/input/input.h
-index 042e7b3..a214133 100644
--- a/include/dt-bindings/input/input.h
+++ b/include/dt-bindings/input/input.h
@@ -9,515 +9,7 @@
@@ -598,9 +593,6 @@ index 042e7b3..a214133 100644
#define MATRIX_KEY(row, col, code) \
((((row) & 0xFF) << 24) | (((col) & 0xFF) << 16) | ((code) & 0xFFFF))
-diff --git a/include/dt-bindings/input/linux-event-codes.h b/include/dt-bindings/input/linux-event-codes.h
-new file mode 100644
-index 0000000..87cf351
--- /dev/null
+++ b/include/dt-bindings/input/linux-event-codes.h
@@ -0,0 +1,805 @@
diff --git a/package/boot/uboot-sunxi/patches/011-dt-sync-dts-files-with-kernel.patch b/package/boot/uboot-sunxi/patches/011-dt-sync-dts-files-with-kernel.patch
index 30b58add71..4508c74449 100644
--- a/package/boot/uboot-sunxi/patches/011-dt-sync-dts-files-with-kernel.patch
+++ b/package/boot/uboot-sunxi/patches/011-dt-sync-dts-files-with-kernel.patch
@@ -103,8 +103,8 @@ Acked-by: Ian Campbell <ijc@hellion.org.uk>
sun4i-a10-pov-protab2-ips9.dtb
dtb-$(CONFIG_MACH_SUN5I) += \
sun5i-a10s-auxtek-t003.dtb \
-@@ -154,7 +155,9 @@ dtb-$(CONFIG_MACH_SUN6I) += \
- sun6i-a31-mixtile-loftq.dtb \
+@@ -155,7 +156,9 @@ dtb-$(CONFIG_MACH_SUN6I) += \
+ sun6i-a31-pangolin.dtb \
sun6i-a31s-cs908.dtb \
sun6i-a31s-primo81.dtb \
- sun6i-a31s-sinovoip-bpi-m2.dtb
@@ -114,7 +114,7 @@ Acked-by: Ian Campbell <ijc@hellion.org.uk>
dtb-$(CONFIG_MACH_SUN7I) += \
sun7i-a20-ainol-aw1.dtb \
sun7i-a20-bananapi.dtb \
-@@ -163,6 +166,8 @@ dtb-$(CONFIG_MACH_SUN7I) += \
+@@ -164,6 +167,8 @@ dtb-$(CONFIG_MACH_SUN7I) += \
sun7i-a20-cubietruck.dtb \
sun7i-a20-hummingbird.dtb \
sun7i-a20-i12-tvbox.dtb \
@@ -123,7 +123,7 @@ Acked-by: Ian Campbell <ijc@hellion.org.uk>
sun7i-a20-lamobo-r1.dtb \
sun7i-a20-m3.dtb \
sun7i-a20-m5.dtb \
-@@ -189,8 +194,10 @@ dtb-$(CONFIG_MACH_SUN8I_A33) += \
+@@ -190,8 +195,10 @@ dtb-$(CONFIG_MACH_SUN8I_A33) += \
sun8i-a33-sinlinx-sina33.dtb
dtb-$(CONFIG_MACH_SUN8I_A83T) += \
sun8i-a83t-allwinner-h8homlet-v2.dtb \
@@ -2486,7 +2486,7 @@ Acked-by: Ian Campbell <ijc@hellion.org.uk>
clock-output-names = "usb_phy0", "usb_phy1", "usb_phy2",
"usb_ohci0", "usb_ohci1",
"usb_ohci2";
-@@ -677,6 +709,16 @@
+@@ -684,6 +716,16 @@
allwinner,pull = <SUN4I_PINCTRL_NO_PULL>;
};
@@ -2503,7 +2503,7 @@ Acked-by: Ian Campbell <ijc@hellion.org.uk>
gmac_pins_mii_a: gmac_mii@0 {
allwinner,pins = "PA0", "PA1", "PA2", "PA3",
"PA8", "PA9", "PA11",
-@@ -754,6 +796,13 @@
+@@ -761,6 +803,13 @@
reg = <0x01c20ca0 0x20>;
};
@@ -2517,7 +2517,7 @@ Acked-by: Ian Campbell <ijc@hellion.org.uk>
rtp: rtp@01c25000 {
compatible = "allwinner,sun6i-a31-ts";
reg = <0x01c25000 0x100>;
-@@ -900,6 +949,16 @@
+@@ -907,6 +956,16 @@
#size-cells = <0>;
};
@@ -2534,7 +2534,7 @@ Acked-by: Ian Campbell <ijc@hellion.org.uk>
timer@01c60000 {
compatible = "allwinner,sun6i-a31-hstimer",
"allwinner,sun7i-a20-hstimer";
-@@ -1061,7 +1120,7 @@
+@@ -1068,7 +1127,7 @@
resets = <&apb0_rst 0>;
gpio-controller;
interrupt-controller;
diff --git a/package/boot/uboot-sunxi/patches/012-sun6i-fix-clock_twi_onoff.patch b/package/boot/uboot-sunxi/patches/012-sun6i-fix-clock_twi_onoff.patch
index 9471b39b3b..45416703a4 100644
--- a/package/boot/uboot-sunxi/patches/012-sun6i-fix-clock_twi_onoff.patch
+++ b/package/boot/uboot-sunxi/patches/012-sun6i-fix-clock_twi_onoff.patch
@@ -12,8 +12,6 @@ Acked-by: Ian Campbell <ijc@hellion.org.uk>
arch/arm/cpu/armv7/sunxi/clock_sun6i.c | 11 ++++++++---
1 file changed, 8 insertions(+), 3 deletions(-)
-diff --git a/arch/arm/cpu/armv7/sunxi/clock_sun6i.c b/arch/arm/cpu/armv7/sunxi/clock_sun6i.c
-index 700b605..4e1e1a4 100644
--- a/arch/arm/cpu/armv7/sunxi/clock_sun6i.c
+++ b/arch/arm/cpu/armv7/sunxi/clock_sun6i.c
@@ -100,13 +100,18 @@ int clock_twi_onoff(int port, int state)
diff --git a/package/boot/uboot-sunxi/patches/013-enable-realtek-phy.patch b/package/boot/uboot-sunxi/patches/013-enable-realtek-phy.patch
index 521750c4ee..47f825c570 100644
--- a/package/boot/uboot-sunxi/patches/013-enable-realtek-phy.patch
+++ b/package/boot/uboot-sunxi/patches/013-enable-realtek-phy.patch
@@ -12,11 +12,9 @@ Acked-by: Ian Campbell <ijc@hellion.org.uk>
include/configs/sunxi-common.h | 1 +
1 file changed, 1 insertion(+)
-diff --git a/include/configs/sunxi-common.h b/include/configs/sunxi-common.h
-index b26363d..ea15e37 100644
--- a/include/configs/sunxi-common.h
+++ b/include/configs/sunxi-common.h
-@@ -310,6 +310,7 @@ extern int soft_i2c_gpio_scl;
+@@ -314,6 +314,7 @@ extern int soft_i2c_gpio_scl;
#define CONFIG_PHY_GIGE /* GMAC can use gigabit PHY */
#define CONFIG_PHY_ADDR 1
#define CONFIG_MII /* MII PHY management */
diff --git a/package/boot/uboot-sunxi/patches/014-fix-gmac-init.patch b/package/boot/uboot-sunxi/patches/014-fix-gmac-init.patch
index a4e43869a6..cf511ce773 100644
--- a/package/boot/uboot-sunxi/patches/014-fix-gmac-init.patch
+++ b/package/boot/uboot-sunxi/patches/014-fix-gmac-init.patch
@@ -28,11 +28,9 @@ Tested-by: Michael Haas <haas@computerlinguist.org>
board/sunxi/gmac.c | 14 +-------------
4 files changed, 12 insertions(+), 41 deletions(-)
-diff --git a/arch/arm/cpu/armv7/sunxi/board.c b/arch/arm/cpu/armv7/sunxi/board.c
-index e80785b..7653148 100644
--- a/arch/arm/cpu/armv7/sunxi/board.c
+++ b/arch/arm/cpu/armv7/sunxi/board.c
-@@ -152,6 +152,7 @@ void s_init(void)
+@@ -136,6 +136,7 @@ void s_init(void)
timer_init();
gpio_init();
i2c_init_board();
@@ -40,7 +38,7 @@ index e80785b..7653148 100644
}
#ifdef CONFIG_SPL_BUILD
-@@ -259,30 +260,3 @@ void enable_caches(void)
+@@ -243,30 +244,3 @@ void enable_caches(void)
dcache_enable();
}
#endif
@@ -71,8 +69,6 @@ index e80785b..7653148 100644
- return 0;
-}
-#endif
-diff --git a/arch/arm/include/asm/arch-sunxi/sys_proto.h b/arch/arm/include/asm/arch-sunxi/sys_proto.h
-index 9df3744..a373319 100644
--- a/arch/arm/include/asm/arch-sunxi/sys_proto.h
+++ b/arch/arm/include/asm/arch-sunxi/sys_proto.h
@@ -24,6 +24,10 @@ void sdelay(unsigned long);
@@ -87,8 +83,6 @@ index 9df3744..a373319 100644
+#endif
#endif
-diff --git a/board/sunxi/board.c b/board/sunxi/board.c
-index 80eae9c..e16718f 100644
--- a/board/sunxi/board.c
+++ b/board/sunxi/board.c
@@ -90,6 +90,11 @@ int board_init(void)
@@ -103,8 +97,6 @@ index 80eae9c..e16718f 100644
/* Uses dm gpio code so do this here and not in i2c_init_board() */
return soft_i2c_board_init();
}
-diff --git a/board/sunxi/gmac.c b/board/sunxi/gmac.c
-index 4e222d8..69eb8ff 100644
--- a/board/sunxi/gmac.c
+++ b/board/sunxi/gmac.c
@@ -6,7 +6,7 @@
diff --git a/package/boot/uboot-sunxi/patches/015-fix-2nd-usb-ctrler-on-sun47i.patch b/package/boot/uboot-sunxi/patches/015-fix-2nd-usb-ctrler-on-sun47i.patch
index 2d49194781..95a77c68d6 100644
--- a/package/boot/uboot-sunxi/patches/015-fix-2nd-usb-ctrler-on-sun47i.patch
+++ b/package/boot/uboot-sunxi/patches/015-fix-2nd-usb-ctrler-on-sun47i.patch
@@ -16,8 +16,6 @@ Acked-by: Ian Campbell <ijc@hellion.org.uk>
drivers/usb/host/ohci-sunxi.c | 15 ++++++++++++---
2 files changed, 23 insertions(+), 5 deletions(-)
-diff --git a/drivers/usb/host/ehci-sunxi.c b/drivers/usb/host/ehci-sunxi.c
-index cf3dcc4..677a5d3 100644
--- a/drivers/usb/host/ehci-sunxi.c
+++ b/drivers/usb/host/ehci-sunxi.c
@@ -17,6 +17,14 @@
@@ -35,7 +33,7 @@ index cf3dcc4..677a5d3 100644
struct ehci_sunxi_priv {
struct ehci_ctrl ehci;
int ahb_gate_mask; /* Mask of ahb_gate0 clk gate bits for this hcd */
-@@ -39,8 +47,9 @@ static int ehci_usb_probe(struct udevice *dev)
+@@ -39,8 +47,9 @@ static int ehci_usb_probe(struct udevice
#ifdef CONFIG_MACH_SUN8I_H3
priv->ahb_gate_mask |= 1 << AHB_GATE_OFFSET_USB_OHCI0;
#endif
@@ -47,8 +45,6 @@ index cf3dcc4..677a5d3 100644
setbits_le32(&ccm->ahb_gate0, priv->ahb_gate_mask);
#ifdef CONFIG_SUNXI_GEN_SUN6I
-diff --git a/drivers/usb/host/ohci-sunxi.c b/drivers/usb/host/ohci-sunxi.c
-index 1b1f651..d4fb95a 100644
--- a/drivers/usb/host/ohci-sunxi.c
+++ b/drivers/usb/host/ohci-sunxi.c
@@ -17,6 +17,14 @@
@@ -66,7 +62,7 @@ index 1b1f651..d4fb95a 100644
struct ohci_sunxi_priv {
ohci_t ohci;
int ahb_gate_mask; /* Mask of ahb_gate0 clk gate bits for this hcd */
-@@ -42,9 +50,10 @@ static int ohci_usb_probe(struct udevice *dev)
+@@ -42,9 +50,10 @@ static int ohci_usb_probe(struct udevice
priv->ahb_gate_mask |= 1 << AHB_GATE_OFFSET_USB_EHCI0;
#endif
priv->usb_gate_mask = CCM_USB_CTRL_OHCI0_CLK;
diff --git a/package/boot/uboot-sunxi/patches/016-spl-print-mmc-slot.patch b/package/boot/uboot-sunxi/patches/016-spl-print-mmc-slot.patch
index 65b1fd1c07..04a2af72ee 100644
--- a/package/boot/uboot-sunxi/patches/016-spl-print-mmc-slot.patch
+++ b/package/boot/uboot-sunxi/patches/016-spl-print-mmc-slot.patch
@@ -14,11 +14,9 @@ Reviewed-by: Tom Rini <trini@konsulko.com>
common/spl/spl.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
-diff --git a/common/spl/spl.c b/common/spl/spl.c
-index e5167bf..82e7f58 100644
--- a/common/spl/spl.c
+++ b/common/spl/spl.c
-@@ -210,9 +210,9 @@ struct boot_device_name boot_name_table[] = {
+@@ -210,9 +210,9 @@ struct boot_device_name boot_name_table[
{ BOOT_DEVICE_RAM, "RAM" },
#endif
#ifdef CONFIG_SPL_MMC_SUPPORT
diff --git a/package/boot/uboot-sunxi/patches/017-usb-add-support-for-usb3-vbus-pin.patch b/package/boot/uboot-sunxi/patches/017-usb-add-support-for-usb3-vbus-pin.patch
index 8c67063688..098fe72035 100644
--- a/package/boot/uboot-sunxi/patches/017-usb-add-support-for-usb3-vbus-pin.patch
+++ b/package/boot/uboot-sunxi/patches/017-usb-add-support-for-usb3-vbus-pin.patch
@@ -12,8 +12,6 @@ Acked-by: Ian Campbell <ijc@hellion.org.uk>
board/sunxi/Kconfig | 6 ++++++
2 files changed, 7 insertions(+)
-diff --git a/arch/arm/cpu/armv7/sunxi/usb_phy.c b/arch/arm/cpu/armv7/sunxi/usb_phy.c
-index 6ac96cc..0749fbd 100644
--- a/arch/arm/cpu/armv7/sunxi/usb_phy.c
+++ b/arch/arm/cpu/armv7/sunxi/usb_phy.c
@@ -76,6 +76,7 @@ static int get_vbus_gpio(int index)
@@ -24,11 +22,9 @@ index 6ac96cc..0749fbd 100644
}
return -EINVAL;
}
-diff --git a/board/sunxi/Kconfig b/board/sunxi/Kconfig
-index 5e9d3af..5e72fac 100644
--- a/board/sunxi/Kconfig
+++ b/board/sunxi/Kconfig
-@@ -342,6 +342,12 @@ config USB2_VBUS_PIN
+@@ -341,6 +341,12 @@ config USB2_VBUS_PIN
---help---
See USB1_VBUS_PIN help text.
diff --git a/package/boot/uboot-sunxi/patches/018-usb-specify-vbus-pins-on-orangepis.patch b/package/boot/uboot-sunxi/patches/018-usb-specify-vbus-pins-on-orangepis.patch
index 4d2a583d06..a216bc9f11 100644
--- a/package/boot/uboot-sunxi/patches/018-usb-specify-vbus-pins-on-orangepis.patch
+++ b/package/boot/uboot-sunxi/patches/018-usb-specify-vbus-pins-on-orangepis.patch
@@ -13,8 +13,6 @@ Acked-by: Ian Campbell <ijc@hellion.org.uk>
configs/orangepi_plus_defconfig | 1 +
2 files changed, 4 insertions(+)
-diff --git a/configs/orangepi_pc_defconfig b/configs/orangepi_pc_defconfig
-index aaf0f68..4e9051d 100644
--- a/configs/orangepi_pc_defconfig
+++ b/configs/orangepi_pc_defconfig
@@ -14,3 +14,6 @@ CONFIG_SPL=y
@@ -24,8 +22,6 @@ index aaf0f68..4e9051d 100644
+CONFIG_USB1_VBUS_PIN=""
+CONFIG_USB2_VBUS_PIN=""
+CONFIG_USB3_VBUS_PIN=""
-diff --git a/configs/orangepi_plus_defconfig b/configs/orangepi_plus_defconfig
-index e52dcfc..6ecb30e 100644
--- a/configs/orangepi_plus_defconfig
+++ b/configs/orangepi_plus_defconfig
@@ -14,3 +14,4 @@ CONFIG_SPL=y
diff --git a/package/boot/uboot-sunxi/patches/019-sid-add-efuse-support-for-h3-a83t.patch b/package/boot/uboot-sunxi/patches/019-sid-add-efuse-support-for-h3-a83t.patch
index 6ceccbd6ee..e7b8cd73df 100644
--- a/package/boot/uboot-sunxi/patches/019-sid-add-efuse-support-for-h3-a83t.patch
+++ b/package/boot/uboot-sunxi/patches/019-sid-add-efuse-support-for-h3-a83t.patch
@@ -14,8 +14,6 @@ Signed-off-by: Hans de Goede <hdegoede@redhat.com>
arch/arm/include/asm/arch-sunxi/cpu_sun4i.h | 7 +++++++
1 file changed, 7 insertions(+)
-diff --git a/arch/arm/include/asm/arch-sunxi/cpu_sun4i.h b/arch/arm/include/asm/arch-sunxi/cpu_sun4i.h
-index b6e11eb..65c0441 100644
--- a/arch/arm/include/asm/arch-sunxi/cpu_sun4i.h
+++ b/arch/arm/include/asm/arch-sunxi/cpu_sun4i.h
@@ -82,7 +82,14 @@
diff --git a/package/boot/uboot-sunxi/patches/020-boot-display-board-model-on-startup.patch b/package/boot/uboot-sunxi/patches/020-boot-display-board-model-on-startup.patch
index 64dff485e3..d49fc97373 100644
--- a/package/boot/uboot-sunxi/patches/020-boot-display-board-model-on-startup.patch
+++ b/package/boot/uboot-sunxi/patches/020-boot-display-board-model-on-startup.patch
@@ -11,8 +11,6 @@ Signed-off-by: Simon Glass <sjg@chromium.org>
include/configs/sunxi-common.h | 1 +
1 file changed, 1 insertion(+)
-diff --git a/include/configs/sunxi-common.h b/include/configs/sunxi-common.h
-index ff356e3..b26363d 100644
--- a/include/configs/sunxi-common.h
+++ b/include/configs/sunxi-common.h
@@ -174,6 +174,7 @@
diff --git a/package/boot/uboot-sunxi/patches/091-sun6i-sync-PLL1-multdiv-with-Boot1.patch b/package/boot/uboot-sunxi/patches/091-sun6i-sync-PLL1-multdiv-with-Boot1.patch
index f782994c14..a402feb3cd 100644
--- a/package/boot/uboot-sunxi/patches/091-sun6i-sync-PLL1-multdiv-with-Boot1.patch
+++ b/package/boot/uboot-sunxi/patches/091-sun6i-sync-PLL1-multdiv-with-Boot1.patch
@@ -12,11 +12,9 @@ More specifically, the following settings are now used:
* up to 1152MHz: mul=3, div=2 (unchanged)
* above 1152MHz: mul=4, div=2 (was: mul=2, div=1)
-diff --git a/arch/arm/cpu/armv7/sunxi/clock_sun6i.c b/arch/arm/cpu/armv7/sunxi/clock_sun6i.c
-index cfb32b4..2986539 100644
--- a/arch/arm/cpu/armv7/sunxi/clock_sun6i.c
+++ b/arch/arm/cpu/armv7/sunxi/clock_sun6i.c
-@@ -102,11 +102,12 @@ void clock_set_pll1(unsigned int clk)
+@@ -122,11 +122,12 @@ void clock_set_pll1(unsigned int clk)
struct sunxi_ccm_reg * const ccm =
(struct sunxi_ccm_reg *)SUNXI_CCM_BASE;
const int p = 0;
@@ -32,6 +30,3 @@ index cfb32b4..2986539 100644
} else if (clk > 768000000) {
k = 3;
m = 2;
---
-cgit v0.10.2
-
diff --git a/package/boot/uboot-sunxi/patches/093-sun6i-fix-PLL-LDO-voltselect.patch b/package/boot/uboot-sunxi/patches/093-sun6i-fix-PLL-LDO-voltselect.patch
index e6af765cae..d200633bc2 100644
--- a/package/boot/uboot-sunxi/patches/093-sun6i-fix-PLL-LDO-voltselect.patch
+++ b/package/boot/uboot-sunxi/patches/093-sun6i-fix-PLL-LDO-voltselect.patch
@@ -16,8 +16,6 @@ order of magnitude as Boot1.
Furthermore, a bit of documentation is added to clarify that the
required setting for the PLL LDO is 1.37v as per the A31 manual.
-diff --git a/arch/arm/cpu/armv7/sunxi/clock_sun6i.c b/arch/arm/cpu/armv7/sunxi/clock_sun6i.c
-index fa7ebd8..3a6e56e 100644
--- a/arch/arm/cpu/armv7/sunxi/clock_sun6i.c
+++ b/arch/arm/cpu/armv7/sunxi/clock_sun6i.c
@@ -24,14 +24,27 @@ void clock_init_safe(void)
@@ -49,9 +47,7 @@ index fa7ebd8..3a6e56e 100644
+
clock_set_pll1(408000000);
- writel(AHB1_ABP1_DIV_DEFAULT, &ccm->ahb1_apb1_div);
-diff --git a/arch/arm/include/asm/arch-sunxi/prcm.h b/arch/arm/include/asm/arch-sunxi/prcm.h
-index 82ed541..41a62a4 100644
+ writel(PLL6_CFG_DEFAULT, &ccm->pll6_cfg);
--- a/arch/arm/include/asm/arch-sunxi/prcm.h
+++ b/arch/arm/include/asm/arch-sunxi/prcm.h
@@ -111,13 +111,13 @@
@@ -72,6 +68,3 @@ index 82ed541..41a62a4 100644
__PRCM_PLL_CTRL_VDD_LDO_OUT((((n) & 0x7) * 30) + 1160)
#define PRCM_PLL_CTRL_LDO_KEY (0xa7 << 24)
#define PRCM_PLL_CTRL_LDO_KEY_MASK (0xff << 24)
---
-cgit v0.10.2
-
diff --git a/package/boot/uboot-sunxi/patches/100-sun6i-alternate-on-UART2.patch b/package/boot/uboot-sunxi/patches/100-sun6i-alternate-on-UART2.patch
index 46c497269a..bf5dc66e1a 100644
--- a/package/boot/uboot-sunxi/patches/100-sun6i-alternate-on-UART2.patch
+++ b/package/boot/uboot-sunxi/patches/100-sun6i-alternate-on-UART2.patch
@@ -4,11 +4,9 @@ Date: Tue, 16 Jun 2015 10:52:01 +0200
Subject: sun6i: define alternate-function for UART2 on GPG
-diff --git a/arch/arm/include/asm/arch-sunxi/gpio.h b/arch/arm/include/asm/arch-sunxi/gpio.h
-index 8e67b3b..1fbf494 100644
--- a/arch/arm/include/asm/arch-sunxi/gpio.h
+++ b/arch/arm/include/asm/arch-sunxi/gpio.h
-@@ -177,6 +177,7 @@ enum sunxi_gpio_number {
+@@ -180,6 +180,7 @@ enum sunxi_gpio_number {
#define SUN6I_GPG_SDC1 2
#define SUN8I_GPG_SDC1 2
#define SUN6I_GPG_TWI3 2
@@ -16,6 +14,3 @@ index 8e67b3b..1fbf494 100644
#define SUN5I_GPG_UART1 4
#define SUN4I_GPH_SDC1 5
---
-cgit v0.10.2
-
diff --git a/package/boot/uboot-sunxi/patches/101-sun6i-support-console-on-UART2.patch b/package/boot/uboot-sunxi/patches/101-sun6i-support-console-on-UART2.patch
index 2b17999fb9..087074d0c9 100644
--- a/package/boot/uboot-sunxi/patches/101-sun6i-support-console-on-UART2.patch
+++ b/package/boot/uboot-sunxi/patches/101-sun6i-support-console-on-UART2.patch
@@ -4,11 +4,9 @@ Date: Tue, 16 Jun 2015 10:53:11 +0200
Subject: ARM: sun6i: Support console on UART2 (GPG6/GPG7)
-diff --git a/arch/arm/cpu/armv7/sunxi/board.c b/arch/arm/cpu/armv7/sunxi/board.c
-index 5f39aa0..99675c3 100644
--- a/arch/arm/cpu/armv7/sunxi/board.c
+++ b/arch/arm/cpu/armv7/sunxi/board.c
-@@ -76,6 +76,10 @@ static int gpio_init(void)
+@@ -88,6 +88,10 @@ static int gpio_init(void)
sunxi_gpio_set_cfgpin(SUNXI_GPG(3), SUN5I_GPG_UART1);
sunxi_gpio_set_cfgpin(SUNXI_GPG(4), SUN5I_GPG_UART1);
sunxi_gpio_set_pull(SUNXI_GPG(4), SUNXI_GPIO_PULL_UP);
@@ -19,8 +17,6 @@ index 5f39aa0..99675c3 100644
#elif CONFIG_CONS_INDEX == 3 && defined(CONFIG_MACH_SUN8I)
sunxi_gpio_set_cfgpin(SUNXI_GPB(0), SUN8I_GPB_UART2);
sunxi_gpio_set_cfgpin(SUNXI_GPB(1), SUN8I_GPB_UART2);
-diff --git a/include/configs/sunxi-common.h b/include/configs/sunxi-common.h
-index 9576bc1..bda4059 100644
--- a/include/configs/sunxi-common.h
+++ b/include/configs/sunxi-common.h
@@ -260,6 +260,8 @@ extern int soft_i2c_gpio_scl;
@@ -32,6 +28,3 @@ index 9576bc1..bda4059 100644
#elif CONFIG_CONS_INDEX == 3 && defined(CONFIG_MACH_SUN8I)
#define OF_STDOUT_PATH "/soc@01c00000/serial@01c28800:115200"
#elif CONFIG_CONS_INDEX == 5 && defined(CONFIG_MACH_SUN8I)
---
-cgit v0.10.2
-
diff --git a/package/boot/uboot-sunxi/patches/102-sunxi-make_CONS_INDEX-configurable.patch b/package/boot/uboot-sunxi/patches/102-sunxi-make_CONS_INDEX-configurable.patch
index bf00343ac9..ee1e3c9bfa 100644
--- a/package/boot/uboot-sunxi/patches/102-sunxi-make_CONS_INDEX-configurable.patch
+++ b/package/boot/uboot-sunxi/patches/102-sunxi-make_CONS_INDEX-configurable.patch
@@ -4,11 +4,9 @@ Date: Tue, 16 Jun 2015 10:59:38 +0200
Subject: ARM: sunxi: Make CONS_INDEX configurable
-diff --git a/board/sunxi/Kconfig b/board/sunxi/Kconfig
-index 2a1cd3c..e155c4c 100644
--- a/board/sunxi/Kconfig
+++ b/board/sunxi/Kconfig
-@@ -209,6 +209,14 @@ config SYS_BOARD
+@@ -229,6 +229,14 @@ config SYS_BOARD
config SYS_SOC
default "sunxi"
@@ -23,6 +21,3 @@ index 2a1cd3c..e155c4c 100644
config UART0_PORT_F
bool "UART0 on MicroSD breakout board"
default n
---
-cgit v0.10.2
-