aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRalph Sennhauser <ralph.sennhauser@gmail.com>2016-09-29 01:46:36 +0200
committerRalph Sennhauser <ralph.sennhauser@gmail.com>2016-11-13 21:45:42 +0100
commit153e1e9abf613630d39e9feb2a894080c6cbf245 (patch)
treeee76bbbb8bd643e710b0e54332e3b8bd56ebdf18
parent3f98448d670ab2e908c8d6002d8c6f8ff5d1d9bd (diff)
downloadmaster-187ad058-153e1e9abf613630d39e9feb2a894080c6cbf245.tar.gz
master-187ad058-153e1e9abf613630d39e9feb2a894080c6cbf245.tar.bz2
master-187ad058-153e1e9abf613630d39e9feb2a894080c6cbf245.zip
kernel: spidev-test: moved to tools/ in Linux 4.5
Commit 5eca4d843f9f0c3140a8657ba2f8217ee6c08c11 moves spidev_test.c from Documentation/ to tools/. Signed-off-by: Ralph Sennhauser <ralph.sennhauser@gmail.com>
-rw-r--r--package/utils/spidev_test/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/package/utils/spidev_test/Makefile b/package/utils/spidev_test/Makefile
index 807039a1f5..2a2122cfbd 100644
--- a/package/utils/spidev_test/Makefile
+++ b/package/utils/spidev_test/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,6 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=spidev-test
-PKG_RELEASE:=$(LINUX_VERSION)
include $(INCLUDE_DIR)/package.mk
@@ -18,21 +17,26 @@ define Package/spidev-test
CATEGORY:=Utilities
DEPENDS:=+kmod-spi-dev
TITLE:=SPI testing utility
- VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
+ VERSION:=$(LINUX_VERSION)
URL:=http://www.kernel.org
- MAINTAINER:=Florian Fainelli <florian@openwrt.org>
endef
define Package/spidev-test/description
SPI testing utility.
endef
+ifeq ($(call kernel_patchver_ge,4.5.0),1)
+ SPIDEV_TEST_C:=$(LINUX_DIR)/tools/spi/spidev_test.c
+else
+ SPIDEV_TEST_C:=$(LINUX_DIR)/Documentation/spi/spidev_test.c
+endif
+
define Build/Prepare
endef
define Build/Compile
$(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/spidev_test \
- $(LINUX_DIR)/Documentation/spi/spidev_test.c
+ $(SPIDEV_TEST_C)
endef
define Package/spidev-test/install