aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZoltan Herpai <wigyori@uid0.hu>2016-11-23 12:11:51 +0100
committerGitHub <noreply@github.com>2016-11-23 12:11:51 +0100
commit097520a257359f19327356f68fda75daff08c59c (patch)
tree55a87b47047bd93cbe55bc6d5fd4b58ff1fb294b
parent3e4dd934820b137cae155f01422f332826ccea05 (diff)
parent46e8df5ea79533a27690aa21ab4e6c569bae001e (diff)
downloadmaster-187ad058-097520a257359f19327356f68fda75daff08c59c.tar.gz
master-187ad058-097520a257359f19327356f68fda75daff08c59c.tar.bz2
master-187ad058-097520a257359f19327356f68fda75daff08c59c.zip
Merge pull request #211 from seragh/owrt-arptables-2015-05-20
arptables: bump to 2015-05-20
-rw-r--r--package/network/utils/arptables/Makefile26
-rw-r--r--package/network/utils/arptables/patches/100-always_optimize.patch19
-rw-r--r--package/network/utils/arptables/patches/200-musl_fixes.patch31
3 files changed, 12 insertions, 64 deletions
diff --git a/package/network/utils/arptables/Makefile b/package/network/utils/arptables/Makefile
index 62681dcd59..bae843a4ff 100644
--- a/package/network/utils/arptables/Makefile
+++ b/package/network/utils/arptables/Makefile
@@ -1,4 +1,4 @@
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,15 +7,16 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=arptables
-PKG_VERSION:=0.0.4
+PKG_VERSION:=2015-05-20
PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/ebtables
-PKG_MD5SUM:=c2e99c3aa9d78c9dfa30710ca3168182
-PKG_LICENSE:=GPL-2.0
+PKG_SOURCE_URL:=git://git.netfilter.org/arptables
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=f4ab8f63f11a72f14687a6646d04ae1bae3fa45f
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-v$(PKG_VERSION)
+PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
@@ -25,15 +26,12 @@ define Package/arptables
SUBMENU:=Firewall
TITLE:=ARP firewalling software
DEPENDS:=+kmod-arptables
- URL:=http://ebtables.sourceforge.net
+ URL:=https://git.netfilter.org/arptables/
endef
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- COPT_FLAGS="$(TARGET_CFLAGS)" \
- KERNEL_DIR="./include/linux"
-endef
+MAKE_FLAGS += \
+ COPT_FLAGS="$(TARGET_CFLAGS) -D__OPTIMIZE__=1" \
+ KERNEL_DIR="$(LINUX_DIR)"
define Package/arptables/install
$(INSTALL_DIR) $(1)/usr/sbin
diff --git a/package/network/utils/arptables/patches/100-always_optimize.patch b/package/network/utils/arptables/patches/100-always_optimize.patch
deleted file mode 100644
index b120eb783a..0000000000
--- a/package/network/utils/arptables/patches/100-always_optimize.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Index: arptables-v0.0.3-4/libarptc/libarptc_incl.c
-===================================================================
---- arptables-v0.0.3-4.orig/libarptc/libarptc_incl.c 2010-03-08 16:49:28.000000000 +0100
-+++ arptables-v0.0.3-4/libarptc/libarptc_incl.c 2012-08-14 12:10:29.527945144 +0200
-@@ -11,14 +11,6 @@
- /* (C)1999 Paul ``Rusty'' Russell - Placed under the GNU GPL (See
- COPYING for details). */
-
--#ifndef __OPTIMIZE__
--STRUCT_ENTRY_TARGET *
--GET_TARGET(STRUCT_ENTRY *e)
--{
-- return (void *)e + e->target_offset;
--}
--#endif
--
- static int sockfd = -1;
- static void *arptc_fn = NULL;
-
diff --git a/package/network/utils/arptables/patches/200-musl_fixes.patch b/package/network/utils/arptables/patches/200-musl_fixes.patch
deleted file mode 100644
index 3a4ba3fb03..0000000000
--- a/package/network/utils/arptables/patches/200-musl_fixes.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/include/arptables.h
-+++ b/include/arptables.h
-@@ -1,6 +1,7 @@
- #ifndef _ARPTABLES_USER_H
- #define _ARPTABLES_USER_H
-
-+#include <sys/types.h>
- #include "arptables_common.h"
- #include "libarptc/libarptc.h"
-
---- a/arptables.c
-+++ b/arptables.c
-@@ -43,6 +43,7 @@
- #include <arptables.h>
- #include <fcntl.h>
- #include <sys/wait.h>
-+#include <net/ethernet.h>
-
- #ifndef TRUE
- #define TRUE 1
---- a/include/libarptc/arpt_kernel_headers.h
-+++ b/include/libarptc/arpt_kernel_headers.h
-@@ -5,7 +5,7 @@
-
- #include <limits.h>
-
--#if defined(__GLIBC__) && __GLIBC__ == 2
-+#if 1
- #include <netinet/ip.h>
- #include <netinet/in.h>
- #include <netinet/ip_icmp.h>