summaryrefslogtreecommitdiffstats
path: root/tools/upx
diff options
context:
space:
mode:
Diffstat (limited to 'tools/upx')
-rw-r--r--tools/upx/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/tools/upx/Makefile b/tools/upx/Makefile
index 2f3313ca38..339c611154 100644
--- a/tools/upx/Makefile
+++ b/tools/upx/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2011-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -21,7 +21,7 @@ include $(INCLUDE_DIR)/host-build.mk
define Host/Compile
rm -f $(HOST_BUILD_DIR)/src/.depend
$(MAKE) UPX_LZMADIR="$(BUILD_DIR_HOST)/lzma-4.65" -C $(HOST_BUILD_DIR)/src \
- CXXFLAGS_WERROR=
+ CXXFLAGS_WERROR="" LDFLAGS="$(HOST_LDFLAGS) -static"
endef
define Host/Install