summaryrefslogtreecommitdiffstats
path: root/tools/squashfs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/squashfs/Makefile')
-rw-r--r--tools/squashfs/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/squashfs/Makefile b/tools/squashfs/Makefile
index c6ad3dd1be..f4a5460135 100644
--- a/tools/squashfs/Makefile
+++ b/tools/squashfs/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -21,6 +21,7 @@ include $(INCLUDE_DIR)/host-build.mk
define Host/Compile
$(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
CC="$(HOSTCC)" \
+ CXX="$(CXX) -static" \
LZMAPATH=$(STAGING_DIR_HOST)/lib \
mksquashfs-lzma unsquashfs-lzma
endef