summaryrefslogtreecommitdiffstats
path: root/tools/scons/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/scons/Makefile')
-rw-r--r--tools/scons/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/tools/scons/Makefile b/tools/scons/Makefile
index aadeb289a2..83c1c584a5 100644
--- a/tools/scons/Makefile
+++ b/tools/scons/Makefile
@@ -23,7 +23,12 @@ define Host/Compile
endef
define Host/Install
- python $(HOST_BUILD_DIR)/setup.py install --prefix=$(STAGING_DIR_HOST)
+ ./files/pywrap.sh $(HOST_BUILD_DIR)/setup.py install --prefix=$(STAGING_DIR_HOST)
+ rm -f $(STAGING_DIR_HOST)/bin/scons*.py
+ for bin in $(STAGING_DIR_HOST)/bin/scons*; do \
+ mv "$$$$bin" "$$$$bin.py"; \
+ cp ./files/pywrap.sh "$$$$bin"; \
+ done
endef
$(eval $(call HostBuild))