summaryrefslogtreecommitdiffstats
path: root/tools/quilt/patches/100-patch_2.6.1_version.patch
diff options
context:
space:
mode:
Diffstat (limited to 'tools/quilt/patches/100-patch_2.6.1_version.patch')
-rw-r--r--tools/quilt/patches/100-patch_2.6.1_version.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/tools/quilt/patches/100-patch_2.6.1_version.patch b/tools/quilt/patches/100-patch_2.6.1_version.patch
new file mode 100644
index 0000000000..84f275318c
--- /dev/null
+++ b/tools/quilt/patches/100-patch_2.6.1_version.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -274,7 +274,7 @@ fi
+ AC_MSG_CHECKING([the version of $PATCH])
+ if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
+ set -- `$PATCH --version 2> /dev/null`
+- patch_version=$2
++ test $2 == "patch" && patch_version=$3 || patch_version=$2
+ AC_MSG_RESULT($patch_version)
+ saved_IFS=$IFS; IFS='.'
+ set -- $patch_version