summaryrefslogtreecommitdiffstats
path: root/tools/pkg-config/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/pkg-config/Makefile')
-rw-r--r--tools/pkg-config/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/tools/pkg-config/Makefile b/tools/pkg-config/Makefile
index 9a1b3fb986..40e6e083e8 100644
--- a/tools/pkg-config/Makefile
+++ b/tools/pkg-config/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2013 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,11 +7,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=pkg-config
-PKG_VERSION:=0.28
+PKG_VERSION:=0.29
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://pkgconfig.freedesktop.org/releases/
-PKG_MD5SUM:=aa3c86e67551adc3ac865160e34a2a0d
+PKG_MD5SUM:=77f27dce7ef88d0634d0d6f90e03a77f
HOST_BUILD_PARALLEL:=1
@@ -21,6 +21,10 @@ unexport PKG_CONFIG
HOST_CONFIGURE_ARGS += --with-internal-glib
+ifeq ($(HOST_OS),Darwin)
+HOST_LDFLAGS += -framework CoreFoundation -framework Carbon
+endif
+
define Host/Install
$(MAKE) -C $(HOST_BUILD_DIR) install
mv $(STAGING_DIR_HOST)/bin/pkg-config $(STAGING_DIR_HOST)/bin/pkg-config.real