summaryrefslogtreecommitdiffstats
path: root/tools/mtd-utils/patches/101-ubifs-optional_lzo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mtd-utils/patches/101-ubifs-optional_lzo.patch')
-rw-r--r--tools/mtd-utils/patches/101-ubifs-optional_lzo.patch84
1 files changed, 0 insertions, 84 deletions
diff --git a/tools/mtd-utils/patches/101-ubifs-optional_lzo.patch b/tools/mtd-utils/patches/101-ubifs-optional_lzo.patch
index 7ab4f63ba1..e69de29bb2 100644
--- a/tools/mtd-utils/patches/101-ubifs-optional_lzo.patch
+++ b/tools/mtd-utils/patches/101-ubifs-optional_lzo.patch
@@ -1,84 +0,0 @@
---- a/mkfs.ubifs/Makefile
-+++ b/mkfs.ubifs/Makefile
-@@ -6,7 +6,7 @@ ALL_SOURCES=*.[ch] hashtable/*.[ch]
-
- TARGETS = mkfs.ubifs
-
--LDLIBS_mkfs.ubifs = -lz -llzo2 -lm -luuid -L$(BUILDDIR)/../ubi-utils/ -lubi
-+LDLIBS_mkfs.ubifs = -lz $(if,$(NO_LZO),,-llzo2) -lm -luuid -L$(BUILDDIR)/../ubi-utils/ -lubi
- LDLIBS_mkfs.ubifs += -L$(BUILDDIR)/../lib -lmtd -lcrc32
- LDLIBS_mkfs.ubifs += $(ZLIBLDFLAGS) $(LZOLDFLAGS)
-
---- a/mkfs.ubifs/compr.c
-+++ b/mkfs.ubifs/compr.c
-@@ -24,7 +24,9 @@
- #include <stdio.h>
- #include <stdint.h>
- #include <string.h>
-+#if CONFIG_UBIFS_LZO
- #include <lzo/lzo1x.h>
-+#endif
- #include <linux/types.h>
-
- #define crc32 __zlib_crc32
-@@ -86,6 +88,16 @@ static int zlib_deflate(void *in_buf, si
- return 0;
- }
-
-+static int no_compress(void *in_buf, size_t in_len, void *out_buf,
-+ size_t *out_len)
-+{
-+ memcpy(out_buf, in_buf, in_len);
-+ *out_len = in_len;
-+ return 0;
-+}
-+
-+#if CONFIG_UBIFS_LZO
-+
- static int lzo_compress(void *in_buf, size_t in_len, void *out_buf,
- size_t *out_len)
- {
-@@ -104,14 +116,16 @@ static int lzo_compress(void *in_buf, si
- return 0;
- }
-
--static int no_compress(void *in_buf, size_t in_len, void *out_buf,
-- size_t *out_len)
-+#else
-+
-+static int lzo_compress(void *in_buf, size_t in_len, void *out_buf,
-+ size_t *out_len)
- {
-- memcpy(out_buf, in_buf, in_len);
-- *out_len = in_len;
-- return 0;
-+ return 1;
- }
-
-+#endif
-+
- static char *zlib_buf;
-
- static int favor_lzo_compress(void *in_buf, size_t in_len, void *out_buf,
-@@ -198,9 +212,11 @@ int compress_data(void *in_buf, size_t i
-
- int init_compression(void)
- {
-+#ifdef CONFIG_UBIFS_LZO
- lzo_mem = malloc(LZO1X_999_MEM_COMPRESS);
- if (!lzo_mem)
- return -1;
-+#endif
-
- zlib_buf = malloc(UBIFS_BLOCK_SIZE * WORST_COMPR_FACTOR);
- if (!zlib_buf) {
-@@ -214,7 +230,9 @@ int init_compression(void)
- void destroy_compression(void)
- {
- free(zlib_buf);
-+#ifdef CONFIG_UBIFS_LZO
- free(lzo_mem);
-+#endif
- if (errcnt)
- fprintf(stderr, "%llu compression errors occurred\n", errcnt);
- }