summaryrefslogtreecommitdiffstats
path: root/tools/mkimage/patches
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mkimage/patches')
-rw-r--r--tools/mkimage/patches/010-freebsd-ulong-fix.patch2
-rw-r--r--tools/mkimage/patches/040-include_order.patch2
-rw-r--r--tools/mkimage/patches/050-image_h_portability.patch2
3 files changed, 3 insertions, 3 deletions
diff --git a/tools/mkimage/patches/010-freebsd-ulong-fix.patch b/tools/mkimage/patches/010-freebsd-ulong-fix.patch
index 154346d8be..75b9e892ad 100644
--- a/tools/mkimage/patches/010-freebsd-ulong-fix.patch
+++ b/tools/mkimage/patches/010-freebsd-ulong-fix.patch
@@ -9,5 +9,5 @@
+#endif
+
#if defined(CONFIG_FIT)
+ #include <hash.h>
#include <libfdt.h>
- #include <fdt_support.h>
diff --git a/tools/mkimage/patches/040-include_order.patch b/tools/mkimage/patches/040-include_order.patch
index f4fbbaf757..66f703c855 100644
--- a/tools/mkimage/patches/040-include_order.patch
+++ b/tools/mkimage/patches/040-include_order.patch
@@ -1,6 +1,6 @@
--- a/tools/Makefile
+++ b/tools/Makefile
-@@ -173,7 +173,7 @@
+@@ -193,7 +193,7 @@
# Define _GNU_SOURCE to obtain the getline prototype from stdio.h
#
HOST_EXTRACFLAGS += -include $(srctree)/include/libfdt_env.h \
diff --git a/tools/mkimage/patches/050-image_h_portability.patch b/tools/mkimage/patches/050-image_h_portability.patch
index 767a8b8713..304a7aa247 100644
--- a/tools/mkimage/patches/050-image_h_portability.patch
+++ b/tools/mkimage/patches/050-image_h_portability.patch
@@ -8,7 +8,7 @@
/* Define this to avoid #ifdefs later on */
struct lmb;
-@@ -240,13 +239,13 @@
+@@ -257,13 +256,13 @@
* all data in network byte order (aka natural aka bigendian).
*/
typedef struct image_header {