summaryrefslogtreecommitdiffstats
path: root/tools/mkimage/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mkimage/Makefile')
-rw-r--r--tools/mkimage/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/tools/mkimage/Makefile b/tools/mkimage/Makefile
index 49eb26184d..2de13ab77b 100644
--- a/tools/mkimage/Makefile
+++ b/tools/mkimage/Makefile
@@ -7,11 +7,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mkimage
-PKG_VERSION:=2014.07
+PKG_VERSION:=2014.10
PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=36d4bad687edcafa396fee607e505d4e
+PKG_SOURCE_URL:=\
+ http://mirror2.openwrt.org/sources \
+ ftp://ftp.denx.de/pub/u-boot
+PKG_MD5SUM:=3ddcaee2f05b7c464778112ec83664b5
PKG_CAT:=bzcat
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
@@ -29,6 +31,7 @@ define Host/Prepare
endef
define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR) defconfig
$(MAKE) -C $(HOST_BUILD_DIR) \
HOSTLDFLAGS="$(HOST_STATIC_LINKING)" \
tools-only