summaryrefslogtreecommitdiffstats
path: root/tools/mkelfimage/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mkelfimage/Makefile')
-rw-r--r--tools/mkelfimage/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/tools/mkelfimage/Makefile b/tools/mkelfimage/Makefile
new file mode 100644
index 0000000000..75cff88d93
--- /dev/null
+++ b/tools/mkelfimage/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mkelfimage
+PKG_VERSION:=2.7
+
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
+PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/m/mkelfimage/
+PKG_MD5SUM:=e505cb87e9c0cdc44cf03d2c4ea8c74b
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Install
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/objdir/sbin/mkelfImage $(STAGING_DIR_HOST)/bin
+endef
+
+$(eval $(call HostBuild))