summaryrefslogtreecommitdiffstats
path: root/tools/libressl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/libressl/Makefile')
-rw-r--r--tools/libressl/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/tools/libressl/Makefile b/tools/libressl/Makefile
new file mode 100644
index 0000000000..bdf34d3138
--- /dev/null
+++ b/tools/libressl/Makefile
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2016 LEDE project
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libressl
+PKG_VERSION:=2.3.4
+PKG_MD5SUM:=b81d990b7eceb156df6eaa7e9f4a353e
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://ftp.openbsd.org/pub/OpenBSD/LibreSSL/
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+$(eval $(call HostBuild))