summaryrefslogtreecommitdiffstats
path: root/tools/isl
diff options
context:
space:
mode:
Diffstat (limited to 'tools/isl')
-rw-r--r--tools/isl/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/tools/isl/Makefile b/tools/isl/Makefile
new file mode 100644
index 0000000000..8fe2da1a06
--- /dev/null
+++ b/tools/isl/Makefile
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2009-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=isl
+PKG_VERSION:=0.14.1
+
+PKG_SOURCE_URL:=http://isl.gforge.inria.fr
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_MD5SUM:=94fcd11e0b1c79250ae341affb1845ea
+
+HOST_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+unexport CFLAGS
+
+HOST_CONFIGURE_ARGS += \
+ --enable-static \
+ --disable-shared \
+ --with-gmp-prefix=$(STAGING_DIR_HOST)
+
+$(eval $(call HostBuild))