summaryrefslogtreecommitdiffstats
path: root/tools/flex
diff options
context:
space:
mode:
Diffstat (limited to 'tools/flex')
-rw-r--r--tools/flex/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/tools/flex/Makefile b/tools/flex/Makefile
new file mode 100644
index 0000000000..9d4ae136b4
--- /dev/null
+++ b/tools/flex/Makefile
@@ -0,0 +1,32 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=flex
+PKG_VERSION:=2.5.35
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=10714e50cea54dc7a227e3eddcd44d57
+PKG_CAT:=bzcat
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR)
+endef
+
+define Host/Install
+ $(MAKE) -C $(HOST_BUILD_DIR) install
+endef
+
+define Host/Clean
+ -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+ $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))