summaryrefslogtreecommitdiffstats
path: root/tools/e2fsprogs
diff options
context:
space:
mode:
Diffstat (limited to 'tools/e2fsprogs')
-rw-r--r--tools/e2fsprogs/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/tools/e2fsprogs/Makefile b/tools/e2fsprogs/Makefile
index 413e965a0e..0bfcfb4f0f 100644
--- a/tools/e2fsprogs/Makefile
+++ b/tools/e2fsprogs/Makefile
@@ -30,6 +30,9 @@ CONFIGURE_ARGS += \
define Host/Install
$(Host/Install/Default)
$(MAKE) -C $(HOST_BUILD_DIR)/lib/uuid install
+ mkdir -p $(STAGING_DIR_HOST)/include/e2fsprogs
+ $(CP) $(STAGING_DIR_HOST)/include/uuid $(STAGING_DIR_HOST)/include/e2fsprogs/
+ rm -rf $(STAGING_DIR_HOST)/include/uuid
$(INSTALL_DATA) $(HOST_BUILD_DIR)/lib/uuid/libuuid.a $(STAGING_DIR_HOST)/lib/
endef