summaryrefslogtreecommitdiffstats
path: root/tools/automake/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/automake/Makefile')
-rw-r--r--tools/automake/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/automake/Makefile b/tools/automake/Makefile
index 300bee21ea..8c390d48de 100644
--- a/tools/automake/Makefile
+++ b/tools/automake/Makefile
@@ -18,6 +18,11 @@ include $(INCLUDE_DIR)/host-build.mk
HOST_CONFIGURE_ARGS += --datarootdir=$(STAGING_DIR_HOST)/share
HOST_CONFIGURE_VARS += am_cv_prog_PERL_ithreads=no
+define Host/Configure
+ (cd $(HOST_BUILD_DIR); $(AM_TOOL_PATHS) STAGING_DIR="" ./bootstrap.sh)
+ $(call Host/Configure/Default)
+endef
+
define Host/Install
# remove old automake resources to avoid version conflicts
rm -rf $(STAGING_DIR_HOST)/share/aclocal-[0-9]*