summaryrefslogtreecommitdiffstats
path: root/tools/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/Makefile')
-rw-r--r--tools/Makefile64
1 files changed, 16 insertions, 48 deletions
diff --git a/tools/Makefile b/tools/Makefile
index 68e7dab534..0d6b515977 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -1,60 +1,28 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# Main makefile for the host tools
#
-include $(TOPDIR)/rules.mk
-TARGETS-y:=sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline
-TARGETS-$(CONFIG_CCACHE) += ccache
-TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
-TARGETS_PREPARE:=$(patsubst %,%-prepare,$(TARGETS-y))
-TARGETS_COMPILE:=$(patsubst %,%-compile,$(TARGETS-y))
-TARGETS_INSTALL:=$(patsubst %,%-install,$(TARGETS-y))
-TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS-y))
-STAMP:=$(STAGING_DIR)/stampfiles/.tools_installed
+curdir:=$(patsubst %/Makefile,%,$(lastword $(MAKEFILE_LIST)))
-all: install
-download: $(TARGETS_DOWNLOAD)
-compile: $(TARGETS_COMPILE)
-install: $(STAMP)
-clean: $(TARGETS_CLEAN)
+# subdirectories to descend into
+$(curdir)/builddirs := sed sstrip ipkg-utils ext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline $(if $(CONFIG_CCACHE),ccache)
-squashfs-compile: lzma-install
+# builddir dependencies
+$(curdir)/squashfs/compile := $(curdir)/lzma/install
-ifneq ($(shell $(SCRIPT_DIR)/timestamp.pl -p . $(STAMP)),$(STAMP))
- $(STAMP): $(TARGETS_INSTALL)
-endif
+# preparatory work
+$(STAGING_DIR)/include-host/.done:
+ @mkdir -p $$(dirname $@)
+ @cp $(curdir)/include/*.h $$(dirname $@)/
+ @touch $@
-$(STAMP): $(TOPDIR)/.config
- mkdir -p $(shell dirname $@)
- touch $@
-
-TOOL_HOST_INCLUDES:=$(patsubst ./include/%.h,$(STAGING_DIR)/include-host/%.h,$(wildcard ./include/*.h))
-$(TOOL_HOST_INCLUDES): $(STAGING_DIR)/include-host/%.h: ./include/%.h
- @mkdir -p $(STAGING_DIR)/include-host
- $(CP) $< $@
-
-$(TOOL_BUILD_DIR):
- @mkdir -p $@
-
-%-prereq %-download %-clean %-refresh %-update: FORCE
- $(MAKE) -C $* $(patsubst $*-%,%,$@)
-
-%-prepare: $(TOOL_HOST_INCLUDES) $(TOOL_BUILD_DIR) FORCE
- $(MAKE) -C $* $(patsubst $*-%,%,$@)
-
-%-compile: %-prepare FORCE
- $(MAKE) -C $* $(patsubst $*-%,%,$@)
-
-%-install: %-compile FORCE
- $(MAKE) -C $* $(patsubst $*-%,%,$@)
-
-ifeq ($(MAKECMDGOALS),install-targets)
-MAKEFLAGS:=$(MAKEFLAGS) -j$(CONFIG_JLEVEL)
-else
-.NOTPARALLEL:
-endif
+# prerequisites for the individual targets
+$(curdir)/ := .config
+$(curdir)//prepare := $(STAGING_DIR)/include-host/.done
+$(eval $(call stampfile,$(curdir),tools))
+$(eval $(call subdir,$(curdir)))