summaryrefslogtreecommitdiffstats
path: root/toolchain
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain')
-rw-r--r--toolchain/gcc/Config.in8
-rw-r--r--toolchain/gcc/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 4aaa88edf5..b183e3618a 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -81,6 +81,14 @@ config SSP_SUPPORT
help
Enable Stack-Smashing Protection support
+config TLS_SUPPORT
+ bool
+ depends !GCC_VERSION_3_4_6 && UCLIBC_VERSION_NPTL
+ prompt "Enable Thread-local storage (TLS) support" if TOOLCHAINOPTS
+ default n
+ help
+ Enable Thread-local storage support
+
config INSTALL_LIBSTDCPP
bool
prompt "Build/install c++ compiler and libstdc++?" if TOOLCHAINOPTS
diff --git a/toolchain/gcc/Makefile b/toolchain/gcc/Makefile
index fe07e7d5c6..8b920607e0 100644
--- a/toolchain/gcc/Makefile
+++ b/toolchain/gcc/Makefile
@@ -2,7 +2,7 @@
# Copyright (C) 2002-2003 Erik Andersen <andersen@uclibc.org>
# Copyright (C) 2004 Manuel Novoa III <mjn3@uclibc.org>
# Copyright (C) 2005-2006 Felix Fietkau <nbd@openwrt.org>
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -116,6 +116,11 @@ else
--disable-libssp
endif
+ifeq ($(CONFIG_TLS_SUPPORT),)
+ GCC_CONFIGURE+= \
+ --disable-tls
+endif
+
ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
GCC_CONFIGURE+= \
--enable-biarch \
@@ -152,7 +157,6 @@ GCC_CONFIGURE_STAGE2:= \
--enable-languages=$(TARGET_LANGUAGES) \
--enable-shared \
--enable-threads \
- --disable-tls \
--with-slibdir=$(TOOLCHAIN_DIR)/lib \
ifdef CONFIG_powerpc