summaryrefslogtreecommitdiffstats
path: root/toolchain/glibc/patches/2.7/102-gcc_4_3.patch
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/glibc/patches/2.7/102-gcc_4_3.patch')
-rw-r--r--toolchain/glibc/patches/2.7/102-gcc_4_3.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/toolchain/glibc/patches/2.7/102-gcc_4_3.patch b/toolchain/glibc/patches/2.7/102-gcc_4_3.patch
new file mode 100644
index 0000000000..2ed3f548a9
--- /dev/null
+++ b/toolchain/glibc/patches/2.7/102-gcc_4_3.patch
@@ -0,0 +1,38 @@
+http://sourceware.org/bugzilla/show_bug.cgi?id=5442
+
+diff -ruN glibc-2.7-old/configure.in glibc-2.7-new/configure.in
+--- glibc-2.7-old/configure.in 2007-06-08 05:16:36.000000000 +0200
++++ glibc-2.7-new/configure.in 2009-01-21 01:12:42.000000000 +0100
+@@ -911,8 +911,12 @@
+ # header directory and add that to the list. NOTE: Only does the right
+ # thing on a system that doesn't need fixincludes. (Not presently a problem.)
+ if test -n "$sysheaders"; then
+- ccheaders=`$CC -print-file-name=include`
+- SYSINCLUDES="-nostdinc -isystem $ccheaders \
++ SYSINCLUDES=-nostdinc
++ for d in include include-fixed; do
++ i=`$CC -print-file-name="$d"` && test "x$i" != x && test "x$i" != "x$d" &&
++ SYSINCLUDES="$SYSINCLUDES -isystem $i"
++ done
++ SYSINCLUDES="$SYSINCLUDES \
+ -isystem `echo $sysheaders | sed 's/:/ -isystem /g'`"
+ if test -n "$CXX"; then
+ cxxversion=`$CXX -dumpversion 2>&AS_MESSAGE_LOG_FD` &&
+diff -ruN glibc-2.7-old/configure glibc-2.7-new/configure
+--- glibc-2.7-old/configure 2007-10-18 13:22:23.000000000 +0200
++++ glibc-2.7-new/configure 2009-01-21 01:12:45.000000000 +0100
+@@ -5062,8 +5062,12 @@
+ # header directory and add that to the list. NOTE: Only does the right
+ # thing on a system that doesn't need fixincludes. (Not presently a problem.)
+ if test -n "$sysheaders"; then
+- ccheaders=`$CC -print-file-name=include`
+- SYSINCLUDES="-nostdinc -isystem $ccheaders \
++ SYSINCLUDES=-nostdinc
++ for d in include include-fixed; do
++ i=`$CC -print-file-name="$d"` && test "x$i" != "x$d" &&
++ SYSINCLUDES="$SYSINCLUDES -isystem $i"
++ done
++ SYSINCLUDES="$SYSINCLUDES \
+ -isystem `echo $sysheaders | sed 's/:/ -isystem /g'`"
+ if test -n "$CXX"; then
+ cxxversion=`$CXX -dumpversion 2>&5` &&