summaryrefslogtreecommitdiffstats
path: root/toolchain/glibc/common.mk
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/glibc/common.mk')
-rw-r--r--toolchain/glibc/common.mk34
1 files changed, 20 insertions, 14 deletions
diff --git a/toolchain/glibc/common.mk b/toolchain/glibc/common.mk
index 14063bf9df..042e63d510 100644
--- a/toolchain/glibc/common.mk
+++ b/toolchain/glibc/common.mk
@@ -1,27 +1,33 @@
#
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
+
+MD5SUM_2.19 = 42dad4edd3bcb38006d13b5640b00b38
+REVISION_2.19 = 25243
+
+MD5SUM_2.21 = 76050a65c444d58b5c4aa0d6034736ed
+REVISION_2.21 = 16d0a0c
+
+MD5SUM_2.22 = b575850e77b37d70f96472285290b391
+REVISION_2.22 = b995d95
+
+
PKG_NAME:=glibc
PKG_VERSION:=$(call qstrip,$(CONFIG_GLIBC_VERSION))
-ifeq ($(PKG_VERSION),2.22)
- PKG_SOURCE_URL:=http://ftpmirror.gnu.org/libc
- PKG_MD5SUM:=eb731406903befef1d8f878a46be75ef862b9056ab0cde1626d08a7a05328948
- PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
- PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.xz
-else
- PKG_REVISION:=$(call qstrip,$(CONFIG_GLIBC_REVISION))
- PKG_SOURCE_PROTO:=git
- PKG_SOURCE_URL:=git://sourceware.org/git/glibc.git
- PKG_SOURCE_VERSION:=$(PKG_REVISION)
- PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-r$(PKG_REVISION)
- PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.bz2
-endif
+PKG_REVISION:=$(REVISION_$(PKG_VERSION))
+PKG_MIRROR_MD5SUM:=$(MD5SUM_$(PKG_VERSION))
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://sourceware.org/git/glibc.git
+PKG_SOURCE_VERSION:=$(PKG_REVISION)
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_REVISION)
+PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.bz2
GLIBC_PATH:=
ifneq ($(CONFIG_EGLIBC_VERSION_2_19),)