summaryrefslogtreecommitdiffstats
path: root/toolchain/glibc/common.mk
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/glibc/common.mk')
-rw-r--r--toolchain/glibc/common.mk19
1 files changed, 13 insertions, 6 deletions
diff --git a/toolchain/glibc/common.mk b/toolchain/glibc/common.mk
index bc50fcb69e..14063bf9df 100644
--- a/toolchain/glibc/common.mk
+++ b/toolchain/glibc/common.mk
@@ -8,13 +8,20 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=glibc
PKG_VERSION:=$(call qstrip,$(CONFIG_GLIBC_VERSION))
-PKG_REVISION:=$(call qstrip,$(CONFIG_GLIBC_REVISION))
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=git://sourceware.org/git/glibc.git
-PKG_SOURCE_VERSION:=$(PKG_REVISION)
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-r$(PKG_REVISION)
-PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.bz2
+ifeq ($(PKG_VERSION),2.22)
+ PKG_SOURCE_URL:=http://ftpmirror.gnu.org/libc
+ PKG_MD5SUM:=eb731406903befef1d8f878a46be75ef862b9056ab0cde1626d08a7a05328948
+ PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+ PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.xz
+else
+ PKG_REVISION:=$(call qstrip,$(CONFIG_GLIBC_REVISION))
+ PKG_SOURCE_PROTO:=git
+ PKG_SOURCE_URL:=git://sourceware.org/git/glibc.git
+ PKG_SOURCE_VERSION:=$(PKG_REVISION)
+ PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-r$(PKG_REVISION)
+ PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.bz2
+endif
GLIBC_PATH:=
ifneq ($(CONFIG_EGLIBC_VERSION_2_19),)