summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/patches/4.0.3/602-sdk-libstdc++-includes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/gcc/patches/4.0.3/602-sdk-libstdc++-includes.patch')
-rw-r--r--toolchain/gcc/patches/4.0.3/602-sdk-libstdc++-includes.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/toolchain/gcc/patches/4.0.3/602-sdk-libstdc++-includes.patch b/toolchain/gcc/patches/4.0.3/602-sdk-libstdc++-includes.patch
new file mode 100644
index 0000000000..c7676ae6a2
--- /dev/null
+++ b/toolchain/gcc/patches/4.0.3/602-sdk-libstdc++-includes.patch
@@ -0,0 +1,22 @@
+diff -urN gcc-4.0.0-100/libstdc++-v3/fragment.am gcc-4.0.0/libstdc++-v3/fragment.am
+--- gcc-4.0.0-100/libstdc++-v3/fragment.am 2004-10-25 15:32:40.000000000 -0500
++++ gcc-4.0.0/libstdc++-v3/fragment.am 2005-04-28 21:48:43.000000000 -0500
+@@ -18,5 +18,5 @@
+ $(WARN_FLAGS) $(WERROR) -fdiagnostics-show-location=once
+
+ # -I/-D flags to pass when compiling.
+-AM_CPPFLAGS = $(GLIBCXX_INCLUDES)
++AM_CPPFLAGS = $(GLIBCXX_INCLUDES) -I$(toplevel_srcdir)/include
+
+diff -urN gcc-4.0.0-100/libstdc++-v3/libmath/Makefile.am gcc-4.0.0/libstdc++-v3/libmath/Makefile.am
+--- gcc-4.0.0-100/libstdc++-v3/libmath/Makefile.am 2003-08-27 16:29:42.000000000 -0500
++++ gcc-4.0.0/libstdc++-v3/libmath/Makefile.am 2005-04-28 21:48:43.000000000 -0500
+@@ -32,7 +32,7 @@
+
+ libmath_la_SOURCES = stubs.c
+
+-AM_CPPFLAGS = $(CANADIAN_INCLUDES)
++AM_CPPFLAGS = $(CANADIAN_INCLUDES) -I$(toplevel_srcdir)/include
+
+ # Only compiling "C" sources in this directory.
+ LIBTOOL = @LIBTOOL@ --tag CC