summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/final/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/gcc/final/Makefile')
-rw-r--r--toolchain/gcc/final/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/toolchain/gcc/final/Makefile b/toolchain/gcc/final/Makefile
index 3434d894a2..01fec38027 100644
--- a/toolchain/gcc/final/Makefile
+++ b/toolchain/gcc/final/Makefile
@@ -39,7 +39,16 @@ define Host/Configure
);
endef
+ifeq ($(CONFIG_USE_GLIBC)$(CONFIG_INSTALL_GCCGO),yy)
+define FixGogccCrt
+ # link crtX.o for gotools
+ mkdir -p $(GCC_BUILD_DIR)/gotools
+ $(foreach crt, i 1 n, ln -sf ../../glibc-dev/lib/crt$(crt).o $(GCC_BUILD_DIR)/gotools/ ; )
+endef
+endif
+
define Host/Compile
+ $(FixGogccCrt)
+$(GCC_MAKE) $(HOST_JOBS) -C $(GCC_BUILD_DIR) all
endef