summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/final/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/gcc/final/Makefile')
-rw-r--r--toolchain/gcc/final/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/toolchain/gcc/final/Makefile b/toolchain/gcc/final/Makefile
index 3fb5ccf83f..1212d145ab 100644
--- a/toolchain/gcc/final/Makefile
+++ b/toolchain/gcc/final/Makefile
@@ -16,6 +16,10 @@ ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
--with-libelf=$(TOPDIR)/staging_dir/host
endif
+ifdef CONFIG_USE_MUSL
+ GCC_MAKE += gcc_cv_libc_provides_ssp=yes
+endif
+
ifneq ($(CONFIG_SJLJ_EXCEPTIONS),)
GCC_CONFIGURE += \
--enable-sjlj-exceptions