summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/ixp4xx-2.6/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ixp4xx-2.6/image/Makefile b/target/linux/ixp4xx-2.6/image/Makefile
index 8d05a1b8f1..70ff0ebf56 100644
--- a/target/linux/ixp4xx-2.6/image/Makefile
+++ b/target/linux/ixp4xx-2.6/image/Makefile
@@ -25,6 +25,11 @@ ifneq ($(CONFIG_IXP4XX_INCLUDE_UCODE),)
-k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
-r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
-p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1).bin
+ BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
+ -F -L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
+ -k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
+ -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
+ -p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1)-16mb.bin
endef
endif