summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/imx6/Makefile3
-rw-r--r--target/linux/imx6/profiles/100-Generic.mk19
2 files changed, 20 insertions, 2 deletions
diff --git a/target/linux/imx6/Makefile b/target/linux/imx6/Makefile
index b9b2062ef3..3af424e64c 100644
--- a/target/linux/imx6/Makefile
+++ b/target/linux/imx6/Makefile
@@ -20,7 +20,6 @@ include $(INCLUDE_DIR)/target.mk
KERNELNAME:="zImage dtbs"
-DEFAULT_PACKAGES += \
- kmod-thermal-imx kmod-usb-chipidea kmod-usb-mxs-phy uboot-envtools
+DEFAULT_PACKAGES +=
$(eval $(call BuildTarget))
diff --git a/target/linux/imx6/profiles/100-Generic.mk b/target/linux/imx6/profiles/100-Generic.mk
new file mode 100644
index 0000000000..91ca3696ad
--- /dev/null
+++ b/target/linux/imx6/profiles/100-Generic.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic (default)
+ PACKAGES:= \
+ kmod-thermal-imx kmod-usb-chipidea kmod-usb-mxs-phy \
+ uboot-envtools
+endef
+
+define Profile/Generic/Description
+ Package set compatible with most Freescale i.MX 6 based boards.
+endef
+
+$(eval $(call Profile,Generic))