summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/x86/image/Config.in2
-rw-r--r--target/linux/x86/image/Makefile6
2 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/x86/image/Config.in b/target/linux/x86/image/Config.in
index 6066ba44ef..ef7d0cd855 100644
--- a/target/linux/x86/image/Config.in
+++ b/target/linux/x86/image/Config.in
@@ -36,7 +36,7 @@ config X86_GRUB_BOOTOPTS
config X86_VDI_IMAGES
- bool "Build VirtualBox image files (VDI). Requires vditool"
+ bool "Build VirtualBox image files (VDI). Requires VBoxManage"
depends TARGET_x86
depends TARGET_ROOTFS_EXT2FS
depends X86_GRUB_IMAGES
diff --git a/target/linux/x86/image/Makefile b/target/linux/x86/image/Makefile
index 9bd2eada6b..839646e547 100644
--- a/target/linux/x86/image/Makefile
+++ b/target/linux/x86/image/Makefile
@@ -66,7 +66,7 @@ ifeq ($(CONFIG_X86_VDI_IMAGES),y)
# left here because the image builder doesnt need these
ifeq ($(1),ext2)
rm $(BIN_DIR)/openwrt-$(BOARD)-ext2.vdi || true
- vditool DD $(BIN_DIR)/openwrt-$(BOARD)-ext2.vdi $(BIN_DIR)/openwrt-$(BOARD)-ext2.image
+ VBoxManage convertfromraw -format VDI $(BIN_DIR)/openwrt-$(BOARD)-ext2.image $(BIN_DIR)/openwrt-$(BOARD)-ext2.vdi
endif
endef
endif
@@ -121,8 +121,8 @@ endef
$(eval $(call BuildImage))
ifeq ($(CONFIG_X86_VDI_IMAGES),y)
- $(eval $(call RequireCommand,vditool, \
- You need vditool to generate VirtualBox images. \
+ $(eval $(call RequireCommand,VBoxManage, \
+ You need VBoxManage to generate VirtualBox images. \
))
endif