summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/files/drivers/net/ethernet/ralink/Kconfig34
-rw-r--r--target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile9
-rw-r--r--target/linux/ramips/mt7620a/config-3.142
-rw-r--r--target/linux/ramips/mt7620n/config-3.142
4 files changed, 38 insertions, 9 deletions
diff --git a/target/linux/ramips/files/drivers/net/ethernet/ralink/Kconfig b/target/linux/ramips/files/drivers/net/ethernet/ralink/Kconfig
index ca2c9ad627..b25a12a128 100644
--- a/target/linux/ramips/files/drivers/net/ethernet/ralink/Kconfig
+++ b/target/linux/ramips/files/drivers/net/ethernet/ralink/Kconfig
@@ -1,30 +1,54 @@
config NET_RALINK
- tristate "Ralink RT288X/RT3X5X/RT3662/RT3883/MT7620 ethernet driver"
+ tristate "Ralink ethernet driver"
depends on RALINK
help
This driver supports the ethernet mac inside the ralink wisocs
if NET_RALINK
+choice
+ prompt "MAC type"
+
+config NET_RALINK_RT288X
+ bool "RT288X"
+ depends on SOC_RT288X
+
+config NET_RALINK_RT305X
+ bool "RT305X"
+ depends on (SOC_RT305X || SOC_MT7620)
+
+config NET_RALINK_RT3883
+ bool "RT3883"
+ depends on SOC_RT3883
+
+config NET_RALINK_MT7620
+ bool "MT7620"
+ depends on SOC_MT7620
+
+config NET_RALINK_MT7621
+ bool "MT7621"
+ depends on SOC_MT7621
+
+endchoice
config NET_RALINK_MDIO
def_bool NET_RALINK
- depends on (SOC_RT288X || SOC_RT3883 || SOC_MT7620)
+ depends on (NET_RALINK_RT288X || NET_RALINK_RT3883 || NET_RALINK_MT7620 || NET_RALINK_MT7621)
select PHYLIB
config NET_RALINK_MDIO_RT2880
def_bool NET_RALINK
- depends on (SOC_RT288X || SOC_RT3883)
+ depends on (NET_RALINK_RT288X || NET_RALINK_RT3883)
select NET_RALINK_MDIO
config NET_RALINK_ESW_RT3052
def_bool NET_RALINK
- depends on SOC_RT305X
+ depends on NET_RALINK_RT305X
select PHYLIB
select SWCONFIG
config NET_RALINK_GSW_MT7620
def_bool NET_RALINK
- depends on SOC_MT7620
+ depends on NET_RALINK_MT7620 || NET_RALINK_MT7621
select NET_RALINK_MDIO
select PHYLIB
select SWCONFIG
diff --git a/target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile b/target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile
index 01884a7836..54a07e7c2b 100644
--- a/target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile
+++ b/target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile
@@ -10,9 +10,10 @@ ralink-eth-$(CONFIG_NET_RALINK_MDIO_RT2880) += mdio_rt2880.o
ralink-eth-$(CONFIG_NET_RALINK_ESW_RT3052) += esw_rt3052.o
ralink-eth-$(CONFIG_NET_RALINK_GSW_MT7620) += gsw_mt7620a.o mt7530.o
-ralink-eth-$(CONFIG_SOC_RT288X) += soc_rt2880.o
-ralink-eth-$(CONFIG_SOC_RT305X) += soc_rt305x.o
-ralink-eth-$(CONFIG_SOC_RT3883) += soc_rt3883.o
-ralink-eth-$(CONFIG_SOC_MT7620) += soc_mt7620.o
+ralink-eth-$(CONFIG_NET_RALINK_RT288X) += soc_rt2880.o
+ralink-eth-$(CONFIG_NET_RALINK_RT305X) += soc_rt305x.o
+ralink-eth-$(CONFIG_NET_RALINK_RT3883) += soc_rt3883.o
+ralink-eth-$(CONFIG_NET_RALINK_MT7620) += soc_mt7620.o
+ralink-eth-$(CONFIG_NET_RALINK_MT7621) += soc_mt7621.o
obj-$(CONFIG_NET_RALINK) += ralink-eth.o
diff --git a/target/linux/ramips/mt7620a/config-3.14 b/target/linux/ramips/mt7620a/config-3.14
index a3411a70db..b0f81487d3 100644
--- a/target/linux/ramips/mt7620a/config-3.14
+++ b/target/linux/ramips/mt7620a/config-3.14
@@ -121,6 +121,8 @@ CONFIG_NEED_PER_CPU_KM=y
CONFIG_NET_RALINK=y
CONFIG_NET_RALINK_GSW_MT7620=y
CONFIG_NET_RALINK_MDIO=y
+CONFIG_NET_RALINK_MT7620=y
+# CONFIG_NET_RALINK_RT305X is not set
CONFIG_NLS=m
CONFIG_NO_GENERIC_PCI_IOPORT_MAP=y
CONFIG_OF=y
diff --git a/target/linux/ramips/mt7620n/config-3.14 b/target/linux/ramips/mt7620n/config-3.14
index f21312f976..1a3155ebba 100644
--- a/target/linux/ramips/mt7620n/config-3.14
+++ b/target/linux/ramips/mt7620n/config-3.14
@@ -119,6 +119,8 @@ CONFIG_NEED_PER_CPU_KM=y
CONFIG_NET_RALINK=y
CONFIG_NET_RALINK_GSW_MT7620=y
CONFIG_NET_RALINK_MDIO=y
+CONFIG_NET_RALINK_MT7620=y
+# CONFIG_NET_RALINK_RT305X is not set
CONFIG_NLS=m
CONFIG_OF=y
CONFIG_OF_ADDRESS=y