summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux')
-rw-r--r--target/linux/generic/patches-3.14/412-mtd-partial_eraseblock_unlock.patch2
-rw-r--r--target/linux/generic/patches-3.14/721-phy_packets.patch2
-rw-r--r--target/linux/generic/patches-3.14/950-vm_exports.patch4
-rw-r--r--target/linux/mvebu/Makefile2
-rw-r--r--target/linux/x86_64/Makefile2
5 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/generic/patches-3.14/412-mtd-partial_eraseblock_unlock.patch b/target/linux/generic/patches-3.14/412-mtd-partial_eraseblock_unlock.patch
index 134f65715e..87c8257fe1 100644
--- a/target/linux/generic/patches-3.14/412-mtd-partial_eraseblock_unlock.patch
+++ b/target/linux/generic/patches-3.14/412-mtd-partial_eraseblock_unlock.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/mtdpart.c
+++ b/drivers/mtd/mtdpart.c
-@@ -331,7 +331,14 @@ static int part_lock(struct mtd_info *mt
+@@ -332,7 +332,14 @@ static int part_lock(struct mtd_info *mt
static int part_unlock(struct mtd_info *mtd, loff_t ofs, uint64_t len)
{
struct mtd_part *part = PART(mtd);
diff --git a/target/linux/generic/patches-3.14/721-phy_packets.patch b/target/linux/generic/patches-3.14/721-phy_packets.patch
index e472a96280..04b5b3af56 100644
--- a/target/linux/generic/patches-3.14/721-phy_packets.patch
+++ b/target/linux/generic/patches-3.14/721-phy_packets.patch
@@ -79,7 +79,7 @@
help
--- a/net/core/dev.c
+++ b/net/core/dev.c
-@@ -2607,10 +2607,20 @@ int dev_hard_start_xmit(struct sk_buff *
+@@ -2614,10 +2614,20 @@ int dev_hard_start_xmit(struct sk_buff *
if (!list_empty(&ptype_all))
dev_queue_xmit_nit(skb, dev);
diff --git a/target/linux/generic/patches-3.14/950-vm_exports.patch b/target/linux/generic/patches-3.14/950-vm_exports.patch
index b9ddb802d1..6d8bc58c3d 100644
--- a/target/linux/generic/patches-3.14/950-vm_exports.patch
+++ b/target/linux/generic/patches-3.14/950-vm_exports.patch
@@ -1,6 +1,6 @@
--- a/mm/shmem.c
+++ b/mm/shmem.c
-@@ -2963,6 +2963,15 @@ put_memory:
+@@ -3043,6 +3043,15 @@ put_memory:
return res;
}
@@ -16,7 +16,7 @@
/**
* shmem_kernel_file_setup - get an unlinked file living in tmpfs which must be
* kernel internal. There will be NO LSM permission checks against the
-@@ -3002,11 +3011,8 @@ int shmem_zero_setup(struct vm_area_stru
+@@ -3082,11 +3091,8 @@ int shmem_zero_setup(struct vm_area_stru
file = shmem_file_setup("dev/zero", size, vma->vm_flags);
if (IS_ERR(file))
return PTR_ERR(file);
diff --git a/target/linux/mvebu/Makefile b/target/linux/mvebu/Makefile
index 6b602315d7..59cc940fe3 100644
--- a/target/linux/mvebu/Makefile
+++ b/target/linux/mvebu/Makefile
@@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
CPU_SUBTYPE:=vfpv3
MAINTAINER:=Luka Perkov <luka@openwrt.org>
-LINUX_VERSION:=3.14.12
+LINUX_VERSION:=3.14.14
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/x86_64/Makefile b/target/linux/x86_64/Makefile
index 93097e63bf..7e5312631c 100644
--- a/target/linux/x86_64/Makefile
+++ b/target/linux/x86_64/Makefile
@@ -12,7 +12,7 @@ BOARDNAME:=x86_64
FEATURES:=ext4 vdi vmdk targz
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.14.12
+LINUX_VERSION:=3.14.14
KERNELNAME:=bzImage