summaryrefslogtreecommitdiffstats
path: root/target/linux
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds8
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network12
-rwxr-xr-xtarget/linux/ramips/base-files/etc/diag.sh2
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh2
-rw-r--r--target/linux/ramips/dts/HT-TM02.dts32
-rw-r--r--target/linux/ramips/rt305x/profiles/hootoo.mk18
6 files changed, 31 insertions, 43 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index b3f8849997..405a6c0d70 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -118,10 +118,10 @@ case $board in
hlk-rm04)
set_wifi_led "rt2800pci-phy0::radio"
;;
- ht-tm02)
- ucidef_set_led_netdev "eth" "ETH" "ht-tm02:white:status" "eth0"
- set_wifi_led "ht-tm02:blue:wifi"
- ;;
+ ht-tm02)
+ ucidef_set_led_netdev "eth" "Ethernet" "ht-tm02:green:lan" "eth0"
+ set_wifi_led "ht-tm02:blue:wlan"
+ ;;
all0239-3g|\
hw550-3g)
set_usb_led "hw550-3g:green:usb"
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index d727eeef48..a86466e5e7 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -50,6 +50,7 @@ ramips_setup_interfaces()
all5003 | \
broadway | \
dcs-930| \
+ ht-tm02| \
ncs601w | \
wnce2001)
ucidef_add_switch "switch0" "1" "0"
@@ -103,12 +104,6 @@ ramips_setup_interfaces()
ucidef_add_switch_vlan "switch0" "2" "4 9t"
;;
- ht-tm02)
- ucidef_set_interface_lan "eth0.1"
- ucidef_add_switch "switch0" "1" "1"
- ucidef_add_switch_vlan "switch0" "1" "4 6t"
- ;;
-
3g-6200n | \
ai-br100 | \
dir-610-a1 | \
@@ -291,7 +286,6 @@ ramips_setup_macs()
hlk-rm04 | \
mpr-a1 | \
mpr-a2 | \
- ht-tm02 | \
dir-300-b7 | \
dir-320-b1 | \
psr-680w |\
@@ -303,6 +297,10 @@ ramips_setup_macs()
wan_mac=$(macaddr_add "$lan_mac" 1)
;;
+ ht-tm02)
+ lan_mac=$(cat /sys/class/net/eth0/address)
+ ;;
+
cy-swr1100 | \
dir-645)
lan_mac=$(mtd_get_mac_ascii nvram lanmac)
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index 1af64b2770..103dfcd236 100755
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -73,7 +73,7 @@ get_status_led() {
status_led="hlk-rm04:red:power"
;;
ht-tm02)
- status_led="ht-tm02:white:status"
+ status_led="ht-tm02:blue:wlan"
;;
all0239-3g|\
hw550-3g)
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index eeb8df049e..59d7418006 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -172,7 +172,7 @@ ramips_board_detect() {
*"HILINK HLK-RM04")
name="hlk-rm04"
;;
- *"HOOTOO HT-TM02")
+ *"HooToo HT-TM02")
name="ht-tm02"
;;
*"HAME MPR-A1")
diff --git a/target/linux/ramips/dts/HT-TM02.dts b/target/linux/ramips/dts/HT-TM02.dts
index 1f456f0546..40d9e019b0 100644
--- a/target/linux/ramips/dts/HT-TM02.dts
+++ b/target/linux/ramips/dts/HT-TM02.dts
@@ -4,14 +4,12 @@
/ {
compatible = "HT-TM02", "ralink,rt5350-soc";
- model = "HOOTOO HT-TM02";
+ model = "HooToo HT-TM02";
palmbus@10000000 {
-
- gpio0: gpio@600 {
+ gpio0: gpio@600 {
status = "okay";
- };
-
+ };
spi@b00 {
status = "okay";
m25p80@0 {
@@ -21,25 +19,21 @@
reg = <0 0>;
linux,modalias = "m25p80", "mx25l6405d";
spi-max-frequency = <10000000>;
-
partition@0 {
label = "u-boot";
reg = <0x0 0x30000>;
read-only;
};
-
partition@30000 {
label = "u-boot-env";
reg = <0x30000 0x10000>;
read-only;
};
-
factory: partition@40000 {
label = "factory";
reg = <0x40000 0x10000>;
read-only;
};
-
partition@50000 {
label = "firmware";
reg = <0x50000 0x7b0000>;
@@ -58,11 +52,11 @@
};
ethernet@10100000 {
- mtd-mac-address = <&factory 0x4>;
+ mtd-mac-address = <&factory 0x28>;
};
esw@10110000 {
- ralink,portmap = <0x3f>;
+ ralink,portmap = <0x10>;
};
wmac@10180000 {
@@ -79,12 +73,12 @@
gpio-leds {
compatible = "gpio-leds";
- wifi {
- label = "ht-tm02:blue:wifi";
+ wlan {
+ label = "ht-tm02:blue:wlan";
gpios = <&gpio0 7 1>;
};
- status {
- label = "ht-tm02:yellow:status";
+ lan {
+ label = "ht-tm02:green:lan";
gpios = <&gpio0 12 1>;
};
@@ -95,10 +89,16 @@
#address-cells = <1>;
#size-cells = <0>;
poll-interval = <20>;
- wps {
+ reset {
label = "reset";
gpios = <&gpio0 10 1>;
linux,code = <0x198>;
};
+ modeswitch {
+ label = "modeswitch";
+ gpios = <&gpio0 14 1>;
+ linux,code = <0x100>;
+ linux,input-type = <5>;
+ };
};
};
diff --git a/target/linux/ramips/rt305x/profiles/hootoo.mk b/target/linux/ramips/rt305x/profiles/hootoo.mk
index 976226d5bd..efd23ed11e 100644
--- a/target/linux/ramips/rt305x/profiles/hootoo.mk
+++ b/target/linux/ramips/rt305x/profiles/hootoo.mk
@@ -1,27 +1,17 @@
#
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
-
define Profile/HT-TM02
- NAME:=HOOTOO HT-TM02
- PACKAGES:=\
- wpad-mini \
- kmod-ledtrig-netdev kmod-ledtrig-timer kmod-leds-gpio kmod-ledtrig-default-on \
- kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-net usbutils \
- kmod-scsi-core kmod-scsi-generic kmod-fs-ext4 \
- kmod-usb-storage kmod-usb-storage-extras block-mount \
- kmod-usb-serial kmod-usb-serial-ftdi kmod-gpio-button-hotplug \
- kmod-nls-cp437 kmod-nls-iso8859-1 kmod-nls-utf8 luci luci-mod-admin-full \
- kmod-app-samba luci-theme-openwrt luci-proto-relay relayd nano \
- fstools
+ NAME:=HooToo HT-TM02
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
endef
define Profile/HT-TM02/Description
- Package set for HOOTOO HT-TM02 board
+ Package set optimized for the HooToo HT-TM02.
endef
$(eval $(call Profile,HT-TM02))