summaryrefslogtreecommitdiffstats
path: root/target/linux/x86/generic/target.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/x86/generic/target.mk')
-rw-r--r--target/linux/x86/generic/target.mk8
1 files changed, 6 insertions, 2 deletions
diff --git a/target/linux/x86/generic/target.mk b/target/linux/x86/generic/target.mk
index 7191292e81..e135b6d6b6 100644
--- a/target/linux/x86/generic/target.mk
+++ b/target/linux/x86/generic/target.mk
@@ -1,7 +1,11 @@
BOARDNAME:=Generic
+CPU_TYPE :=pentium4
+FEATURES += audio fpu pci pcie usb
+DEFAULT_PACKAGES += kmod-button-hotplug
define Target/Description
- Build firmware images for x86 based boards
- (e.g : Soekris, ...)
+ Build firmware images for modern x86 based boards with CPUs
+ supporting at least the Intel Pentium 4 instruction set with
+ MMX, SSE and SSE2.
endef