summaryrefslogtreecommitdiffstats
path: root/target/linux/realview/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/realview/image/Makefile')
-rw-r--r--target/linux/realview/image/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/realview/image/Makefile b/target/linux/realview/image/Makefile
index 28db6f330c..ad7aa6951c 100644
--- a/target/linux/realview/image/Makefile
+++ b/target/linux/realview/image/Makefile
@@ -21,7 +21,16 @@ endef
define Image/Build
$(call Image/Build/$(1))
+ $(call Build/sdcard-img)
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
endef
+define Build/sdcard-img
+ ./gen_realview_sdcard_img.sh \
+ $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)sdcard.img \
+ $(KDIR)/root.ext4 \
+ $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+endef
+
+
$(eval $(call BuildImage))