summaryrefslogtreecommitdiffstats
path: root/target/linux/realview/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/realview/image/Makefile')
-rw-r--r--target/linux/realview/image/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/realview/image/Makefile b/target/linux/realview/image/Makefile
index dd0d9ee76d..c6ff8ce46a 100644
--- a/target/linux/realview/image/Makefile
+++ b/target/linux/realview/image/Makefile
@@ -8,7 +8,11 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
define Image/BuildKernel
- cp $(LINUX_DIR)/arch/$(ARCH)/boot/$(subst ",,$(KERNELNAME)) $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+ cp $(KDIR)/$(subst ",,$(KERNELNAME)) $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+endef
+
+define Image/BuildKernel/Initramfs
+ cp $(KDIR)/$(subst ",,$(KERNELNAME))-initramfs $(BIN_DIR)/openwrt-$(BOARD)-vmlinux-initramfs.elf
endef
define Image/Build/squashfs