summaryrefslogtreecommitdiffstats
path: root/target/linux/rdc/patches-2.6.24
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/rdc/patches-2.6.24')
-rw-r--r--target/linux/rdc/patches-2.6.24/001-rdc3210_flash_map.patch63
-rw-r--r--target/linux/rdc/patches-2.6.24/001-x86_generic_gpio.patch13
-rw-r--r--target/linux/rdc/patches-2.6.24/002-r6040_ethernet.patch37
-rw-r--r--target/linux/rdc/patches-2.6.24/003-rootfstype.patch11
-rw-r--r--target/linux/rdc/patches-2.6.24/004-rdc_fixes.patch73
-rw-r--r--target/linux/rdc/patches-2.6.24/004-yenta_mystery.patch20
-rw-r--r--target/linux/rdc/patches-2.6.24/005-cmdline_setup.patch10
-rw-r--r--target/linux/rdc/patches-2.6.24/005-fix_amit_breakage.patch40
-rw-r--r--target/linux/rdc/patches-2.6.24/006-pci_ids.patch16
-rw-r--r--target/linux/rdc/patches-2.6.24/600-x86_lzma.patch62
10 files changed, 0 insertions, 345 deletions
diff --git a/target/linux/rdc/patches-2.6.24/001-rdc3210_flash_map.patch b/target/linux/rdc/patches-2.6.24/001-rdc3210_flash_map.patch
deleted file mode 100644
index 6da095df58..0000000000
--- a/target/linux/rdc/patches-2.6.24/001-rdc3210_flash_map.patch
+++ /dev/null
@@ -1,63 +0,0 @@
---- a/drivers/mtd/maps/Kconfig
-+++ b/drivers/mtd/maps/Kconfig
-@@ -117,6 +117,50 @@ config MTD_PNC2000
- PNC-2000 is the name of Network Camera product from PHOTRON
- Ltd. in Japan. It uses CFI-compliant flash.
-
-+config MTD_RDC3210
-+ tristate "CFI Flash device mapped on RDC3210"
-+ depends on X86 && MTD_CFI && MTD_PARTITIONS
-+ help
-+ RDC-3210 is the flash device we find on Ralink reference board.
-+
-+config MTD_RDC3210_STATIC_MAP
-+ bool "Partitions on RDC3210 mapped statically" if MTD_RDC3210
-+ select MTD_RDC3210_FACTORY_PRESENT
-+ help
-+ The mapping driver will use the static partition map for the
-+ RDC-3210 flash device.
-+
-+config MTD_RDC3210_FACTORY_PRESENT
-+ bool "Reserve a partition on RDC3210 for factory presets"
-+ depends on MTD_RDC3210
-+ default y
-+ help
-+ The mapping driver will reserve a partition on the RDC-3210 flash
-+ device for resetting flash contents to factory defaults.
-+
-+config MTD_RDC3210_ALLOW_JFFS2
-+ bool "JFFS2 filesystem usable in a partition on RDC3210"
-+ depends on MTD_RDC3210 && !MTD_RDC3210_STATIC_MAP
-+ help
-+ The mapping driver will align a partition on the RDC-3210 flash
-+ device to an erase-block boundary so that a JFFS2 filesystem may
-+ reside on it.
-+
-+config MTD_RDC3210_SIZE
-+ hex "Amount of flash memory on RDC3210"
-+ depends on MTD_RDC3210
-+ default "0x400000"
-+ help
-+ Total size in bytes of the RDC-3210 flash device
-+
-+config MTD_RDC3210_BUSWIDTH
-+ int "Width of CFI Flash device mapped on RDC3210"
-+ depends on MTD_RDC3210
-+ default "2"
-+ help
-+ Number of bytes addressed on the RDC-3210 flash device before
-+ addressing the same chip again
-+
- config MTD_SC520CDP
- tristate "CFI Flash device mapped on AMD SC520 CDP"
- depends on X86 && MTD_CFI && MTD_CONCAT
---- a/drivers/mtd/maps/Makefile
-+++ b/drivers/mtd/maps/Makefile
-@@ -30,6 +30,7 @@ obj-$(CONFIG_MTD_PMC_MSP_EVM) += pmcms
- obj-$(CONFIG_MTD_PMC_MSP_RAMROOT)+= pmcmsp-ramroot.o
- obj-$(CONFIG_MTD_PNC2000) += pnc2000.o
- obj-$(CONFIG_MTD_PCMCIA) += pcmciamtd.o
-+obj-$(CONFIG_MTD_RDC3210) += rdc3210.o
- obj-$(CONFIG_MTD_RPXLITE) += rpxlite.o
- obj-$(CONFIG_MTD_TQM8XXL) += tqm8xxl.o
- obj-$(CONFIG_MTD_SA1100) += sa1100-flash.o
diff --git a/target/linux/rdc/patches-2.6.24/001-x86_generic_gpio.patch b/target/linux/rdc/patches-2.6.24/001-x86_generic_gpio.patch
deleted file mode 100644
index 11c894bcf2..0000000000
--- a/target/linux/rdc/patches-2.6.24/001-x86_generic_gpio.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/arch/x86/Kconfig
-+++ b/arch/x86/Kconfig
-@@ -81,6 +81,10 @@ config GENERIC_BUG
- default y
- depends on BUG
-
-+config GENERIC_GPIO
-+ bool
-+ default n
-+
- config GENERIC_HWEIGHT
- bool
- default y
diff --git a/target/linux/rdc/patches-2.6.24/002-r6040_ethernet.patch b/target/linux/rdc/patches-2.6.24/002-r6040_ethernet.patch
deleted file mode 100644
index 97d6e7d41f..0000000000
--- a/target/linux/rdc/patches-2.6.24/002-r6040_ethernet.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- a/drivers/net/Kconfig
-+++ b/drivers/net/Kconfig
-@@ -1449,6 +1449,24 @@ config APRICOT
- To compile this driver as a module, choose M here. The module
- will be called apricot.
-
-+config R6040
-+ tristate "RDC Fast-Ethernet support (EXPERIMENTAL)"
-+ depends on NET_PCI && EXPERIMENTAL
-+ select MII
-+ help
-+ If you have a network (Ethernet) controller of this type, say Y and
-+ read the Ethernet-HOWTO, available from
-+ <http://www.tldp.org/docs.html#howto>.
-+
-+ To compile this driver as a module, choose M here and read
-+ <file:Documentation/networking/net-modules.txt>. The module will be
-+ called r6040.
-+
-+
-+config R6040_NAPI
-+ bool "NAPI support for R6040"
-+ depends on R6040
-+ default y
- config B44
- tristate "Broadcom 440x/47xx ethernet support"
- depends on SSB_POSSIBLE
---- a/drivers/net/Makefile
-+++ b/drivers/net/Makefile
-@@ -116,6 +116,7 @@ obj-$(CONFIG_LNE390) += lne390.o 8390.o
- obj-$(CONFIG_NE3210) += ne3210.o 8390.o
- obj-$(CONFIG_SB1250_MAC) += sb1250-mac.o
- obj-$(CONFIG_B44) += b44.o
-+obj-$(CONFIG_R6040) += r6040.o
- obj-$(CONFIG_FORCEDETH) += forcedeth.o
- obj-$(CONFIG_NE_H8300) += ne-h8300.o
- obj-$(CONFIG_AX88796) += ax88796.o
diff --git a/target/linux/rdc/patches-2.6.24/003-rootfstype.patch b/target/linux/rdc/patches-2.6.24/003-rootfstype.patch
deleted file mode 100644
index 3ad90472a8..0000000000
--- a/target/linux/rdc/patches-2.6.24/003-rootfstype.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/init/do_mounts.c
-+++ b/init/do_mounts.c
-@@ -256,6 +256,8 @@ static void __init get_fs_names(char *pa
- {
- char *s = page;
-
-+ if (!root_fs_names)
-+ root_fs_names = "squashfs,jffs2";
- if (root_fs_names) {
- strcpy(page, root_fs_names);
- while (*s++) {
diff --git a/target/linux/rdc/patches-2.6.24/004-rdc_fixes.patch b/target/linux/rdc/patches-2.6.24/004-rdc_fixes.patch
deleted file mode 100644
index a42e5409c7..0000000000
--- a/target/linux/rdc/patches-2.6.24/004-rdc_fixes.patch
+++ /dev/null
@@ -1,73 +0,0 @@
---- a/arch/x86/Kconfig
-+++ b/arch/x86/Kconfig
-@@ -304,6 +304,17 @@ config X86_VSMP
- supposed to run on these EM64T-based machines. Only choose this option
- if you have one of these machines.
-
-+config X86_RDC
-+ bool "Support for RDC 3211 boards"
-+ select GENERIC_GPIO
-+ select LEDS_GPIO
-+ select LEDS_CLASS
-+ help
-+ Support for RDC 3211 systems. Say 'Y' here if the kernel is
-+ supposed to run on an IA-32 RDC R3211 system.
-+ Only choose this option if you have such as system, otherwise you
-+ should say N here.
-+
- endchoice
-
- config SCHED_NO_NO_OMIT_FRAME_POINTER
---- a/arch/x86/kernel/reboot_fixups_32.c
-+++ b/arch/x86/kernel/reboot_fixups_32.c
-@@ -30,6 +30,17 @@ static void cs5536_warm_reset(struct pci
- udelay(50); /* shouldn't get here but be safe and spin a while */
- }
-
-+static void r8610_reset(struct pci_dev *dev)
-+{
-+ int i;
-+
-+ outl(0x80003840,0xCF8);
-+ i=inl(0xCFC);
-+ i |= 0x1600;
-+ outl(i,0xCFC);
-+ outb(1,0x92);
-+}
-+
- struct device_fixup {
- unsigned int vendor;
- unsigned int device;
-@@ -40,6 +51,7 @@ static struct device_fixup fixups_table[
- { PCI_VENDOR_ID_CYRIX, PCI_DEVICE_ID_CYRIX_5530_LEGACY, cs5530a_warm_reset },
- { PCI_VENDOR_ID_AMD, PCI_DEVICE_ID_AMD_CS5536_ISA, cs5536_warm_reset },
- { PCI_VENDOR_ID_NS, PCI_DEVICE_ID_NS_SC1100_BRIDGE, cs5530a_warm_reset },
-+{ PCI_VENDOR_ID_RDC, PCI_DEVICE_ID_RDC_R6030, r8610_reset },
- };
-
- /*
---- a/arch/x86/Makefile_32
-+++ b/arch/x86/Makefile_32
-@@ -99,6 +99,11 @@ mflags-$(CONFIG_X86_ES7000) := -Iinclude
- mcore-$(CONFIG_X86_ES7000) := arch/x86/mach-default
- core-$(CONFIG_X86_ES7000) := arch/x86/mach-es7000/
-
-+# RDC subarch support
-+mflags-$(CONFIG_X86_RDC) := -Iinclude/asm-x86/mach-rdc
-+mcore-$(CONFIG_X86_RDC) := arch/x86/mach-default
-+core-$(CONFIG_X86_RDC) += arch/x86/mach-rdc/
-+
- # Xen paravirtualization support
- core-$(CONFIG_XEN) += arch/x86/xen/
-
---- a/include/asm-x86/timex.h
-+++ b/include/asm-x86/timex.h
-@@ -7,6 +7,8 @@
-
- #ifdef CONFIG_X86_ELAN
- # define PIT_TICK_RATE 1189200 /* AMD Elan has different frequency! */
-+#elif defined(CONFIG_X86_RDC)
-+# define PIT_TICK_RATE 1041667 /* Underlying HZ for R8610 */
- #else
- # define PIT_TICK_RATE 1193182 /* Underlying HZ */
- #endif
diff --git a/target/linux/rdc/patches-2.6.24/004-yenta_mystery.patch b/target/linux/rdc/patches-2.6.24/004-yenta_mystery.patch
deleted file mode 100644
index 7f202c6c77..0000000000
--- a/target/linux/rdc/patches-2.6.24/004-yenta_mystery.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/drivers/pcmcia/yenta_socket.c
-+++ b/drivers/pcmcia/yenta_socket.c
-@@ -1171,6 +1171,17 @@ static int __devinit yenta_probe (struct
-
- /* We must finish initialization here */
-
-+#ifdef CONFIG_X86_RDC
-+/* #define YO_TI1510_DATASHEET_GUY_EXPLAIN_THIS_JUNK 0x0044f044 */
-+#define YO_TI1510_DATASHEET_GUY_EXPLAIN_THIS_JUNK 0x0844b060
-+/* #define YO_TI1510_DATASHEET_GUY_EXPLAIN_THIS_JUNK 0x0044d044 */
-+
-+ config_writel(socket, 32*4, YO_TI1510_DATASHEET_GUY_EXPLAIN_THIS_JUNK);
-+ config_writel(socket, 35*4, 0x00000022);
-+ config_writel(socket, 36*4, 0x60200000);
-+ config_writel(socket, 40*4, 0x7e020000);
-+#endif
-+
- if (!socket->cb_irq || request_irq(socket->cb_irq, yenta_interrupt, IRQF_SHARED, "yenta", socket)) {
- /* No IRQ or request_irq failed. Poll */
- socket->cb_irq = 0; /* But zero is a valid IRQ number. */
diff --git a/target/linux/rdc/patches-2.6.24/005-cmdline_setup.patch b/target/linux/rdc/patches-2.6.24/005-cmdline_setup.patch
deleted file mode 100644
index 934d36d67e..0000000000
--- a/target/linux/rdc/patches-2.6.24/005-cmdline_setup.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/arch/x86/kernel/setup_32.c
-+++ b/arch/x86/kernel/setup_32.c
-@@ -609,6 +609,7 @@ void __init setup_arch(char **cmdline_p)
- print_memory_map("user");
- }
-
-+ strcat(boot_command_line, " init=/etc/preinit console=ttyS0,38400");
- strlcpy(command_line, boot_command_line, COMMAND_LINE_SIZE);
- *cmdline_p = command_line;
-
diff --git a/target/linux/rdc/patches-2.6.24/005-fix_amit_breakage.patch b/target/linux/rdc/patches-2.6.24/005-fix_amit_breakage.patch
deleted file mode 100644
index 5be29df356..0000000000
--- a/target/linux/rdc/patches-2.6.24/005-fix_amit_breakage.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- a/arch/x86/boot/boot.h
-+++ b/arch/x86/boot/boot.h
-@@ -60,7 +60,7 @@ static inline void outl(u32 v, u16 port)
- {
- asm volatile("outl %0,%1" : : "a" (v), "dN" (port));
- }
--static inline u32 inl(u32 port)
-+static inline u32 inl(u16 port)
- {
- u32 v;
- asm volatile("inl %1,%0" : "=a" (v) : "dN" (port));
---- a/arch/x86/boot/pm.c
-+++ b/arch/x86/boot/pm.c
-@@ -16,6 +16,9 @@
-
- #include "boot.h"
- #include <asm/segment.h>
-+#ifdef CONFIG_X86_RDC
-+#include <asm/mach-rdc/rdc321x_defs.h>
-+#endif
-
- /*
- * Invoke the realmode switch hook if present; otherwise
-@@ -160,6 +163,16 @@ void go_to_protected_mode(void)
- die();
- }
-
-+#ifdef CONFIG_X86_RDC
-+ {
-+ u32 bootctl;
-+
-+ outl(0x80003840, RDC3210_CFGREG_ADDR);
-+ bootctl = inl(RDC3210_CFGREG_DATA) | 0x07ff0000;
-+ outl(bootctl, RDC3210_CFGREG_DATA);
-+ }
-+#endif
-+
- /* Reset coprocessor (IGNNE#) */
- reset_coprocessor();
-
diff --git a/target/linux/rdc/patches-2.6.24/006-pci_ids.patch b/target/linux/rdc/patches-2.6.24/006-pci_ids.patch
deleted file mode 100644
index 96ab2b14e2..0000000000
--- a/target/linux/rdc/patches-2.6.24/006-pci_ids.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/include/linux/pci_ids.h
-+++ b/include/linux/pci_ids.h
-@@ -2106,6 +2106,13 @@
- #define PCI_DEVICE_ID_HERC_WIN 0x5732
- #define PCI_DEVICE_ID_HERC_UNI 0x5832
-
-+#define PCI_VENDOR_ID_RDC 0x17f3
-+#define PCI_DEVICE_ID_RDC_R6020 0x6020
-+#define PCI_DEVICE_ID_RDC_R6030 0x6030
-+#define PCI_DEVICE_ID_RDC_R6040 0x6040
-+#define PCI_DEVICE_ID_RDC_R6060 0x6060
-+#define PCI_DEVICE_ID_RDC_R6061 0x6061
-+
- #define PCI_VENDOR_ID_SITECOM 0x182d
- #define PCI_DEVICE_ID_SITECOM_DC105V2 0x3069
-
diff --git a/target/linux/rdc/patches-2.6.24/600-x86_lzma.patch b/target/linux/rdc/patches-2.6.24/600-x86_lzma.patch
deleted file mode 100644
index 9d94950b5c..0000000000
--- a/target/linux/rdc/patches-2.6.24/600-x86_lzma.patch
+++ /dev/null
@@ -1,62 +0,0 @@
---- a/scripts/Makefile.lib
-+++ b/scripts/Makefile.lib
-@@ -166,4 +166,9 @@ cmd_objcopy = $(OBJCOPY) $(OBJCOPYFLAGS)
- quiet_cmd_gzip = GZIP $@
- cmd_gzip = gzip -f -9 < $< > $@
-
--
-+# LZMA
-+#
-+quiet_cmd_lzma = LZMA $@
-+cmd_lzma = bash -e scripts/lzma_kern $< $@ -lc7 -lp0 -pb0
-+# to use lzmacomp,
-+# cmd_lzma = lzmacomp $< 700 > $@
---- /dev/null
-+++ b/scripts/lzma_kern
-@@ -0,0 +1,4 @@
-+get-size() { echo "$5" ;}
-+printf -v len '%.8x' "$(get-size $(ls -l "$1"))"
-+lzma e "$@"
-+echo -ne "\x$(echo $len | cut -c 7,8)\x$(echo $len | cut -c 5,6)\x$(echo $len | cut -c 3,4)\x$(echo $len | cut -c 1,2)" >> "$2"
---- a/arch/x86/boot/compressed/Makefile_32
-+++ b/arch/x86/boot/compressed/Makefile_32
-@@ -4,8 +4,8 @@
- # create a compressed vmlinux image from the original vmlinux
- #
-
--targets := vmlinux vmlinux.bin vmlinux.bin.gz head_32.o misc_32.o piggy.o \
-- vmlinux.bin.all vmlinux.relocs
-+targets := vmlinux vmlinux.bin vmlinux.bin.lzma head_32.o piggy.o \
-+ vmlinux.bin.all vmlinux.relocs lzma_misc.o
- EXTRA_AFLAGS := -traditional
-
- LDFLAGS_vmlinux := -T
-@@ -17,7 +17,7 @@ KBUILD_CFLAGS := -m32 -D__KERNEL__ $(LI
- $(call cc-option,-fno-stack-protector)
- LDFLAGS := -m elf_i386
-
--$(obj)/vmlinux: $(src)/vmlinux_32.lds $(obj)/head_32.o $(obj)/misc_32.o $(obj)/piggy.o FORCE
-+$(obj)/vmlinux: $(src)/vmlinux_32.lds $(obj)/head_32.o $(obj)/lzma_misc.o $(obj)/piggy.o FORCE
- $(call if_changed,ld)
- @:
-
-@@ -37,14 +37,14 @@ $(obj)/vmlinux.bin.all: $(vmlinux.bin.al
- $(call if_changed,relocbin)
-
- ifdef CONFIG_RELOCATABLE
--$(obj)/vmlinux.bin.gz: $(obj)/vmlinux.bin.all FORCE
-- $(call if_changed,gzip)
-+$(obj)/vmlinux.bin.lzma: $(obj)/vmlinux.bin.all FORCE
-+ $(call if_changed,lzma)
- else
--$(obj)/vmlinux.bin.gz: $(obj)/vmlinux.bin FORCE
-- $(call if_changed,gzip)
-+$(obj)/vmlinux.bin.lzma: $(obj)/vmlinux.bin FORCE
-+ $(call if_changed,lzma)
- endif
-
- LDFLAGS_piggy.o := -r --format binary --oformat elf32-i386 -T
-
--$(obj)/piggy.o: $(src)/vmlinux_32.scr $(obj)/vmlinux.bin.gz FORCE
-+$(obj)/piggy.o: $(src)/vmlinux_32.scr $(obj)/vmlinux.bin.lzma FORCE
- $(call if_changed,ld)