summaryrefslogtreecommitdiffstats
path: root/target/linux/rdc-2.6
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/rdc-2.6')
-rw-r--r--target/linux/rdc-2.6/Makefile4
-rw-r--r--target/linux/rdc-2.6/config/default2
-rw-r--r--target/linux/rdc-2.6/profiles/AR525W.mk2
-rw-r--r--target/linux/rdc-2.6/profiles/WL-153.mk2
4 files changed, 7 insertions, 3 deletions
diff --git a/target/linux/rdc-2.6/Makefile b/target/linux/rdc-2.6/Makefile
index bf096f2422..1b180cd41e 100644
--- a/target/linux/rdc-2.6/Makefile
+++ b/target/linux/rdc-2.6/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
ARCH:=i386
BOARD:=rdc
BOARDNAME:=RDC x86
-FEATURES:=squashfs jffs2 broken
+FEATURES:=squashfs jffs2
LINUX_VERSION:=2.6.22.1
@@ -22,10 +22,12 @@ include $(INCLUDE_DIR)/kernel-build.mk
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
define Kernel/SetInitramfs
+ echo "r6040 parent=wlan0" > $(BUILD_DIR)/root/etc/modules.d/99-r6040
rm -f $(BUILD_DIR)/root/sbin/init
ln -s /etc/preinit $(BUILD_DIR)/root/sbin/init
sed -i 's,exec /sbin/init,exec /bin/busybox init,g' $(BUILD_DIR)/root/etc/preinit
sed -i 's,/sbin/init,/bin/busybox init,g' $(BUILD_DIR)/root/init
+ sed -i 's,eth0,eth1,g' $(BUILD_DIR)/root/etc/config/network
endef
endif
diff --git a/target/linux/rdc-2.6/config/default b/target/linux/rdc-2.6/config/default
index c28d44b456..b0990e42e2 100644
--- a/target/linux/rdc-2.6/config/default
+++ b/target/linux/rdc-2.6/config/default
@@ -27,10 +27,12 @@ CONFIG_CLOCKSOURCE_WATCHDOG=y
# CONFIG_COMPAT_VDSO is not set
# CONFIG_CPU5_WDT is not set
# CONFIG_CPU_FREQ is not set
+CONFIG_CRC_ITU_T=y
CONFIG_CRYPTO_AES_586=m
CONFIG_CRYPTO_ARC4=y
CONFIG_CRYPTO_DEV_GEODE=m
# CONFIG_CRYPTO_DEV_PADLOCK is not set
+CONFIG_CRYPTO_ECB=y
CONFIG_CRYPTO_TWOFISH_586=m
# CONFIG_CS5535_GPIO is not set
# CONFIG_DCDBAS is not set
diff --git a/target/linux/rdc-2.6/profiles/AR525W.mk b/target/linux/rdc-2.6/profiles/AR525W.mk
index 847607e8c5..5c01554d43 100644
--- a/target/linux/rdc-2.6/profiles/AR525W.mk
+++ b/target/linux/rdc-2.6/profiles/AR525W.mk
@@ -7,7 +7,7 @@
define Profile/ar525w
NAME:=AirLink101 AR525W
- PACKAGES:=kmod-rt61 kmod-r6040
+ PACKAGES:=kmod-rt61-pci kmod-r6040
endef
$(eval $(call Profile,ar525w))
diff --git a/target/linux/rdc-2.6/profiles/WL-153.mk b/target/linux/rdc-2.6/profiles/WL-153.mk
index 8a9489421b..f030455b2d 100644
--- a/target/linux/rdc-2.6/profiles/WL-153.mk
+++ b/target/linux/rdc-2.6/profiles/WL-153.mk
@@ -7,7 +7,7 @@
define Profile/wl153
NAME:=Sitecom WL-153
- PACKAGES:=kmod-rt61 kmod-r6040
+ PACKAGES:=kmod-rt61-pci kmod-r6040
endef
$(eval $(call Profile,wl153))